Closed Bug 1574515 Opened 5 months ago Closed 5 months ago

Perma gtest | timed out after 300 seconds without output

Categories

(Core :: Audio/Video: GMP, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=261940846&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/d1t5HUQ6SquaG_mHh8AQnw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-16T04:53:50.026Z] 04:53:50 INFO - TEST-START | XPCOMDeadlockDetectorTest.XPCOMSanityDeathTest
[task 2019-08-16T04:53:50.179Z] 04:53:50 INFO - Running GTest tests...
[task 2019-08-16T04:58:50.344Z] 04:58:50 ERROR - gtest TEST-UNEXPECTED-FAIL | gtest | timed out after 300 seconds without output
[task 2019-08-16T04:58:50.501Z] 04:58:50 ERROR - Return code: 1
[task 2019-08-16T04:58:50.501Z] 04:58:50 ERROR - No tests run or test summary not found
[task 2019-08-16T04:58:50.502Z] 04:58:50 INFO - TinderboxPrint: gtest-gtest<br/><em class="testfail">T-FAIL</em>
[task 2019-08-16T04:58:50.502Z] 04:58:50 ERROR - # TBPL FAILURE #
[task 2019-08-16T04:58:50.502Z] 04:58:50 WARNING - setting return code to 2
[task 2019-08-16T04:58:50.502Z] 04:58:50 ERROR - The gtest suite: gtest ran with return status: FAILURE
[task 2019-08-16T04:58:50.502Z] 04:58:50 INFO - Running post-action listener: _package_coverage_data
[task 2019-08-16T04:58:50.502Z] 04:58:50 INFO - Running post-action listener: _resource_record_post_action
[task 2019-08-16T04:58:50.502Z] 04:58:50 INFO - Running post-action listener: process_java_coverage_data
[task 2019-08-16T04:58:50.503Z] 04:58:50 INFO - [mozharness: 2019-08-16 04:58:50.502959Z] Finished run-tests step (success)
[task 2019-08-16T04:58:50.503Z] 04:58:50 INFO - Running post-run listener: _resource_record_post_run
[task 2019-08-16T04:58:50.609Z] 04:58:50 INFO - instance_metadata.json not found; unable to determine instance type
[task 2019-08-16T04:58:50.611Z] 04:58:50 INFO - Validating Perfherder data against /Users/cltbld/tasks/task_1565924112/mozharness/external_tools/performance-artifact-schema.json

Could you please take a look at this?

Flags: needinfo?(nfroyd)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #2)

From bug 1573160?

Very unlikely, since XPCOMDeadlockDetectorTest doesn't use thread pools.

We wound up disabling this test in bug 1473531 for osx ccov builds...maybe this is another manifestation of the same problem?

Flags: needinfo?(nfroyd)

It does look like bug 1035892 might cause problems in this area:

https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=2b1ffc8004d5e8160bc5bb1109c9f67a003048ef&selectedJob=262071175

Or it's possible that something prior to that landing might have triggered the perma-failure?

It's the first time I look at that particular test. It's disabling the crash reporter so maybe it interacts with my changes but I really don't know how. I'll try and test it locally ASAP.

Additional note: I don't have access to my Mac right now but I'll have it on Wednesday so that's the earliest I can look into this.

Backed out bug 1035892 for now.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Flags: needinfo?(gsvelto)
You need to log in before you can comment on or make changes to this bug.