Closed Bug 1575014 Opened 5 months ago Closed 4 months ago

`./mach try ... --gecko-profile` results in InterpreterError: infix: [..] expects integer [..] integer

Categories

(Testing :: Raptor, defect, P1)

Version 3
defect

Tracking

(firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: nalexander, Assigned: nalexander)

References

Details

Attachments

(1 file)

An error crept in, resulting in:

[task ...] InterpreterError: InterpreterError: infix: [..] expects integer [..] integer

At some point, suite became a string name and not an object with a string name member.

Spinning this out of Bug 1573208.

An error crept in, resulting in:

[task ...] InterpreterError: InterpreterError: infix: [..] expects integer [..] integer

At some point, suite became a string name and not an object with a
string name member.

Depends on D41602

Priority: -- → P1

Is this ready to land?

Assignee: nobody → nalexander
Status: NEW → ASSIGNED
Flags: needinfo?(nalexander)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚BST from comment #3)

Is this ready to land?

The patch fixes the issue (I think?), but doesn't fix the tests. Push to try and the failure will arise.

Flags: needinfo?(nalexander)

Just posting here to confirm that this patch worked for me. https://treeherder.mozilla.org/#/jobs?repo=try&revision=028ce072745b896e7f7b2170c475160e0ad62ed3 got past the decision task and successfully uploaded the profiles.

Duplicate of this bug: 1583119

I will take this ticket, since I want to do the equivalent for browsertime and it's in the same area (Bug 1583652). Just trying to find the test failures now, in fact!

(In reply to Nick Alexander :nalexander [he/him] from comment #7)

I will take this ticket, since I want to do the equivalent for browsertime and it's in the same area (Bug 1583652). Just trying to find the test failures now, in fact!

For the record, it was a tg task and the failure is:

0:27.78 taskcluster/taskgraph/test/test_morph.py::test_template_gecko_profile[command0] TEST-UNEXPECTED-FAIL
0:27.78 taskcluster/taskgraph/test/test_morph.py::test_template_gecko_profile[command1] TEST-UNEXPECTED-FAIL
0:27.78 taskcluster/taskgraph/test/test_morph.py::test_template_gecko_profile[command2] TEST-UNEXPECTED-FAIL
0:27.78 taskcluster/taskgraph/test/test_morph.py::test_template_gecko_profile[command3] TEST-UNEXPECTED-FAIL

Try build percolating: https://treeherder.mozilla.org/#/jobs?repo=try&revision=c7667300800b860014556682f80bdeb555f9da9c.

I don't think this requires re-review so I'll land if it's green.

tomprince: sorry to put this back in your queue, but it ended up needing a totally different approach (see the commit comment) and needs re-review.

Try build percolating at https://treeherder.mozilla.org/#/jobs?repo=try&revision=1b7f6d11b2731c4bb5abb15a8e8f5313c0f506ef.

Flags: needinfo?(mozilla)

(In reply to Nick Alexander :nalexander [he/him] from comment #10)

tomprince: sorry to put this back in your queue, but it ended up needing a totally different approach (see the commit comment) and needs re-review.

(Note: that one of the phabricator actions is re-requesting review, which is available even if it has been accepted)

Flags: needinfo?(mozilla)
Pushed by nalexander@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6282465f1188
Fix `./mach try --gecko-profile ...`. r=tomprince,ahal
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.