Closed Bug 1575513 Opened 2 months ago Closed 2 months ago

Hyphenation of German words is buggy in Firefox 68.0.2 on MacOS

Categories

(Core :: Layout: Text and Fonts, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1557291
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- affected
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: polarbirke, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36

Steps to reproduce:

I noticed that a hyphenation polyfill we use is surprisingly activating in current Firefox after its feature detection determines that Firefox does not support CSS hyphens support for German.

I have built a tiny test case with German words that should be hyphenated via CSS hyphens: auto; here: https://codepen.io/polarbirke/pen/JjPRgqr.

I could verify that the test case works correctly in the (outdated) Firefox 64.0a1 Nightly I have installed (see attachment), so this looks like a regression.

Actual results:

Firefox 68.0.2 does not hyphenate words like "Silbentrennung" or "Deutschland".

Expected results:

The words should have been hyphenated (see attachment).

Summary: Hyphenation of German words is buggy in Firefox 68.02 on MacOS → Hyphenation of German words is buggy in Firefox 68.0.2 on MacOS
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Layout: Text and Fonts
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Regressed by: 1550532

It happens only on Uppercase words, and it's fixed in 69. In the meantime, you can work around by adding a boolean pref intl.hyphenate-capitalized.de set to true in about:config.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1557291

Thanks for the heads-up!

You need to log in before you can comment on or make changes to this bug.