Closed Bug 1575820 Opened 4 months ago Closed 3 months ago

The "First Run Triplets" are not displayed on the first tab opened after logging in to "Firefox Sync"

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.1 - Sept 2 - 15
Tracking Status
firefox68 --- unaffected
firefox69 --- wontfix
firefox70 + verified
firefox71 --- verified

People

(Reporter: mcoman, Assigned: pdahiya)

References

Details

(Keywords: github-merged)

Attachments

(3 files)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Beta 69.0b15 - Build ID: 20190819184224
  • Firefox Nightly 70.0a1 - Build ID: 20190821215524

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have a new Firefox profile;
  • Have valid FxA credentials.
  • You are not logged in to "Firefox Sync".

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites and click the "Firefox Account" toolbar button.
  2. Click the "Turn on Sync..." button and enter your credentials.
  3. Open a "New Tab" and observe the behavior.

[Expected result]:

  • The page is successfully opened and the "First Run Triplets" are displayed at the top of the page.

[Actual result]:

  • The "First Run Triplets" are not displayed at all.

[Notes]:

  • The "First Run Triplets" will be displayed again on the next opened tab.
  • Attached a screen recording of the issue.
Iteration: --- → 71.1 - Sept 2 - 15
Priority: -- → P1
Assignee: nobody → pdahiya
Blocks: 1579949

[Tracking Requested - why for this release]: "First Run Triplets" are not displayed on the first tab and previously opened tab after logging in to "Firefox Sync"

Status: NEW → RESOLVED
Closed: 3 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (71.0a1 Build ID - 20190911095413) installed, on Windows 10 x64, Arch Linux and Mac 10.14.6. Now, the "First Run Triplets" are successfully displayed on the first tab opened after logging in to "Firefox Sync".

Status: RESOLVED → VERIFIED

Can you request uplift to beta?

Flags: needinfo?(pdahiya)

Comment on attachment 9092234 [details]
Bug 1575820 - The "First Run Triplets" are not displayed on the first tab opened after logging in to "Firefox Sync"

Beta/Release Uplift Approval Request

  • User impact if declined: After sync successful login, user will not see triplet cars on first opened and existing open new tabs.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See #comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch that's verified in nightly by QA
  • String changes made/needed: None
Flags: needinfo?(pdahiya)
Attachment #9092234 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9092234 [details]
Bug 1575820 - The "First Run Triplets" are not displayed on the first tab opened after logging in to "Firefox Sync"

Let's uplift for beta 7; sounds like we should show these cards to sync users too when this was launched in 69.

Attachment #9092234 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that this issue is no longer reproducible with the latest Firefox Beta (70.0b7 Build ID - 20190916074538) installed, on Windows 10 x64, Arch Linux and Mac 10.14.6. Now, the "First Run Triplets" are successfully displayed on the first tab opened after logging in to "Firefox Sync".

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.