Closed Bug 1576115 Opened 1 year ago Closed 3 months ago

xpcshell debugging is broken when setting devtools.browsertoolbox.fission to true

Categories

(DevTools :: Framework, defect, P1)

defect

Tracking

(Fission Milestone:M5, firefox72 fixed)

RESOLVED FIXED
Firefox 72
Fission Milestone M5
Tracking Status
firefox72 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission dt-fission-m1)

Attachments

(1 file)

On the client side, we get this error:

console.error: "Protocol error (noProcesses): This root actor has no processes."

Which comes from the server side:
https://searchfox.org/mozilla-central/source/devtools/server/actors/root.js#547-554

Priority: -- → P3
Whiteboard: dt-fission
Whiteboard: dt-fission → dt-fission-reserve
No longer blocks: dt-fission

Here is an updated, fixed revision URL:
https://searchfox.org/mozilla-central/rev/d061ba55ac76f41129618d638f4ef674303ec103/devtools/server/actors/root.js#529-533

The STR looks like this:

  • ./mach xpcshell-test devtools/server/tests/unit/test_client_request.js --jsdebugger
  • open another firefox
  • open about:debugging
  • connect to localhost:6000
  • scroll down and inspect the "Main process"

ER: you can debug the xpcshell test

AR: the toolbox opened from about:debugging is empty and you see comment 0 exception in stdout.

You may find an even nicier STR in bug 1594507 comment 0 :)

Blocks: 1588050

With Fission, we expect RootActor.listProcesses to return a list of all process actors.

Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Priority: P3 → P1
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eec2b47cdc07
Expose processes from xpcshell test DebuggerServer. r=jdescottes
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M5
Duplicate of this bug: 1594507
Whiteboard: dt-fission-reserve → dt-fission
Flags: qe-verify+
QA Contact: vlad.lucaci
Whiteboard: dt-fission → dt-fission dt-fission-m1
You need to log in before you can comment on or make changes to this bug.