Closed Bug 1576126 Opened 1 year ago Closed 1 year ago

Port |Bug 961529 - Add Feeds module| to SeaMonkey

Categories

(SeaMonkey :: Feed Discovery and Preview, task)

task
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

Port the following:
Bug 961529 - Add Feeds module
Parts of Bug 1144493 - wallpaper over enough cracks to make page info work with e10s
Parts of Bug 1165272 - Part 2: Replace getNoAppCodebasePrincipal
Bug 1233895 - Make Feeds.jsm properly handle principal origin attributes when loading subresources
Bug 1375243 - Explicitly create a URI object to avoid sync URI fixups from the content process
Bug 1440284 - change this.EXPORTED_SYMBOLS back to var EXPORTED_SYMBOLS in JS modules

Attached patch Add Feeds ModuleSplinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Nothing
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Changes in this patch are needed by next version of patch going on Bug 1575201

Attachment #9087699 - Flags: review?(frgrahl)
Attachment #9087699 - Flags: approval-comm-release?
Attachment #9087699 - Flags: approval-comm-esr60?
Comment on attachment 9087699 [details] [diff] [review]
Add Feeds Module

lgtm
r/a=me
Attachment #9087699 - Flags: review?(frgrahl)
Attachment #9087699 - Flags: review+
Attachment #9087699 - Flags: approval-comm-release?
Attachment #9087699 - Flags: approval-comm-release+
Attachment #9087699 - Flags: approval-comm-esr60?
Attachment #9087699 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/f4394597a1cd
Port Bug 961529 "Add Feeds module" to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.