Closed Bug 1576272 Opened 4 months ago Closed 3 months ago

about:logins loaded with a prepopulated filter to a site with no saved logins shows an unusable screen

Categories

(Firefox :: about:logins, defect, P2)

70 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: ntim, Assigned: jaws)

References

(Regressed 1 open bug)

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(3 files)

Attached image image.png

STR: Visit about:logins?filter=kdskdsfjhskdjfhlksdaflkadsfasdkjlfsdlkfjasdasfsdfsda

Summary: about:logins?filter=kdskdsfjhskdjfhlksdaflkadsfasdkjlfsdlkfjasd shows strange screen → about:logins loaded with a prepopulated filter to a site with no saved logins shows an unusable screen
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2a533696457
Show the empty-search results view of about:logins if the page is opened with a filter that doesn't match any stored logins. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Can you request uplift? Thanks!

Flags: qe-verify+
Flags: needinfo?(jaws)
Regressions: 1579825

I have verified this issue on the latest Nightly 71.0a1 (2019-09-08) build on Windows 7 x64, Mac 10.14 and Ubuntu 16.04 x64.
Now if you navigate to "about:logins" page using a prepopulated filter like in the example provided in comment 0, the following behavior can be observed:

  • The "No logins found" message is displayed in the "Login List".
  • The "Looking for your saved logins? Set up Sync." page is displayed.

Even if you have other saved logins the "Looking for your saved logins? Set up Sync." page is displayed. From the QA point of view, this might be confusing for the users since they already have other saved logins but the "Looking for your saved logins? Set up Sync." message is displayed. Shouldn't be displayed a different message if the filter returns 0 results? Based on the mock-ups a blank page is displayed if the search returns 0 results.

Attached a screen recording with this behavior.

The behavior you are seeing was intended by the patch on this bug. Can you please file a bug about showing a blank screen and we can discuss if we want to move forward with that in the new bug?

Flags: needinfo?(jaws) → needinfo?(cosmin.muntean)

Thanks, Jared! I have logged the described behavior in bug 1579852.

Based on comment 5 and comment 6, I will mark this issue as Verified - Fixed.

Status: RESOLVED → VERIFIED
Flags: needinfo?(cosmin.muntean)

Happy to take this on beta, can you request uplift? Thanks!

Flags: needinfo?(jaws)

Comment on attachment 9089442 [details]
Bug 1576272 - Show the empty-search results view of about:logins if the page is opened with a filter that doesn't match any stored logins. r?MattN

Beta/Release Uplift Approval Request

  • User impact if declined: Users who use the "view saved logins" button in the context menu of login forms on websites may end up with an unusable about:logins page
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): This changes how filters are applied to the page. The change is covered by automated tests and has been verified by QA.
  • String changes made/needed: none
Flags: needinfo?(jaws)
Attachment #9089442 - Flags: approval-mozilla-beta?
QA Whiteboard: [qa-triaged]

Comment on attachment 9089442 [details]
Bug 1576272 - Show the empty-search results view of about:logins if the page is opened with a filter that doesn't match any stored logins. r?MattN

Fix for about:logins in particular situations, helpful for skyline quality.
OK for beta uplift.

Attachment #9089442 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified this issue and is no longer reproducible on the latest Firefox Beta 70.0b6 build on Windows 10 x64, Windows 7 x64, Mac 10.14 and Arch Linux 4.14.

Flags: qe-verify+
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Version: unspecified → 70 Branch
You need to log in before you can comment on or make changes to this bug.