Closed Bug 1576686 Opened 1 year ago Closed 1 year ago

Perma fission devtools/server/tests/browser/browser_storage_dynamic_windows.js | Test timed out -

Categories

(DevTools :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1576316

People

(Reporter: kashav, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=263279115&repo=autoland&lineNumber=7770

https://taskcluster-artifacts.net/FNvhXLPyQi-bofzSPHR75g/0/public/logs/live_backing.log

[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | indexedDB storage actor is present - 
[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Number of hosts for indexedDB match - 
[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Host http://test1.example.org is present - 
[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Host http://sectest1.example.org is present - 
[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | localStorage storage actor is present - 
[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Number of hosts for localStorage match - 
[task 2019-08-24T00:34:56.437Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Host http://test1.example.org is present - 
[task 2019-08-24T00:34:56.438Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Host http://sectest1.example.org is present - 
[task 2019-08-24T00:34:56.438Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | sessionStorage storage actor is present - 
[task 2019-08-24T00:34:56.438Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Number of hosts for sessionStorage match - 
[task 2019-08-24T00:34:56.438Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Host http://test1.example.org is present - 
[task 2019-08-24T00:34:56.438Z] 00:34:56     INFO - TEST-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Host http://sectest1.example.org is present - 
[task 2019-08-24T00:34:56.440Z] 00:34:56     INFO - Testing if new iframe addition works properly
[task 2019-08-24T00:34:56.440Z] 00:34:56     INFO - Console message: [JavaScript Error: "TypeError: localStorage is null" {file: "https://sectest1.example.org/browser/devtools/server/tests/browser/storage-secured-iframe.html" line: 13}]
[task 2019-08-24T00:34:56.441Z] 00:34:56     INFO - @https://sectest1.example.org/browser/devtools/server/tests/browser/storage-secured-iframe.html:13:1
[task 2019-08-24T00:34:56.441Z] 00:34:56     INFO - 
[task 2019-08-24T00:34:56.441Z] 00:34:56     INFO - Buffered messages finished
[task 2019-08-24T00:34:56.441Z] 00:34:56     INFO - TEST-UNEXPECTED-FAIL | devtools/server/tests/browser/browser_storage_dynamic_windows.js | Test timed out - 
[task 2019-08-24T00:34:56.442Z] 00:34:56     INFO - Removing tab.
[task 2019-08-24T00:34:56.443Z] 00:34:56     INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-08-24T00:34:56.443Z] 00:34:56     INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-08-24T00:34:56.444Z] 00:34:56     INFO - Tab removed and finished closing
[task 2019-08-24T00:34:56.444Z] 00:34:56     INFO - GECKO(5294) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-08-24T00:34:56.444Z] 00:34:56     INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-08-24T00:34:56.445Z] 00:34:56     INFO - TEST-UNEXPECTED-PASS | devtools/server/tests/browser/browser_storage_dynamic_windows.js | We expect at least one assertion to fail because this test file is marked as fail-if in the manifest. - 
[task 2019-08-24T00:34:56.445Z] 00:34:56     INFO - TEST-INFO | expected FAIL
[task 2019-08-24T00:34:56.446Z] 00:34:56     INFO - GECKO(5294) | MEMORY STAT | vsize 3223MB | residentFast 424MB | heapAllocated 229MB
[task 2019-08-24T00:34:56.447Z] 00:34:56     INFO - TEST-OK | devtools/server/tests/browser/browser_storage_dynamic_windows.js | took 45159ms

This was probably regressed by bug 1562264.

Priority: -- → P3

FWIW this passes locally in my tree which has the fix for bug 1576316 applied.

Assignee: nobody → ehsan
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576316
You need to log in before you can comment on or make changes to this bug.