Closed Bug 1576864 Opened 3 months ago Closed 3 months ago

Absolutely positioned fieldset does not render height changes

Categories

(Core :: Layout: Positioned, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1351924

People

(Reporter: ajp, Unassigned)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/18.17763

Steps to reproduce:

Set an absolutely positioned fieldset via javascript and the height updates are not rendered unless/until the width is changed.

https://jsfiddle.net/AdamPoole/taqvrbm5
Click the "height +" button several times then click "width +" button

firefox v68.0.2

Actual results:

No visible response to "height +" clicks. Inspecting the element we see the style is updated on each click. When "width +" clicked the fieldset is rendered with the new height and width.

Expected results:

Each button click should result in a change to the fieldset's size. This is true if the element is positioned relative.

Component: Untriaged → Layout: Positioned
Product: Firefox → Core

Good news, this is already fixed :)

Mozregression says: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d6eed298a41b1536a7f8624a5a4728847ac0b77a&tochange=7d9b5d8c9b9b36b135237292785537fc13f40226

It looks p. plausible that bug 1351924 fixed this. David, do you think a test-case for this particular issue is worth it on top of the tests landed in that bug?

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Flags: needinfo?(dbaron)
Resolution: --- → DUPLICATE
Duplicate of bug: 1351924

(Given that this was fixed quite a while ago, I didn't actually test
this in the reftest harness prior to the patch, but I did check that the
testcase fails in the browser on Firefox 68 release.)

(Oops, ran more tests than I intended by using the wrong --index to mach try again.)

Flags: needinfo?(dbaron)

Note: Like dupe-target-bug 1351924's main patch, we backed this out on beta. (See bug 1586175 for more details)

You need to log in before you can comment on or make changes to this bug.