Closed Bug 1577437 Opened 2 years ago Closed 11 months ago

Safe mode "Disable all add-ons" checkbox + "Make Changes and Restart" button doesn't work

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(thunderbird_esr60 wontfix, thunderbird_esr68? affected, thunderbird60 wontfix, thunderbird68 wontfix, thunderbird69 wontfix, thunderbird70 wontfix, thunderbird76 wontfix, thunderbird77 affected, thunderbird78 affected)

RESOLVED FIXED
Thunderbird 78.0
Tracking Status
thunderbird_esr60 --- wontfix
thunderbird_esr68 ? affected
thunderbird60 --- wontfix
thunderbird68 --- wontfix
thunderbird69 --- wontfix
thunderbird70 --- wontfix
thunderbird76 --- wontfix
thunderbird77 --- affected
thunderbird78 --- affected

People

(Reporter: andysem, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. In "Help -> Troubleshooting Information", click "Restart with addons disabled".
  2. Upon restart, Thunderbird Safe Mode window appears. There, check the "Disable all addons" checkbox.
  3. Try clicking on the "Make Changes and Restart" button.

Actual results:

The button, although not greyed out, cannot be pressed. Nothing happens when I click on it.

Expected results:

The button should work.

Confirmed.

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true

This is a little concerning that a primary debug tool is broken.

Benjamin, are you also able to reproduce this on Windows? (I was not)

Blocks: tb68found
Flags: needinfo?(benjamin)

I confirm the issue for TB 68.0.
But the same issue already is present in TB60.8.0.

I tested this in Thunderbird 69.0b4 on Ubuntu 18.04.3 LTS.
Selected "Toolbars and Controls" instead of "Disable all add-ons" and the "Make Changes and Restart" button worked for me.
Restored me backed up profile and got all my toolbar and control settings back.

Not working in TB 60 either. Comment #3 and comment #4 are correct.

Summary: Safe mode "Make Changes and Restart" doesn't work → Safe mode "Disable all add-ons" + "Make Changes and Restart" doesn't work
Version: 68 → 60

I just tried this on Windows using Thunderbird 69.0b4. The interface works as expected.

Flags: needinfo?(benjamin)

It doesn't.

STR:
Help > Restart with add-ons disabled
Restart
Click" Disable all add-ons"
Click button "Make Changes and Restart

Nothing happens.

Ah, I clicked the wrong button, need to slow down and be more observant.

I see the same using TB 70.0a1.

Nothing in error console?

Summary: Safe mode "Disable all add-ons" + "Make Changes and Restart" doesn't work → Safe mode "Disable all add-ons" checkbox + "Make Changes and Restart" button doesn't work

The only console output I see is:

WebGL(0x7f234cdba000)::ForceLoseContext
WebGL(0x7f234cdbf800)::ForceLoseContext

If there is some other kind of console, please tell how to capture its output.

andysem,
Still see this in a current beta?

FWIW I found no other reports of this. https://mzl.la/3amOGpV

I can still reproduce this bug in TB 76.0b1.

Flags: needinfo?(andysem)

(In reply to Eckard Berberich from comment #13)

I can still reproduce this bug in TB 76.0b1.

So can I using 76.0b1 and 77.0a1 on Linux.

NI Magnus to assign dev

Flags: needinfo?(mkmelin+mozilla)
Component: General → Mail Window Front End

AddonManager.getAllAddons doesn't take a callback, so nothing happens...

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)
Attachment #9153137 - Flags: review?(paul)
Comment on attachment 9153137 [details] [diff] [review]
bug1577437_safemode.patch

Review of attachment 9153137 [details] [diff] [review]:
-----------------------------------------------------------------

Changes look good.  I've tested with and without the patch and found that it fixes the problem. (Tested on Linux with current trunk build.)
Attachment #9153137 - Flags: review?(paul) → review+

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5cefc4c79165
fix "Make Changes and Reset" - AddonManager.getAllAddons doesn't use a callback anymore. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 78.0
You need to log in before you can comment on or make changes to this bug.