Closed Bug 1577443 Opened 9 months ago Closed 9 months ago

Remove cmd_checkLinks that is unused

Categories

(SeaMonkey :: Composer, enhancement)

SeaMonkey 2.67
Unspecified
All
enhancement
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: m_kato, Assigned: iann_bugzilla)

References

Details

Attachments

(3 files, 1 obsolete file)

https://searchfox.org/comm-central/search?q=cmd_checkLinks&path=

cmd_checkLinks seems not to use in Thunderbird and SeaMonkey. Although debugQAEditorOverlay.xul has menu for this command, this is debugging tools.

This is only user of nsIHTMLEditor.getLinkedObjects that is unused by Firefox. So I hope that cmd_checkLinks is removed since it is unused since I would like to remove nsIHTMLEditor.getLinkedObjects from Gecko.

Ian, is cmd_checkLinks still needed? This seems to be used on debugQA extension only. Although this command uses nsIHTMLEditor.getLinkedObjects method, it isn't used in Firefox and I would like to remove this method from Gecko.

Flags: needinfo?(iann_bugzilla)

I think it can be removed. It is a debugging help for Composer but seems to do nothing.

As cmd_checkLinks also relies on URIChecker which was removed in Bug 1222829 (in Gecko 45 around 4 years ago and spotted by me a year later), I'm fairly sure that nsIHTMLEditor.getLinkedObjects method can be removed.

Flags: needinfo?(iann_bugzilla)
Attached patch Remove checkLinks for cc (obsolete) — Splinter Review

Patch for comm-central that doesn't remove l10n

Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #9089457 - Flags: review?(frgrahl)
Attachment #9089457 - Attachment description: 1577443_remove_checkLinks_cc.patch → Remove checkLinks for cc

Patch for SM 2.57, does have l10n string removal

Attachment #9089460 - Flags: review?(frgrahl)
Attachment #9089460 - Flags: approval-comm-esr60?

[Approval Request Comment]
Regression caused by (bug #): 1222829
User impact if declined: None, doesn't work anyway
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: One string removal and one dtd file removal

Attachment #9089463 - Flags: review?(frgrahl)
Attachment #9089463 - Flags: approval-comm-release?

Include l10n removals as requested

Attachment #9089457 - Attachment is obsolete: true
Attachment #9089457 - Flags: review?(frgrahl)
Attachment #9089553 - Flags: review?(frgrahl)
Comment on attachment 9089553 [details] [diff] [review]
Remove checkLinks for cc v1.1

And away it goes
Attachment #9089553 - Flags: review?(frgrahl) → review+
Comment on attachment 9089463 [details] [diff] [review]
Remove checkLinks for 2.53

r/a=me
Attachment #9089463 - Flags: review?(frgrahl)
Attachment #9089463 - Flags: review+
Attachment #9089463 - Flags: approval-comm-release?
Attachment #9089463 - Flags: approval-comm-release+
Comment on attachment 9089460 [details] [diff] [review]
Remove checkLinks for 2.57

r/a=me.
Attachment #9089460 - Flags: review?(frgrahl)
Attachment #9089460 - Flags: review+
Attachment #9089460 - Flags: approval-comm-esr60?
Attachment #9089460 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/429123f68201
Remove cmd_checkLinks that is unused. r=frg DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Fixed. Pushed with DONT BUILD all suite code (composer).
https://hg.mozilla.org/releases/comm-esr60/rev/c773e2fef6cab3d26aaf46c31e6789cfd6f75a22

Version: unspecified → SeaMonkey 2.67
Duplicate of this bug: 1485225
You need to log in before you can comment on or make changes to this bug.