Open Bug 1577474 Opened 1 year ago Updated 1 year ago

Shortcut modifier order is not consistent

Categories

(WebExtensions :: Frontend, defect, P3)

70 Branch
All
Unspecified
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: mcurtean, Unassigned)

Details

(Keywords: polish)

Attachments

(1 file)

[Affected versions]:

Firefox 70.0a1 20190828214452
[Affected platforms]:

Win 10 64-bit
Ubuntu 18.04.2 LTS x 64 bit
MACos High Sierra 10.13.6
[Steps to reproduce]:

Install add-ons:
https://addons.mozilla.org/en-US/firefox/addon/bookmark-shortcuts/
https://addons.mozilla.org/en-US/firefox/addon/webext-private-bookmarks/
https://addons.mozilla.org/en-US/firefox/addon/darkreader/
https://addons.mozilla.org/en-US/firefox/addon/default-bookmark-folder/?src=search
https://addons.mozilla.org/en-US/firefox/addon/measure-it/
Navigate to Extensions from about:addons page.
Click on the wheel button and from the drop down menu select the "Manage extension shortcuts" option.
In the "Manage extension shortcuts" section view the duplicate shortcut warnings.
Try to resolve the warnings in order by finding and modifying the extensions shortcuts.

[Expected results]:
The shortcut keys order in the individual warning message is identical with the shortcut keys order used on the extension shortcut fields.

[Actual results]:
The shortcuts in the warnings are not identical with the ones used in the extension shortcut fields. For example "ALT+SHIFT+D" warning is resolved by changing one of the "SHIFT+ALT+D" extension shortcuts.

Please see the attached GIF.

Note: This issue does not occur in the case of other shortkey combinations.

Keywords: polish
Priority: -- → P3
Flags: needinfo?(mstriemer)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mstriemer)
Resolution: --- → DUPLICATE
Duplicate of bug: 1577485

Is this issue going to be resolved in https://bugzilla.mozilla.org/show_bug.cgi?id=1577485 as well?
Please note that while the bugs are formulated similarly, in 1577485 the defect is the order of the warnings while in this issue it's the appearance of the shortcut keys in that, for example, "ALT+SHIFT+D" is displayed in the warning instead of "SHIFT+ALT+D".

Flags: needinfo?(mstriemer)

Ah, I misunderstood the issue. I thought I saw another bug that mentioned something similar to the actual report here, but I can't find it right now.

I think this is a larger issue than just the warning messages. One extension could have Alt+Shift+4 and another Shift+Alt+4 and I don't think we'd notice those are dupes.

Status: RESOLVED → REOPENED
Flags: needinfo?(mstriemer)
Resolution: DUPLICATE → ---
Summary: "SHIFT+ALT+[number or letter]" shortcut keys are not displayed in the correct order in the individual warning messages → Shortcut modifier order is not consistent
Version: Firefox 70 → 70 Branch
You need to log in before you can comment on or make changes to this bug.