Closed Bug 1577587 Opened 4 months ago Closed 3 months ago

minimize to dock doesn't work

Categories

(Core :: Widget: Cocoa, defect, P1)

x86_64
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: fiveNinePlusR, Assigned: mstange)

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(1 file)

Double clicking on the titlebar in mac os doesn't minimize firefox to the dock with the "Double click a window's titlebar to minimize the dock" preference enabled.

I suppose this never worked ever since we put tabs in the title bar? Or is this a recent regression?

Flags: needinfo?(fiveNinePlusR)

it's worked for a long time only recently breaking in the past few days. there might be a relevant about:config item that shows the titlebar though that some people don't have set.

Flags: needinfo?(fiveNinePlusR)

What version of Firefox are you using?

Flags: needinfo?(fiveNinePlusR)

It for sure was broken in 70.0a1 (2019-08-27) (64-bit) and is still broken in 70.0a1 (2019-08-30) (64-bit)

Flags: needinfo?(fiveNinePlusR)
Component: General → Widget: Cocoa
Product: Firefox → Core

I found the problem in the code, but it's not clear to me how this could have broken recently. It should have been broken ever since macOS 10.11.

Assignee: nobody → mstange
Status: NEW → ASSIGNED

I do use this feature fairly often and I'm positive I've used it since 10.11 rolled around. perhaps it's some other cause that changed that preference value from working? I'm on 10.13.6 fwiw and have usually updated close to the release of each OS. (except 10.14+ because hardware incompatibilities)

Priority: -- → P1

n-i just in case my phabricator r+ was missed. Thanks!

Flags: needinfo?(mstange)
Pushed by spohl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f478b82706bd
Check the correct preference in -[ChildView shouldMinimizeOnTitlebarDoubleClick] on 10.11 and up. r=spohl

Actually, I went ahead and landed this.

Flags: needinfo?(mstange)
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Thanks for landing it!

on latest nightly and it looks like this patch is included but the issue still remains. can someone else verify this?

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

(In reply to fiveNinePlusR from comment #13)

on latest nightly and it looks like this patch is included but the issue still remains. can someone else verify this?

Oh, that is unfortunate. I've filed a new bug about this (bug 1581433) so that we can keep this one closed, because we try to have one landing per bug and the patch definitely fixed the problem on my 10.12 machine.

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED

Was this something we intended to uplift to Beta for Fx70? RC week is next week.

Flags: needinfo?(mstange)

Yes, let's uplift. We'll also want to uplift bug 1581433 but I've only just written the patch for that one.

Flags: needinfo?(mstange)

Comment on attachment 9089477 [details]
Bug 1577587 - Check the correct preference in -[ChildView shouldMinimizeOnTitlebarDoubleClick] on 10.11 and up. r=spohl

Beta/Release Uplift Approval Request

  • User impact if declined: Double clicking on toolbars doesn't minimize the window despite the system setting.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It just adds a check to another system preference. I've tested it on multiple macOS versions.
  • String changes made/needed:
Attachment #9089477 - Flags: approval-mozilla-beta?

Comment on attachment 9089477 [details]
Bug 1577587 - Check the correct preference in -[ChildView shouldMinimizeOnTitlebarDoubleClick] on 10.11 and up. r=spohl

Fix for new regression in 70, OK for beta 14 uplift.

Attachment #9089477 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced the initial issue using an old Beta build: 20191007220302
Verified - fixed on latest Beta 70.0b14 (Build id: 20191010142853) and latest Nightly 71.0a1 (Build id: 20191010214019) on Mac OS 10.14 and Mac OS 10.15

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.