Closed Bug 1581433 Opened 3 months ago Closed 2 months ago

Double clicking the titlebar to minimize to Dock still doesn't work on 10.13, even after the patch for bug 1577587

Categories

(Core :: Widget: Cocoa, defect, P2)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 + verified

People

(Reporter: mstange, Assigned: mstange)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

See bug 1577587:

(In reply to fiveNinePlusR from bug 1577587 comment #0)

Double clicking on the titlebar in mac os doesn't minimize firefox to the dock with the "Double click a window's titlebar to minimize the dock" preference enabled.

(In reply to fiveNinePlusR from bug 1577587 comment #13)

on latest nightly and it looks like this patch is included but the issue still remains. can someone else verify this?

Flags: needinfo?(fiveNinePlusR)

sure:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2d881c1ee2d0f3a92767dedd5b311e446cc138b7&tochange=70ec0ddc8f325ad57741865e7bd58bb311e9bb20

15:51.32 INFO: Using local file: /var/folders/zv/v3f3_6js4tjc0fr1b_3zjk8w0000gn/T/tmp3s1Mog/2d881c1ee2d0-shippable--autoland--target.dmg (downloaded in background)
15:51.32 INFO: Running autoland build built on 2019-08-26 03:02:15.961000, revision 2d881c1e
16:21.72 INFO: Launching /private/var/folders/zv/v3f3_6js4tjc0fr1b_3zjk8w0000gn/T/tmpj4cru7/Firefox Nightly.app/Contents/MacOS/firefox
16:21.72 INFO: Application command: /private/var/folders/zv/v3f3_6js4tjc0fr1b_3zjk8w0000gn/T/tmpj4cru7/Firefox Nightly.app/Contents/MacOS/firefox --allow-downgrade -foreground -profile /var/folders/zv/v3f3_6js4tjc0fr1b_3zjk8w0000gn/T/tmppTLaOT.mozrunner
16:21.75 INFO: application_buildid: 20190826014703
16:21.75 INFO: application_changeset: 2d881c1ee2d0f3a92767dedd5b311e446cc138b7
16:21.75 INFO: application_name: Firefox
16:21.75 INFO: application_repository: https://hg.mozilla.org/integration/autoland
16:21.75 INFO: application_version: 70.0a1
Was this inbound build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', 'back' or 'exit' and press Enter): good
17:12.71 INFO: Narrowed inbound regression window from [a1e72b9b, 70ec0ddc] (4 builds) to [2d881c1e, 70ec0ddc] (2 builds) (~1 steps left)
17:12.71 INFO: No more inbound revisions, bisection finished.
17:12.71 INFO: Last good revision: 2d881c1ee2d0f3a92767dedd5b311e446cc138b7
17:12.71 INFO: First bad revision: 70ec0ddc8f325ad57741865e7bd58bb311e9bb20

Flags: needinfo?(fiveNinePlusR) → needinfo?(mstange)
Duplicate of this bug: 1583358
Has Regression Range: --- → yes

Thanks for getting the regression range! Looks like I'll need to do some debugging on 10.13.

Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)

The priority flag is not set for this bug.
:spohl, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(spohl.mozilla.bugs)
Flags: needinfo?(spohl.mozilla.bugs)
Priority: -- → P2

I've set up a 10.13 machine and tested this, and double-click-to-minimize works correctly over here.

Can you please run the following two commands in Terminal on your machine and paste the output here? Thanks!

defaults read -g AppleMiniaturizeOnDoubleClick
defaults read -g AppleActionOnDoubleClick
Flags: needinfo?(fiveNinePlusR)

Erik, could you run the commands from comment 6, too?

Flags: needinfo?(erik)

1
Minimize

Flags: needinfo?(erik)

~ ❯❯❯ defaults read -g AppleMiniaturizeOnDoubleClick
1
~ ❯❯❯ defaults read -g AppleActionOnDoubleClick
Minimize

it definitely works in most every other application on my system.

Flags: needinfo?(fiveNinePlusR)

FWIW, this is happening to me on 10.14.6.

Oh I think I found my mistake. When you say "titlebar", you actually mean the titlebar. And not the tab bar or the toolbar.
I never tested the configuration with the separate titlebar enabled.

Ok, I think I know what to do.

Yep! :-)

This was already working for toolbars, but it wasn't working for the titlebar in windows that
actually have a real separate titlebar.
All our windows use NSFullSizeContentViewWindowMask, so we no longer get this behavior for free.
In windows with titlebars, the titlebar area is covered with a TitlebarGradientView, so that's
where we need to handle the double clicks.

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/88ec006f2ab7
Maximize or minimize the window when double clicking the titlebar. r=spohl
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Verified over here! Thank you! :-D

Comment on attachment 9099669 [details]
Bug 1581433 - Maximize or minimize the window when double clicking the titlebar. r=spohl

Beta/Release Uplift Approval Request

  • User impact if declined: Double-clicking the titlebar, on windows with separate titlebars, will not minimize or maximize the window.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The code is straightforward, the surface area for bugs is limited, has been tested on multiple versions of macOS
  • String changes made/needed:
Attachment #9099669 - Flags: approval-mozilla-beta?

Comment on attachment 9099669 [details]
Bug 1581433 - Maximize or minimize the window when double clicking the titlebar. r=spohl

Fix for recent regression in titlebar behavior, OK for beta 14 uplift.

Attachment #9099669 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Hi, This issue is verified as Fixed in our latest Nightly build as well as Beta 70.0b14 on Mac OSX 10.13.6

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.