Closed Bug 1577708 Opened 5 months ago Closed 5 months ago

Very low on-hover contrast in dark theme Change Search Settings button

Categories

(Firefox :: Theme, defect, P1)

Desktop
All
defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.1 - Sept 2 - 15
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: cfogel, Assigned: harry)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Affected versions

  • 70.0b2, 70.0a1 (2019-08-29)

Affected platforms

  • Ubuntu 16.04

Steps to reproduce

  1. Launch Firefox swap to Dark Theme and enable the search bar;
  2. Click inside the Search Bar and type any text;
  3. Hover over the Change Search Settings button;

Expected result

  • Buttons are properly displayed;

Actual result

  • the default state of the background_color for the button is the on_hover one;
  • the hover effect makes it so the text is not readable;

Regression range

Additional notes

  • attached screenshot with the issue;
  • 68, 69 builds are not affected;

I assume it was a mistake that your marked 69 as affected.

Harry, this is probably your regression. Can you take a look?

Flags: needinfo?(htwyford)
Priority: -- → P1
Regressed by: 1561894

Thank you for the correction, indeed was force of habit.
Re-confirmed with 69.0 and 69.b016 and they are not affected.
Managed to get the regression range as well, updating the initial post with the results.

Has Regression Range: --- → yes
Has STR: --- → yes

While this problem is worst on Linux, I'm expanding the scope of this bug since contrast is low on all platforms. The attached patch affects all platforms as well.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 71.1 - Sept 2 - 15
Points: --- → 1
Flags: needinfo?(htwyford)
OS: Linux → All
Summary: [Ubuntu] Change Search Settings button lacks dark theme color styling for on-hover effect → Very low on-hover contrast in dark theme Change Search Settings button
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c166af1c637e
Increase contrast on search settings button. r=dao
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Can you request beta uplift? It would be nice to not ship this regression.

Flags: needinfo?(htwyford)

Comment on attachment 9089946 [details]
Bug 1577708 - Increase contrast on search settings button. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: Low contrast on a UI element. Contrast issues are bad enough that the element is sometimes invisible on Linux.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Single-line CSS change on a fairly low-traffic component of the browser (the standalone search bar).
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9089946 - Flags: approval-mozilla-beta?

Comment on attachment 9089946 [details]
Bug 1577708 - Increase contrast on search settings button. r?dao

CSS fix, helps a11y, let's uplift.

Attachment #9089946 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I've managed to reproduce this issue on Firefox Nightly 70.0a1 (2019-08-29) and verified that it has been fixed on Nightly 71.0a1 (2019-9-10)
I'll be back to verify it on Beta 70b5 asap.

I've also verified the fix on Firefox Beta 70.0b5

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.