Closed Bug 1578105 Opened 3 months ago Closed 3 months ago

[Protections Panel] Info button styling is broken on Windows

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: nhnt11, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(2 files)

Seems like the outline gets set but the background color doesn't. Looks pretty bad.

Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Type: task → defect
Priority: -- → P1
Assignee: nhnt11 → tihuang

The into button lacks the '-moz-appearance: none;' rule to disable the
system styling. Fix this by adding this.
\

Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/69454149a5fa
Fix the styling issue of the info button on Windows. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9090345 [details]
Bug 1578105 - Fix the styling issue of the info button on Windows. r?nhnt11!

Beta/Release Uplift Approval Request

  • User impact if declined: The info button of the protection panel on Windows will be broken.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open the protection panel by clicking the shield icon in any webpages
  1. Hover on the info button on the header of the protection.
  2. Check whether the into button has a correct grey-ish background.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a one-line change and only for UI display. It doesn't change any functionality.
  • String changes made/needed: None
Attachment #9090345 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9090345 [details]
Bug 1578105 - Fix the styling issue of the info button on Windows. r?nhnt11!

CSS only fix for newly shipping feature; let's get it into beta 5.

Attachment #9090345 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Attached image Info button.png

Verified as fixed on Firefox Nightly 71.0a1 (2019-09-08) on Windows 10 x64 and on Windows 7 x32.

I Noticed that on Ubuntu 18.04 x64 the info button looks a bit different when hovering on it and it changes it color from white to dark grey. (See screenshot attached)
Is this behavior intended or there is already a bug logged for it?

Flags: needinfo?(tihuang)

Thanks Hani,

No, this is not intended behavior. The color should stay the same after hovering on it. I filed Bug 1580106 for this.

Flags: needinfo?(tihuang)

Verified as fixed on Firefox 70.0b5 on Windows 10 x64 and on Windows 7 x32.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.