Closed Bug 1578528 Opened 3 months ago Closed Last month

Support new text in about:welcome Join message variant

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox71 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(3 files)

Update text to support new wording in Join message three variant a, variant b and variant c

https://mozilla.invisionapp.com/share/GNT0C6U53Z8#/screens/374174942_about-Welcome_69

Assignee: nobody → pdahiya
Attached image join-message-70.png

NI Aaron to provide images shown against Sync and Lockwise in the list.

NI Jim to provide url where 'Learn about the Firefox family of products' in join variant should point to.

Thanks!

Flags: needinfo?(jimthomas)
Flags: needinfo?(abenson)
Flags: needinfo?(jimthomas)

NI Jim to help clarify if about:welcome first run experiment are planned for all locales or en-US only. This will help determine localization request of the new text. Thanks!

Flags: needinfo?(jimthomas)

All Locales, and final language will need to be reviewed with Legal/Trust for that context.

Flags: needinfo?(jimthomas)

NI Jim to help setup legal review of join messaging of three variants in bug description. We need final messaging before merging PR in master and submitting for localization. Thanks!

Flags: needinfo?(jimthomas)

[Tracking Requested - why for this release]:

Iteration: --- → 71.2 - Sept 16 - 29
Priority: -- → P1

Copy needs a few minor adjustments and then is approved by legal. Note the addition of a single word for Monitor:
https://docs.google.com/document/d/1WeDoWG1c4CHo_5rM_X1wLbJFpiZUlZbLrhkBAGG3Ppc/edit#

Flags: needinfo?(jimthomas)

NI @aaron for design review of new join messaging variants in dev. Thanks!

Flags: needinfo?(abenson)
Flags: needinfo?(abenson)

These look great!

Flags: needinfo?(abenson)
Blocks: 1586093
Status: NEW → RESOLVED
Closed: Last month
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified this issue with the latest Firefox Nightly (71.0a1 Build ID - 20191006214844) installed, on Windows 10 x64, Arch Linux and Mac 10.14.6. Now, I can confirm that "modal_variant_a" and "modal_variant_c" are respecting the design specs. However, there is a mismatch between the specs for the "modal_variant_b" and the actual implementation, more exactly the "Supercharge your privacy protection." string is displayed inside the modal instead of the "Supercharge your browser's privacy protection." one.

Punam, could you please confirm if this change is intended or not?

Flags: needinfo?(pdahiya)

(In reply to Marius Coman [:mcoman], Experiments QA from comment #14)

I have verified this issue with the latest Firefox Nightly (71.0a1 Build ID - 20191006214844) installed, on Windows 10 x64, Arch Linux and Mac 10.14.6. Now, I can confirm that "modal_variant_a" and "modal_variant_c" are respecting the design specs. However, there is a mismatch between the specs for the "modal_variant_b" and the actual implementation, more exactly the "Supercharge your privacy protection." string is displayed inside the modal instead of the "Supercharge your browser's privacy protection." one.

Punam, could you please confirm if this change is intended or not?

Yes, we dropped browser's after legal string review as noted in https://bugzilla.mozilla.org/show_bug.cgi?id=1578528#c10 under alternative headlines. Thanks

Flags: needinfo?(pdahiya)

Thanks, Punam! Considering the above answer and according to comment 14, I am changing the status of this issue to Verified - Fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.