Closed Bug 1578806 Opened 1 year ago Closed 1 year ago

Build failure on macOS post bug 1507754

Categories

(Thunderbird :: Build Config, defect)

Unspecified
macOS
defect
Not set

Tracking

(thunderbird_esr6870+ fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird71 --- fixed

People

(Reporter: khushil324, Assigned: rjl)

Details

Attachments

(1 file)

No description provided.

Error while building on the MacOS:

sed -i -e "s_^\(SourceRepository=\).*_\1https://hg.mozilla.org/mozilla-central_" \ -e "s/^\(SourceStamp=\).*/\1174361d152923aea2b24226a57cde3099509ed6a/" \ ../../dist/bin/platform.ini sed: -e: No such file or directory

sed on macOS does not know about the -i option, so this line will need to be changed.

Assignee: nobody → rob
Component: General → Build Config
Summary: Error while building on the MacOS sed -i -e "s_^\(SourceRepository=\).*_\1https://hg.mozilla.org/mozilla-central_" \ -e "s/^\(SourceStamp=\).*/\1174361d152923aea2b24226a57cde3099509ed6a/" \ ../../dist/bin/platform.ini sed: -e: No such file or directo → Build failure on macOS post bug 1507754
Fix for macOS build failures.
Attachment #9090574 - Flags: review?(geoff)
Comment on attachment 9090574 [details] [diff] [review]
platformini_no_sed.patch

No `sed -i`? What are they thinking? :-/

Oh well, that gets rid of the crazy regular expression pattern.
Attachment #9090574 - Flags: review?(geoff) → review+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/bb5f999a1fb0
Fix platform.ini creation when building on macOS. r=darktrojan

Status: NEW → RESOLVED
Closed: 1 year ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
Comment on attachment 9090574 [details] [diff] [review]
platformini_no_sed.patch

[Approval Request Comment]
Regression caused by (bug #): 1507754
User impact if declined: All local builds on macOS fail
Testing completed (on c-c, etc.): This has been on central for the past few weeks
Risk to taking this patch (and alternatives if risky): Low. This fixes a 100% local build failure rate when the build host is macOS.
Attachment #9090574 - Flags: approval-comm-esr68?
Attachment #9090574 - Flags: approval-comm-esr68? → approval-comm-esr68+
You need to log in before you can comment on or make changes to this bug.