Closed Bug 1579019 Opened Last month Closed Last month

BlockAboutConfig policy does not block about:config in Preferences tab

Categories

(Thunderbird :: Preferences, defect, P5, minor)

Desktop
Windows

Tracking

(thunderbird_esr6869+ fixed, thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 69+ fixed
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: kontakt.luck, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Set REG_DWORD in Registry: HKLM\SOFTWARE\Policies\Mozilla\Thunderbird - BlockAboutConfig to 1
Open Settings > Advanced > Edit Configuration

Actual results:

Window About:config opened

Expected results:

Blocked Site dialog should appear

Severity: normal → minor
Component: Untriaged → Preferences
OS: Unspecified → Windows
Priority: -- → P5
Hardware: Unspecified → Desktop

Where is it documented that this should work?

(NI for Geoff to attract attention, not to answer the specific question. Seems to be a policy thing.)

Flags: needinfo?(geoff)

Support for the policy engine has been added in Thunderbird 68.

Configurable policies are found here: https://searchfox.org/comm-central/source/mail/components/enterprisepolicies/schemas/policies-schema.json

That's not good, I wonder if this is actually a hole in the policy framework itself. about:config should not open anywhere, which works correctly in a content tab, but not in the <browser> inside the preferences tab.

We should also remove the button which leads to it, which would solve the problem.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(geoff)
Summary: BlockAboutConfig does not Block about:config → BlockAboutConfig policy does not block about:config in Preferences tab

We do block about:config in Firefox, so something must be missing in the TB implementation.

Attached patch 1579019-hide-about-config-1.diff (obsolete) — Splinter Review
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9090871 - Flags: review?(mkmelin+mozilla)
Attachment #9090871 - Flags: approval-comm-beta?
Attachment #9090874 - Flags: approval-comm-esr68?

I think you've missed my point Mike. Presumably the blocking is done somewhere in the page loading code, since a blocked page is replaced by about:neterror. But this doesn't happen for the same page loaded in a <browser> inside our preferences page.

I think you've missed my point Mike. Presumably the blocking is done somewhere in the page loading code, since a blocked page is replaced by about:neterror. But this doesn't happen for the same page loaded in a <browser> inside our preferences page.

No, I understood. Content policy must not be getting loaded for that browser. It's done here:

https://searchfox.org/comm-central/source/mail/components/enterprisepolicies/Policies.jsm#657

It's less problematic in Thunderbird because there is no URL bar, but we should still figure it out.

Comment on attachment 9090874 [details] [diff] [review]
1579019-hide-about-config-esr1.diff

Review of attachment 9090874 [details] [diff] [review]:
-----------------------------------------------------------------

I'd rather disable, or maybe better just let the error page show what's going on.
Attachment #9090871 - Flags: review?(mkmelin+mozilla)
Attachment #9090871 - Flags: approval-comm-beta?
Attachment #9090871 - Attachment is obsolete: true
Attachment #9091671 - Flags: review?(mkmelin+mozilla)
Attachment #9091671 - Flags: approval-comm-beta?
Attachment #9090874 - Attachment is obsolete: true
Attachment #9090874 - Flags: approval-comm-esr68?
Attachment #9091673 - Flags: approval-comm-esr68?
Attachment #9091671 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → Thunderbird 71.0

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4e5fad04693c
Disable "Config Editor" button if about:config is blocked by policy. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: Last month
Keywords: checkin-needed
Resolution: --- → FIXED
Attachment #9091671 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #9091673 - Flags: approval-comm-esr68? → approval-comm-esr68+
See Also: → 1580753
Blocks: tb-policies
You need to log in before you can comment on or make changes to this bug.