Closed Bug 1579575 Opened Last month Closed Last month

Account Central not appearing after a new account is created (TB 70 beta)

Categories

(Thunderbird :: Account Manager, defect, critical)

Desktop
All
defect
Not set
critical

Tracking

(thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: walts48, Assigned: aceman)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached image no-account-central.png

Installed TB 70.0b1 en-GB on Windows 10 and Ubuntu 18.04.3 LTS Linux.
Started each from a terminal command to launch the profile manager
Created tests profiles.
Started TB 70.0b1 with the test profile.
Noticed there was a new Account Wizard.
Created my POP3 account.
Email downloaded to the Inbox.
Selected the Account in the Folder pane.

The Account Central pane was still showing "Set up an account" and "Create a new calendar".
I had the same result after creating my IMAP account.

I should have seen the full Account Central Pane with the "Email", "Accounts" and "Advanced Features" sections.
Those did appear after restart of TB 70.0b1 on each system.

Eckard did you see this when doing Mac testing?

Flags: needinfo?(de.berberich)

Do you think fixing this bug will fix the Newsgroups heading and the Feeds heading also not appearing in Account Central after creating those types of accounts?

I had to select the account in the Folder pane, right click and use Subscribe from the context menu.

It appears that everything works after an update from TB 69.0b4 to 70.0b1.

Severity: normal → blocker
Flags: needinfo?(jorgk)

OK, so the issue is that Account Central shows, but it has the wrong content, yes?

Actual:
The Account Central pane was still showing "Set up an account" and "Create a new calendar".

Expected:
I should have seen the full Account Central Pane with the "Email", "Accounts" and "Advanced Features" sections.

Personally, to me this is not a blocker. Looks like a regression from bug 1551133. We'll see what Alex and Magnus say.

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(jorgk)
Flags: needinfo?(alessandro)
Regressed by: 1551133
Summary: Account Central not appearing after a new account is created → Account Central not appearing after a new account is created (TB 70 beta)

(In reply to WaltS48 [:walts48] from comment #1)

Eckard did you see this when doing Mac testing?

I just tested the account creation again in a new profile and, yes, I can confirm this issue.

Flags: needinfo?(de.berberich)

(In reply to Jorg K (GMT+2) from comment #3)

OK, so the issue is that Account Central shows, but it has the wrong content, yes?

Yes

Personally, to me this is not a blocker. Looks like a regression from bug 1551133. We'll see what Alex and Magnus say.

I thought it might have something to do with the new account creation dialog.

Severity: blocker → critical

I'm not sure this has anything to do with bug 1551133.
I can reproduce this without creating a new account, just by visiting the Account central for any account and then choosing other folders/accounts, when the Account central is displayed it is always for the same account that was viewed the first time.
I debugged it and the page is never reloaded to pick up the new selected account.

This is actually from bug 1568440, which does exactly that, prevents the page from refreshing...
Reverting that change fixes this problem. But of course it reopens bug 1568440 so a common solution needs to be found.

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(alessandro)
Regressed by: 1568440
No longer regressed by: 1551133
Flags: needinfo?(geoff)
Attached patch 1579575.patch (obsolete) — Splinter Review

We probably need to check if the selected folder changed. If so, we have to reload the page. So let's make the href contain the folder URI too.

Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #9091309 - Flags: review?(jorgk)
Attachment #9091309 - Flags: review?(geoff)

Please also check if bug 1568440 is covered by this.

Now passing eslint/prettier :)

Attachment #9091309 - Attachment is obsolete: true
Attachment #9091309 - Flags: review?(jorgk)
Attachment #9091309 - Flags: review?(geoff)
Attachment #9091311 - Flags: review?(jorgk)
Attachment #9091311 - Flags: review?(geoff)
Comment on attachment 9091311 [details] [diff] [review]
1579575.patch v1.1

Sorry, I'm really incompetent here.
Flags: needinfo?(geoff)
Attachment #9091311 - Flags: review?(jorgk)
Comment on attachment 9091311 [details] [diff] [review]
1579575.patch v1.1

I wonder if it would be better to use the account key instead of the URI, but it scarcely matters.
Attachment #9091311 - Flags: review?(geoff) → review+

On a closer look, the change makes sense to me, but let's go with r=darktrojan.

Keywords: checkin-needed

The argument after ? is actually unused now, in this patch it is just to differentiate the 'spec' for different accounts.
But I already have a followup prepared that uses the argument and simplifies the account central code.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/6928adb14504
reload Account Central pane if the selected folder changed. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: Last month
Keywords: checkin-needed
Resolution: --- → FIXED
Blocks: 1579987
Target Milestone: --- → Thunderbird 71.0
Attachment #9091311 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.