Closed Bug 15796 Opened 21 years ago Closed 20 years ago

[LIVEAUDIO] Unable to play .wav file in OBJECT element with LiveAudio

Categories

(Core :: Layout, defect, P3)

All
Windows 95
defect

Tracking

()

VERIFIED WONTFIX

People

(Reporter: christinehoff4, Assigned: serhunt)

Details

Attachments

(1 file)

Using build 1999100618 on Win 95.

Open attached file and .wav file (you will need a media player - I used
LiveAudio)

Expected result: LiveAudio object should appear and you should be able to click
and play.
Actual result: Object does not appear.

This works in Nav 4.7 on Win 95
Unable to attach .wav file
Assignee: rickg → av
Andrei -- please take a look
Blocks: 17432
Status: NEW → ASSIGNED
Hm... I see the object appearing fine. Simple test case

<object data="test.wav" type="audio/wav" width=200 height=100></object>

works for me. I tried today's build on Win95, but I remember it working for
quite a while.

Could you send specific case you used?
Chris, I tried the test case you sent me, and it looks alright. LiveAudio
appears but doesn't play, that' another issue. QuickTime4 plugin plays sound
just fine. Can you confirm this? If so, the original bug should be closed.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I am closing this. If anybody finds it doesn't work again please reopen.
Andrew: I put the appropriate LiveAudio files into the Plugin directory in
Seamonkey and I still could not get the .wav file to work. I get what you did,
the LiveAudio gray box, but I can't play it. Doesn't this mean there is still a
bug? The original bug was using LiveAudio.
QA Contact: petersen → chrisd
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reopening bug - unable to play .wav file with LiveAudio
Summary: Object element doesn't work with .wav file → Unable to play .wav file in OBJECT element with LiveAudio
[updating summary]
Summary: Unable to play .wav file in OBJECT element with LiveAudio → [LIVEAUDIO] Unable to play .wav file in OBJECT element with LiveAudio
NOTE: The Nav4.x Netscape LiveAudio player is long, long dead. It was never used
by anyone. So we don't want to spend cycles making sure the LiveAudio player
itself works.

Andrei -- Please only keep open this bug if it demonstrates a general problem
with backward compatibility with plug-ins in the Mozilla Plug-in API that we
must fix to make sure other plug-ins work.  If the problem is specific to the
LiveAudio player, close this bug as WONTFIX.  All LiveAudio-specific bugs should
be closed as WONTFIX.
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → WONTFIX
Doing this, as long as QT plays sounds fine.
Status: RESOLVED → VERIFIED
Verified WONTFIX
No longer blocks: 17432
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.