Closed Bug 1579732 Opened 2 years ago Closed 2 years ago

When resizing browser window, Resizing window is slow

Categories

(Core :: Graphics, defect, P3)

71 Branch
Desktop
Windows 10
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- disabled
firefox69 --- disabled
firefox70 --- disabled
firefox71 --- disabled
firefox72 --- wontfix
firefox73 --- wontfix

People

(Reporter: alice0775, Unassigned)

References

(Regression)

Details

(Keywords: nightly-community, perf, regression)

Attachments

(2 files)

Attached file about:support

This problem is more noticeable in Nightly710.a1.

Reproducible: always

Steps To Reproduce:

  1. Open any web page
    e.g, http://ftp.mozilla.org/pub/firefox/nightly/2018/12/
  2. Resize browser window by dragging a window side border

Actual Results:
Redraw contents is slow
Black/White area appears temporarily

Expected Results:
Firefox70.0b4 is much smoother than Nightly71.0a1

Attached video Screencast
Version: 71 Branch → Trunk
User Story: (updated)

This is nightly only. And early beta and release seems to be not affected.

Severity: normal → minor
See Also: → 1579929

Hi @Alice0775 White, tested with nightly 71.0a1 & beta 70.0b5=> cannot reproduce. I've tried on both ways, with:

  1. Graphics Features Compositing: Direct3D 11 (Advanced Layers)
  2. Graphics Features Compositing: Webrender
  • at about:config -> type "gfx.webrender.force-disabled"-> in my case in set to "false" by default so, I have Webrender on; if is set to "false" I have Direct3D 11 (Advanced Layers) enabled.
    Do you have the possibility to activate Webrender as I said above, and re-test if you get the same result ? I've noticed that you have a GPU- AMD Radeon HD 6450/ I use NVIDIA GeForce GT 1030.
    Further, I will set a component if isn't the right one please fell free to change it, also someone from dev's team could give us a hand with that.
    Regards,
    Liviu
Component: Untriaged → Graphics
Flags: needinfo?(alice0775)
Product: Firefox → Core
Version: Trunk → 71 Branch

I can also reproduce the issue with WebRender enabled.

Flags: needinfo?(alice0775)

(In reply to Alice0775 White from comment #4)

I can also reproduce the issue with WebRender enabled.

Hi @Alice0775 White! You said that Firefox 70.0b4 was better, would you have a regression range for this?

I did not manage to reproduce this on Windows 10 (NVIDIA) or Mac (AMD).

Flags: needinfo?(alice0775)
Priority: -- → P3

And black flickers worsen when change window size mode from Normal window to Maximum window.
(Uncheck "Show window contents while dragging" in Performance dialog of System properties of windows10 control panel)
#2 Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2e7460e2a73e061e3bc75646dc7d8b5e76943160&tochange=f5cc355f51aa846cbb998b5d49bafc2ead3bfa53

Has Regression Range: --- → yes
Regressed by: 1549674, 1547277
Regressed by: 1574016
No longer regressed by: 1547277

(In reply to Timothy Nikkel (:tnikkel) from comment #8)

Alice, would you mind trying these builds and seeing how they perform. I'm trying to understand how bug 1574016 affects this.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=93c9267e41422a921584d94e977b10f3d15cf86d
*Very good, no longer flickering when maximized from normal size mode

https://treeherder.mozilla.org/#/jobs?repo=try&revision=6065c609be8f6dd8f7c457dfbef1fdbf764f2c50
*Very good, no longer flickering when maximized from normal size mode

https://treeherder.mozilla.org/#/jobs?repo=try&revision=70740ed3da62aeea75da978a76e77ad8ba3fce15
*flickering when maximized from normal size mode

https://treeherder.mozilla.org/#/jobs?repo=try&revision=acbec672a12ff10e65725d19affbacafc2fb92e2
*flickering when maximized from normal size mode

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1c776faa96093f36f426f1b3ea1ecc8230495558
*flickering when maximized from normal size mode

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8043d9d3da80b7b81cf7a92748c7bc2218c780dc
*no longer flickering when maximized from normal size mode, but sometimes, it flickers at first time.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b45ba15e29b0f77285aed0e66fa8a91f3e72cf9c
*flickering when maximized from normal size mode

What next Timothy?

Flags: needinfo?(tnikkel)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #10)

What next Timothy?

Note that I was only investigating comment 7 which was caused by my patch, which seems kinda unrelated to this bug as filed in the first comment.

The only thing I determined was that we seem to be missing an invalidation in that step.

Alice, did the builds in comment 8 have any effect on resizing the browser window by dragging a window border?

Flags: needinfo?(tnikkel) → needinfo?(alice0775)

(In reply to Timothy Nikkel (:tnikkel) from comment #11)

Alice, did the builds in comment 8 have any effect on resizing the browser window by dragging a window border?

same as the actual results of comment #0. i.e, no effect.

anyway, setting gfx.direct3d11.use-double-buffering to "false" mitigates the problem.

Flags: needinfo?(alice0775)

Is there more to be done here?

Flags: needinfo?(jmuizelaar)

Yes. This needs further investigation. Sotaro can you reproduce the problem?

Flags: needinfo?(jmuizelaar) → needinfo?(sotaro.ikeda.g)
See Also: → 1580222
See Also: → 1494522

As in Comment 12 , Black/White area could be related to DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL SwapChain usage and compositor window usage. It looks similar to Bug 1494522. In this case, the symptom seems to related to cpu power.

chrome browser also uses DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL SwapChain and child windows in gpu process if possible. It also has similar Black/White area symptom.

Flags: needinfo?(sotaro.ikeda.g)

We have shipped our last beta for 71 and this is a P3, so this is wontfix for 71.

Double buffering was disabled at the last minute for 71 but is still enabled in 72. What's the plan here?

Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(jmuizelaar)

Alice, how much worse do find resizing in Firefox vs resizing in Chrome?

Flags: needinfo?(alice0775)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #18)

Alice, how much worse do find resizing in Firefox vs resizing in Chrome?

Black/White area appears temporarily.
However, it is almost same between Chromium 80.0.3972.0 and Nightly 73.0a1 20191213094653

If forcibly enabled WebRender, it is much better than Direct3D11(Advanced Layers).

So, I think this is now WONTFOX!

Flags: needinfo?(alice0775)

Thank you.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(sotaro.ikeda.g)
Resolution: --- → WONTFIX
Flags: needinfo?(jmuizelaar)
See Also: → 1617517
See Also: → 1670209
You need to log in before you can comment on or make changes to this bug.