Closed Bug 1579768 Opened 1 year ago Closed 5 months ago

Debugger paused overlay is too obtrusive and can't be disabled

Categories

(DevTools :: Debugger, defect, P1)

Desktop
All
defect

Tracking

(firefox69 unaffected, firefox70 wontfix, firefox71 verified)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox69 --- unaffected
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: v+mozbug, Assigned: jlast)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-complete, regression, Whiteboard: [debugger-reserve])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Debugging with latest DevEd, Paused on breakpoint, then Paused while stepping.

Actual results:

Browser tab got a grey overlay, and a message box, with the context about being paused.

Expected results:

I want to be able to see my content when I'm debugging. I sort of understand that it can be confusing, especially when using a separate window for DevTools (like I always do) when stopped at a breakpoint, because if you look at the browser window and do click or type something, nothing happens because it is stopped at a breakpoint. After a bit, one figures that out, and returns to interacting with the DevTools!

BUT: when the content has the grey overlay, it is hard to evaluate shades of color underneath. And the stuff behind the message box cannot be seen.

Both the grey overlay, and the message box can hinder debugging, which is why I consider this a defect.

I recommend removing the overlay and message box as a well-meaning bad idea.

If lots of people love it, either make it optional on a setting, or make it "active" so that if you click the overlay or message box, that they go away for 30 seconds, so one can see the unadultered browser window for debugging analysis purposes.

If a similar setting or feature already exists to remove the grey overlay and message box, the message box should mention it.

Hi @Glenn Linderman, tested in Windows 10 using FF dev edition - beta 70.0b6. Can you please make a shot video to see what you refer? In my end I don't see a grey overlay on browser's tab. The gray overlay is over the body of the page. If you meant of something else please clarify.
Further, I will set a component, if isn't the proper one please fell free to change it.
Regards,
Liviu

Component: Untriaged → Debugger
Flags: needinfo?(v+mozbug)
Product: Firefox → DevTools

Hi @Liviu,

Yes, it is just a terminology thing... when I said "browser tab" I meant the "body of the page displayed in the browser tab for which DevTools was invoked".

So you are seeing exactly the same thing I am.

Flags: needinfo?(v+mozbug)

Hi @Glenn Linderman, Yes I saw the same thing in the following FF versions: nightly 71.0a1, beta 70.0b6 & dev edition 70.0b6 => the issue can be reproduced.
On release 69.0 release - the issue won't occur.
[Platforms affected]: Mac OS X, Ubuntu 18.04, Windows 10
[FF affected versions]: nightly 71.0a1, beta 70.0b6 & dev edition 70.0b6

Due this fact I run a mozregression, here are the results:

first bad:
build_date: 2019-08-12
changeset: 1ca06cd3e226f80adf2b1b8837ed9a475fa90baa
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7d9b5d8c9b9b36b135237292785537fc13f40226&tochange=1ca06cd3e226f80adf2b1b8837ed9a475fa90baa
repo_name: mozilla-central

last good:
build_date: 2019-07-19
changeset: 23d4ebd5f8e70bb86f179556572b55655d6e066d
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=23d4ebd5f8e70bb86f179556572b55655d6e066d&tochange=db5038b9b3d3b3d8d8296b7ee5f978cc1efec8ac

DEBUG : Found commit message:
Bug 1567461 - Ensure ModuloBuffer can be properly move-constructed - r=gregtatum
Without declaring them, ModuloBuffer had its copy&move constructor&assignments
defaulted. This means it could have been copied, and then both objects would now
own the same resource and attempt to free it on destruction!

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → Desktop
Version: 70 Branch → Trunk

Bug 1574646 tracks the overlay work; we'll incorporate this feedback in our planning.

Blocks: dbg-overlay
Summary: DevTools "Paused while stepping" → Debugger paused overlay is too obtrusive and can't be disabled
Priority: -- → P1
Assignee: nobody → jlaster
Blocks: dbg-71
Status: NEW → ASSIGNED
Whiteboard: [debugger-reserve]
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c266a3d8d62
Debugger paused overlay is too obtrusive and cant be disabled. r=davidwalsh
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Duplicate of this bug: 1581568

For reference, I finally figured out that the preference is called "devtools.debugger.features.overlay" and should be set to "false" to disable the overlay.

I have no idea if there is documentation for this feature or where such documentation for this feature might be, it just suddenly (70 branch) jumped out to annoy me. I figured out the name from the patch and about:config but it needs to be documented here for quick reference by people finding the bug. At least now that 71 branch is released, I can turn it off.

Sadly, it looks like the 70 branch will not have a way to turn it off, when released. I can only recommend using DevEd rather than debugging in 70 branch.

Flags: qe-verify+

Confirmed issue with 70.0a1 (2019-09-01).
Fix verified with 71.0b7 on Windows 10, macOS 10.13, Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

I've documented this; see https://github.com/mdn/sprints/issues/2276#issuecomment-559792262 for the full details.

Let me know if there's anything else you'd like to see added. Thanks!

You need to log in before you can comment on or make changes to this bug.