Closed Bug 1579969 Opened 7 months ago Closed 7 months ago

Perma fail Tier 2 0:36.82 python/mozbuild/mozbuild/test/backend/test_build.py::TestBuild::test_faster_recursive_make TEST-UNEXPECTED-FAIL | ::test_recursive_make TEST-UNEXPECTED-FAIL

Categories

(Firefox Build System :: General, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox69 unaffected, firefox70 fixed, firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mshal)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=265762928&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/PU3GGyVWRYOkOw9w7lkiKQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-09T18:20:57.799Z] 0:36.48 rootdir: Z:\task_1568050511\build\src, inifile: Z:\task_1568050511\build\src\config\mozunit\mozunit\pytest.ini
[task 2019-09-09T18:20:57.800Z] 0:36.48 collecting ... collected 7 items
[task 2019-09-09T18:20:57.800Z] 0:36.48
[task 2019-09-09T18:20:57.800Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestLcovParser::test_basic_parse PASSED
[task 2019-09-09T18:20:57.800Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestLcovParser::test_multiple_commas PASSED
[task 2019-09-09T18:20:57.801Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestLineRemapping::test_map_multiple_included PASSED
[task 2019-09-09T18:20:57.801Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestLineRemapping::test_remap_lcov PASSED
[task 2019-09-09T18:20:57.801Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestUrlFinder::test_chrome_resource_paths PASSED
[task 2019-09-09T18:20:57.801Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestUrlFinder::test_jar_paths PASSED
[task 2019-09-09T18:20:57.801Z] 0:36.48 python/mozbuild/mozbuild/test/codecoverage/test_lcov_rewrite.py::TestUrlFinder::test_wrong_scheme_paths PASSED
[task 2019-09-09T18:20:57.801Z] 0:36.48
[task 2019-09-09T18:20:57.801Z] 0:36.48 ========================== 7 passed in 0.08 seconds ===========================
[task 2019-09-09T18:20:58.144Z] 0:36.82 Z:\task_1568050511\build\src\python\mozbuild\mozbuild\test\backend\test_build.py
[task 2019-09-09T18:20:58.144Z] 0:36.82 ============================= test session starts =============================
[task 2019-09-09T18:20:58.145Z] 0:36.82 platform win32 -- Python 2.7.15, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- Z:\task_1568050511\build\src\obj-x86_64-pc-mingw32_virtualenvs\src-fpS1SYgV-2\Scripts\python.exe
[task 2019-09-09T18:20:58.145Z] 0:36.82 rootdir: Z:\task_1568050511\build\src, inifile: Z:\task_1568050511\build\src\config\mozunit\mozunit\pytest.ini
[task 2019-09-09T18:20:58.146Z] 0:36.82 collecting ... collected 3 items
[task 2019-09-09T18:20:58.146Z] 0:36.82
[task 2019-09-09T18:20:58.146Z] 0:36.82 python/mozbuild/mozbuild/test/backend/test_build.py::TestBuild::test_faster_make PASSED
[task 2019-09-09T18:20:58.146Z] 0:36.82 python/mozbuild/mozbuild/test/backend/test_build.py::TestBuild::test_faster_recursive_make TEST-UNEXPECTED-FAIL
[task 2019-09-09T18:20:58.146Z] 0:36.82 python/mozbuild/mozbuild/test/backend/test_build.py::TestBuild::test_recursive_make TEST-UNEXPECTED-FAIL
[task 2019-09-09T18:20:58.146Z] 0:36.82
[task 2019-09-09T18:20:58.146Z] 0:36.82 ================================== FAILURES ===================================
[task 2019-09-09T18:20:58.146Z] 0:36.82 ____________________ TestBuild.test_faster_recursive_make _____________________
[task 2019-09-09T18:20:58.146Z] 0:36.82
[task 2019-09-09T18:20:58.146Z] 0:36.82 self = <mozbuild.test.backend.test_build.TestBuild testMethod=test_faster_recursive_make>
[task 2019-09-09T18:20:58.146Z] 0:36.82
[task 2019-09-09T18:20:58.146Z] 0:36.82 def test_faster_recursive_make(self):
[task 2019-09-09T18:20:58.146Z] 0:36.82 substs = list(BASE_SUBSTS) + [
[task 2019-09-09T18:20:58.146Z] 0:36.82 ('BUILD_BACKENDS', 'FasterMake+RecursiveMake'),
[task 2019-09-09T18:20:58.147Z] 0:36.82 ]
[task 2019-09-09T18:20:58.148Z] 0:36.82 with self.do_test_backend(get_backend_class(
[task 2019-09-09T18:20:58.148Z] 0:36.83 'FasterMake+RecursiveMake'), substs=substs) as config:
[task 2019-09-09T18:20:58.150Z] 0:36.83 buildid = mozpath.join(config.topobjdir, 'config', 'buildid')
[task 2019-09-09T18:20:58.150Z] 0:36.83 ensureParentDir(buildid)
[task 2019-09-09T18:20:58.150Z] 0:36.83 with open(buildid, 'w') as fh:
[task 2019-09-09T18:20:58.150Z] 0:36.83 fh.write('20100101012345\n')
[task 2019-09-09T18:20:58.150Z] 0:36.83
[task 2019-09-09T18:20:58.150Z] 0:36.83 build = MozbuildObject(config.topsrcdir, None, None,
[task 2019-09-09T18:20:58.151Z] 0:36.83 config.topobjdir)
[task 2019-09-09T18:20:58.151Z] 0:36.83 overrides = [
[task 2019-09-09T18:20:58.151Z] 0:36.83 'install_manifest_depends=',
[task 2019-09-09T18:20:58.151Z] 0:36.83 'MOZ_JAR_MAKER_FILE_FORMAT=flat',
[task 2019-09-09T18:20:58.151Z] 0:36.83 'TEST_MOZBUILD=1',
[task 2019-09-09T18:20:58.151Z] 0:36.83 ]
[task 2019-09-09T18:20:58.151Z] 0:36.83 with self.line_handler() as handle_make_line:
[task 2019-09-09T18:20:58.151Z] 0:36.83 build._run_make(directory=config.topobjdir, target=overrides,
[task 2019-09-09T18:20:58.151Z] 0:36.83 > silent=False, line_handler=handle_make_line)
[task 2019-09-09T18:20:58.151Z] 0:36.83
[task 2019-09-09T18:20:58.151Z] 0:36.83 python\mozbuild\mozbuild\test\backend\test_build.py:120:
[task 2019-09-09T18:20:58.151Z] 0:36.83 _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
[task 2019-09-09T18:20:58.151Z] 0:36.83 python\mozbuild\mozbuild\base.py:741: in _run_make
[task 2019-09-09T18:20:58.151Z] 0:36.83 return fn(**params)
[task 2019-09-09T18:20:58.151Z] 0:36.83 python\mozbuild\mozbuild\base.py:795: in _run_command_in_objdir
[task 2019-09-09T18:20:58.151Z] 0:36.83 return self.run_process(cwd=self.topobjdir, **args)
[task 2019-09-09T18:20:58.151Z] 0:36.83 _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
[task 2019-09-09T18:20:58.152Z] 0:36.83
[task 2019-09-09T18:20:58.152Z] 0:36.83 self = <mozbuild.base.MozbuildObject object at 0x000000000548A198>
[task 2019-09-09T18:20:58.152Z] 0:36.83 args = ['c:\mozilla-build\bin\mozmake.EXE', '-C', 'Z:/task_1568050511/build/src/tmpsxyprz', '-j8', '-w', 'install_manifest_depends=', ...]
[task 2019-09-09T18:20:58.152Z] 0:36.83 cwd = 'Z:/task_1568050511/build/src/tmpsxyprz', append_env = {'MACH': '1'}
[task 2019-09-09T18:20:58.152Z] 0:36.83 explicit_env = None, log_name = 'make', log_level = 20
[task 2019-09-09T18:20:58.152Z] 0:36.83 line_handler = <function handle_make_line at 0x000000000548C7B8>
[task 2019-09-09T18:20:58.152Z] 0:36.83 require_unix_environment = False, ensure_exit_code = 0, ignore_children = True
[task 2019-09-09T18:20:58.152Z] 0:36.83 pass_thru = False
[task 2019-09-09T18:20:58.152Z] 0:36.83
[task 2019-09-09T18:20:58.152Z] 0:36.83 def run_process(self, args=None, cwd=None, append_env=None,
[task 2019-09-09T18:20:58.152Z] 0:36.83 explicit_env=None, log_name=None, log_level=logging.INFO,
[task 2019-09-09T18:20:58.153Z] 0:36.83 line_handler=None, require_unix_environment=False,
[task 2019-09-09T18:20:58.153Z] 0:36.83 ensure_exit_code=0, ignore_children=False, pass_thru=False):
[task 2019-09-09T18:20:58.153Z] 0:36.83 """Runs a single process to completion.
[task 2019-09-09T18:20:58.153Z] 0:36.83
[task 2019-09-09T18:20:58.153Z] 0:36.83 Takes a list of arguments to run where the first item is the
[task 2019-09-09T18:20:58.153Z] 0:36.83 executable. Runs the command in the specified directory and
[task 2019-09-09T18:20:58.153Z] 0:36.83 with optional environment variables.
[task 2019-09-09T18:20:58.153Z] 0:36.83
[task 2019-09-09T18:20:58.153Z] 0:36.83 append_env -- Dict of environment variables to append to the current
[task 2019-09-09T18:20:58.153Z] 0:36.83 set of environment variables.
[task 2019-09-09T18:20:58.153Z] 0:36.83 explicit_env -- Dict of environment variables to set for the new
[task 2019-09-09T18:20:58.154Z] 0:36.83 process. Any existing environment variables will be ignored.
[task 2019-09-09T18:20:58.154Z] 0:36.83
[task 2019-09-09T18:20:58.154Z] 0:36.83 require_unix_environment if True will ensure the command is executed
[task 2019-09-09T18:20:58.154Z] 0:36.83 within a UNIX environment. Basically, if we are on Windows, it will
[task 2019-09-09T18:20:58.154Z] 0:36.83 execute the command via an appropriate UNIX-like shell.
[task 2019-09-09T18:20:58.154Z] 0:36.83
[task 2019-09-09T18:20:58.154Z] 0:36.83 ignore_children is proxied to mozprocess's ignore_children.
[task 2019-09-09T18:20:58.154Z] 0:36.83
[task 2019-09-09T18:20:58.154Z] 0:36.83 ensure_exit_code is used to ensure the exit code of a process matches
[task 2019-09-09T18:20:58.154Z] 0:36.83 what is expected. If it is an integer, we raise an Exception if the
[task 2019-09-09T18:20:58.155Z] 0:36.83 exit code does not match this value. If it is True, we ensure the exit
[task 2019-09-09T18:20:58.155Z] 0:36.83 code is 0. If it is False, we don't perform any exit code validation.
[task 2019-09-09T18:20:58.155Z] 0:36.83
[task 2019-09-09T18:20:58.155Z] 0:36.83 pass_thru is a special execution mode where the child process inherits
[task 2019-09-09T18:20:58.155Z] 0:36.83 this process's standard file handles (stdin, stdout, stderr) as well as
[task 2019-09-09T18:20:58.155Z] 0:36.83 additional file descriptors. It should be used for interactive processes
[task 2019-09-09T18:20:58.155Z] 0:36.83 where buffering from mozprocess could be an issue. pass_thru does not
[task 2019-09-09T18:20:58.155Z] 0:36.83 use mozprocess. Therefore, arguments like log_name, line_handler,
[task 2019-09-09T18:20:58.155Z] 0:36.83 and ignore_children have no effect.
[task 2019-09-09T18:20:58.155Z] 0:36.83 """
[task 2019-09-09T18:20:58.155Z] 0:36.83 args = self._normalize_command(args, require_unix_environment)
[task 2019-09-09T18:20:58.156Z] 0:36.83
....

mshal could you, please, take a look?

Flags: needinfo?(mshal)
Regressed by: 1496746
Assignee: nobody → mshal
Flags: needinfo?(mshal)

Bug 1578254 added a dependency on .cargo/config to export, which happens
to work in the python/mozbuild/mozbuild/test/backend/test_build.py test
cases because DEPTH=., and make finds the checked-in file .cargo/config
in topsrcdir because VPATH points there. After removing VPATH in bug
1496746, the test no longer finds the file in topsrcdir, and doesn't
have a rule to build it since that exists in the top-level moz.build
file.

Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d538cd31820
Don't add export dependency on .cargo/config when testing; r=glandium
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Comment on attachment 9091584 [details]
Bug 1579969 - Don't add export dependency on .cargo/config when testing; r?glandium

Build fix, uplift requested by Aryx.

Attachment #9091584 - Flags: approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.