Closed Bug 1581004 Opened 1 year ago Closed 3 months ago

Perma (tier2) dom/file/tests/test_mozfiledataurl.html | assertion count 1 is more than expected 0 assertions

Categories

(Core :: DOM: File, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M4

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(1 file)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=266424966&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/AZFW8X9LTRWfh_DxgIZ08A/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-12T22:29:26.254Z] 22:29:26 INFO - TEST-OK | dom/file/tests/test_mozfiledataurl.html | took 4856ms
[task 2019-09-12T22:29:26.254Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 25 (0x7f03eeae5000) [pid = 2510] [serial = 78] [outer = 0x7f03f379b100]
[task 2019-09-12T22:29:26.255Z] 22:29:26 INFO - TEST-UNEXPECTED-FAIL | dom/file/tests/test_mozfiledataurl.html | assertion count 1 is more than expected 0 assertions
[task 2019-09-12T22:29:26.255Z] 22:29:26 INFO - TEST-START | dom/file/tests/test_nonascii_blob_url.html
[task 2019-09-12T22:29:26.255Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 24 (0x7f03f2b91000) [pid = 2510] [serial = 65] [outer = (nil)] [url = about:blank]
[task 2019-09-12T22:29:26.255Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 23 (0x7f03eea5d000) [pid = 2510] [serial = 66] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/file/tests/file_mozfiledataurl_doc.html]
[task 2019-09-12T22:29:26.256Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 22 (0x7f03f2b86000) [pid = 2510] [serial = 71] [outer = (nil)] [url = about:blank]
[task 2019-09-12T22:29:26.256Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 21 (0x7f03f2b90000) [pid = 2510] [serial = 73] [outer = (nil)] [url = blob:http://mochi.test:8888/79c25470-0ae0-4cfc-b22c-f0b948c986f7]
[task 2019-09-12T22:29:26.257Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 20 (0x7f03f2b86400) [pid = 2510] [serial = 72] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/file/tests/file_mozfiledataurl_doc.html]
[task 2019-09-12T22:29:26.257Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 21 (0x7f03eea5dc00) [pid = 2510] [serial = 79] [outer = 0x7f03f379b100]
[task 2019-09-12T22:29:26.257Z] 22:29:26 INFO - GECKO(2349) | --DOCSHELL 0x7f0c547a8000 == 1 [pid = 2663] [id = {ed2596d7-74f3-4141-903e-0ae16587727b}] [url = about:blank]
[task 2019-09-12T22:29:26.258Z] 22:29:26 INFO - GECKO(2349) | --DOCSHELL 0x7f0c53db9800 == 0 [pid = 2663] [id = {721e0128-1f97-4a77-80a5-d64fb2d5c62e}] [url = http://example.com/tests/dom/file/tests/file_mozfiledataurl_inner.html]
[task 2019-09-12T22:29:26.258Z] 22:29:26 INFO - GECKO(2349) | [Child 2663, Main Thread] WARNING: Wrong inner/outer window combination!: file /builds/worker/workspace/build/src/dom/base/Document.cpp, line 6888
[task 2019-09-12T22:29:26.258Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 4 (0x7f0c54de5f20) [pid = 2663] [serial = 1] [outer = (nil)] [url = http://example.com/tests/dom/file/tests/file_mozfiledataurl_inner.html]
[task 2019-09-12T22:29:26.259Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 3 (0x7f0c53d55c00) [pid = 2663] [serial = 2] [outer = (nil)] [url = about:blank]
[task 2019-09-12T22:29:26.259Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 2 (0x7f0c54de5200) [pid = 2663] [serial = 4] [outer = (nil)] [url = about:blank]
[task 2019-09-12T22:29:26.259Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 1 (0x7f0c54d2a000) [pid = 2663] [serial = 3] [outer = (nil)] [url = http://example.com/tests/dom/file/tests/file_mozfiledataurl_inner.html]
[task 2019-09-12T22:29:26.259Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 0 (0x7f0c53d5d000) [pid = 2663] [serial = 5] [outer = (nil)] [url = about:blank]
[task 2019-09-12T22:29:26.260Z] 22:29:26 INFO - GECKO(2349) | [Child 2663, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/workspace/build/src/xpcom/base/nsCycleCollector.cpp, line 3361
[task 2019-09-12T22:29:26.260Z] 22:29:26 INFO - GECKO(2349) | nsStringStats
[task 2019-09-12T22:29:26.261Z] 22:29:26 INFO - GECKO(2349) | => mAllocCount: 6969
[task 2019-09-12T22:29:26.261Z] 22:29:26 INFO - GECKO(2349) | => mReallocCount: 0
[task 2019-09-12T22:29:26.261Z] 22:29:26 INFO - GECKO(2349) | => mFreeCount: 6969
[task 2019-09-12T22:29:26.262Z] 22:29:26 INFO - GECKO(2349) | => mShareCount: 4271
[task 2019-09-12T22:29:26.262Z] 22:29:26 INFO - GECKO(2349) | => mAdoptCount: 195
[task 2019-09-12T22:29:26.263Z] 22:29:26 INFO - GECKO(2349) | => mAdoptFreeCount: 201
[task 2019-09-12T22:29:26.263Z] 22:29:26 INFO - GECKO(2349) | => Process ID: 2663, Thread ID: 139691374102336
[task 2019-09-12T22:29:26.263Z] 22:29:26 INFO - GECKO(2349) | ++DOCSHELL 0x7f03eea99000 == 13 [pid = 2510] [id = {faa8f559-419c-415e-95d9-cf8b7507a97d}]
[task 2019-09-12T22:29:26.264Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 22 (0x7f03f04326a0) [pid = 2510] [serial = 80] [outer = (nil)]
[task 2019-09-12T22:29:26.264Z] 22:29:26 INFO - GECKO(2349) | [Child 2510, Main Thread] WARNING: CompleteRedirectSetup failed, HttpChannelChild already open?: file /builds/worker/workspace/build/src/netwerk/protocol/http/HttpChannelChild.cpp, line 2125
[task 2019-09-12T22:29:26.264Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 21 (0x7f03f04326a0) [pid = 2510] [serial = 80] [outer = (nil)] [url = ]
[task 2019-09-12T22:29:26.264Z] 22:29:26 INFO - GECKO(2349) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpyVBOZk.mozrunner/runtests_leaks_tab_pid2691.log
[task 2019-09-12T22:29:26.265Z] 22:29:26 INFO - GECKO(2349) | --DOMWINDOW == 20 (0x7f03f2de4020) [pid = 2510] [serial = 76] [outer = (nil)] [url = about:blank]
[task 2019-09-12T22:29:26.265Z] 22:29:26 INFO - GECKO(2349) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-09-12T22:29:26.265Z] 22:29:26 INFO - GECKO(2349) | WARN 2019-09-12T22:29:06Z: audio_thread_priority::rt_linux: Could not make thread real-time.
[task 2019-09-12T22:29:26.266Z] 22:29:26 INFO - GECKO(2349) | WARN 2019-09-12T22:29:06Z: audioipc_client: Could not promote audio threads to real-time during initialization.
[task 2019-09-12T22:29:26.266Z] 22:29:26 INFO - GECKO(2349) | ++DOCSHELL 0x7f82785b8800 == 1 [pid = 2691] [id = {ec22b388-8fc1-43a4-936a-657acec1624a}]
[task 2019-09-12T22:29:26.267Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 1 (0x7f82795dcf20) [pid = 2691] [serial = 1] [outer = (nil)]
[task 2019-09-12T22:29:26.267Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 2 (0x7f827856fc00) [pid = 2691] [serial = 2] [outer = 0x7f82795dcf20]
[task 2019-09-12T22:29:26.267Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 3 (0x7f827950a000) [pid = 2691] [serial = 3] [outer = 0x7f82795dcf20]
[task 2019-09-12T22:29:26.268Z] 22:29:26 INFO - GECKO(2349) | MEMORY STAT | vsize 2706MB | residentFast 191MB | heapAllocated 39MB
[task 2019-09-12T22:29:26.268Z] 22:29:26 INFO - TEST-OK | dom/file/tests/test_nonascii_blob_url.html | took 1077ms
[task 2019-09-12T22:29:26.269Z] 22:29:26 INFO - GECKO(2349) | ++DOMWINDOW == 21 (0x7f03eeaea800) [pid = 2510] [serial = 81] [outer = 0x7f03f379b100]

Summary: Intermittent dom/file/tests/test_mozfiledataurl.html | assertion count 1 is more than expected 0 assertions → Perma (tier2) dom/file/tests/test_mozfiledataurl.html | assertion count 1 is more than expected 0 assertions

The specific assertion here is related to session history, so redirecting to peter.

[Child 2510, Main Thread] ###!!! ASSERTION: Adding a child where we already have a child? This may misbehave: 'Error', file /builds/worker/workspace/build/src/docshell/shistory/nsSHEntry.cpp, line 671
#01: nsDocShell::AddChildSHEntryToParent(nsISHEntry*, int, bool) [docshell/base/nsDocShell.cpp:3507]
#02: nsDocShell::AddToSessionHistory(nsIURI*, nsIChannel*, nsIPrincipal*, nsIPrincipal*, nsIPrincipal*, nsIContentSecurityPolicy*, bool, nsISHEntry**) [docshell/base/nsDocShell.cpp:0]
#03: nsDocShell::OnNewURI(nsIURI*, nsIChannel*, nsIPrincipal*, nsIPrincipal*, nsIPrincipal*, unsigned int, nsIContentSecurityPolicy*, bool, bool, bool) [docshell/base/nsDocShell.cpp:11038]
#04: nsDocShell::OnLoadingSite(nsIChannel*, bool, bool) [docshell/base/nsDocShell.cpp:11124]
#05: nsDocShell::CreateContentViewer(nsTSubstring<char> const&, nsIRequest*, nsIStreamListener**) [docshell/base/nsDocShell.cpp:8159]
#06: nsDSURIContentListener::DoContent(nsTSubstring<char> const&, bool, nsIRequest*, nsIStreamListener**, bool*) [docshell/base/nsDSURIContentListener.cpp:185]
#07: nsDocumentOpenInfo::TryContentListener(nsIURIContentListener*, nsIChannel*) [uriloader/base/nsURILoader.cpp:741]
#08: nsDocumentOpenInfo::DispatchContent(nsIRequest*, nsISupports*) [uriloader/base/nsURILoader.cpp:413]
#09: nsDocumentOpenInfo::OnStartRequest(nsIRequest*) [uriloader/base/nsURILoader.cpp:292]
#10: mozilla::net::HttpChannelChild::DoOnStartRequest(nsIRequest*, nsISupports*) [netwerk/protocol/http/HttpChannelChild.cpp:683]
#11: mozilla::net::HttpChannelChild::OnStartRequest(nsresult const&, mozilla::net::nsHttpResponseHead const&, bool const&, mozilla::net::nsHttpHeaderArray const&, mozilla::net::ParentLoadInfoForwarderArgs const&, bool const&, bool const&, bool const&, unsigned long const&, int const&, unsigned int const&, nsTString<char> const&, nsTString<char> const&, mozilla::net::NetAddr const&, mozilla::net::NetAddr const&, unsigned int const&, nsTString<char> const&, long const&, bool const&, bool const&, bool const&, mozilla::net::ResourceTimingStruct const&, bool const&) [netwerk/protocol/http/HttpChannelChild.cpp:609]
#12: mozilla::net::StartRequestEvent::Run() [netwerk/protocol/http/HttpChannelChild.cpp:434]
#13: mozilla::net::ChannelEventQueue::RunOrEnqueue(mozilla::net::ChannelEvent*, bool) [netwerk/ipc/ChannelEventQueue.h:211]
#14: mozilla::net::HttpChannelChild::RecvOnStartRequest(nsresult const&, mozilla::net::nsHttpResponseHead const&, bool const&, mozilla::net::nsHttpHeaderArray const&, mozilla::net::ParentLoadInfoForwarderArgs const&, bool const&, bool const&, bool const&, unsigned long const&, int const&, unsigned int const&, nsTString<char> const&, nsTString<char> const&, mozilla::net::NetAddr const&, mozilla::net::NetAddr const&, short const&, unsigned int const&, nsTString<char> const&, long const&, bool const&, bool const&, bool const&, mozilla::net::ResourceTimingStruct const&, bool const&) [netwerk/protocol/http/HttpChannelChild.cpp:503]
#15: mozilla::net::PHttpChannelChild::OnMessageReceived(IPC::Message const&) [s3:gecko-generated-sources:9ca8d9125c8b9fe4f9d8aa6ae5dfb54119ed55c296d86cdf8d5119058e9c03a87c07ee0bd20777f00049b45f238c86dfa0adb6864778fe01ea3d22d31607de1f/ipc/ipdl/PHttpChannelChild.cpp::859]
#16: mozilla::dom::PContentChild::OnMessageReceived(IPC::Message const&) [s3:gecko-generated-sources:819d57f1ac335c9022af60c24b45d1310a5e7ae4edb11d3380f34438b1431bb4968a4cbfd118c8344e19f7c4617ee53203eda7536acaeb5aaf41537f27dac0c1/ipc/ipdl/PContentChild.cpp::7834]
#17: mozilla::ipc::MessageChannel::DispatchAsyncMessage(mozilla::ipc::ActorLifecycleProxy*, IPC::Message const&) [ipc/glue/MessageChannel.cpp:2186]
#18: mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message&&) [ipc/glue/MessageChannel.cpp:2112]
#19: mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask&) [ipc/glue/MessageChannel.cpp:0]
#20: mozilla::ipc::MessageChannel::MessageTask::Run() [ipc/glue/MessageChannel.cpp:1987]
#21: nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:1214]
#22: NS_ProcessNextEvent(nsIThread*, bool) [xpcom/threads/nsThreadUtils.cpp:486]
#23: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:0]
#24: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:315]
#25: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
#26: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:139]
#27: XRE_RunAppShell() [toolkit/xre/nsEmbedFunctions.cpp:934]
#28: mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:238]
#29: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:315]
#30: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:291]
#31: XRE_InitChildProcess(int, char**, XREChildData const*) [toolkit/xre/nsEmbedFunctions.cpp:769]
#32: content_process_main(mozilla::Bootstrap*, int, char**) [ipc/contentproc/plugin-container.cpp:57]
#33: main [browser/app/nsBrowserApp.cpp:272]
Flags: needinfo?(nika) → needinfo?(peterv)

Please disable this test for fission, adding kmag as the reviewer.

Flags: needinfo?(csabou)
Priority: P5 → P3
Flags: needinfo?(csabou)

To be kept open until this test is fixed for fission.

Keywords: leave-open
Priority: P3 → P2
Blocks: 1582881
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f3a439325b98
disabled test_mozfiledataurl.html on fission r=kmag
Whiteboard: [stockwell disabled]
No longer blocks: 1582881

The test itself passes and we getting session history working in Fission will take time.
So we could add SimpleTest.expectAssertions(0, 3);
But there is another bug 1580391 which is trickier. The underlying issue seems to be bug 1586793.

Fission Milestone: --- → M4.1

I don't think session history in the parent will be done in M4.1.

Fission Milestone: M4.1 → ?
Depends on: fission-history
Flags: needinfo?(peterv)

This test got re-enabled for Fission by kmag in Bug 1586911.

Status: NEW → RESOLVED
Fission Milestone: ? → M4
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.