Print compose window as formatted message - currently prints plain, unformatted text, no addresses, no attachment informations, "about:blank" title

RESOLVED DUPLICATE of bug 297702

Status

MailNews Core
Composition
--
enhancement
RESOLVED DUPLICATE of bug 297702
16 years ago
5 years ago

People

(Reporter: John Coonrod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: workaround: save to and print from drafts)

(Reporter)

Description

16 years ago
1) The Compose screen has a file/print function, but no "print" button, which is
confusing.
2) When you print a composed message before sending it, it does not print any of
the header lines, which is annoying.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

15 years ago
Why is nothing happening on this? Seems like a simple enough problem to fix.
(Reporter)

Comment 2

15 years ago
Why is nothing STILL happening with this? It STILL seems like an easy but to fix.
(Reporter)

Comment 3

15 years ago
I checked this with 1.5b, and it has still not been fixed. Why????

Updated

14 years ago
Severity: normal → enhancement
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

14 years ago
*** Bug 239215 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
We have some customers asking for the feature to print an email before sending
it, Would be nice to have it in with 1.7 (and the future Netscape 7.2), just
like bug 202468 .
Product: MailNews → Core

Updated

13 years ago
Blocks: 297702

Comment 6

12 years ago
Hi, one of the users I support is required by her boss to print out messages, but unfortunately when she tries to print a message before it has been sent (from the compose window) the title is not recognised for printout in the printout page headers, nor is the message header shown in the page itself -- part 2 of the bug posted on 2002-07-18 is the bug we seem to be encountering.

We switched her over to Thunderbird not anticipating this issue, as we ourselves do not normally print emails, but it would be really nice if someone could please solve the issue!

It appears to be a Mozilla bug as we are using Thunderbird for Windows version 1.5 (20051025) and Thunderbird for Windows version 1.0.7 and the error is reproducible always, from within Thunderbird and from within a fresh install of Mozilla 1.8b2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702)

I realise the original bug poster and follow up poster may have not been on the positive side, but could someone please look at this bug afresh?

while https://bugzilla.mozilla.org/show_bug.cgi?id=297702 (bug 297702) is an instance of this bug, it seems to be misfiled under Thunderbird instead of Mozilla.

warmest wishes, maki

Comment 7

10 years ago
morphing this to just the formatting issue.  

print button is a separate UI issue, for seamonkey and thunderbird to do independently if they wish (but seems unlikely).  Perhaps an extension ala Buttons can do this.
Summary: Printing composed messages → Print compose window as formatted message - currently prints plain, unformatted text, no addresses, no attachment informations, "about:blank" title
Whiteboard: workaround: save to and print from drafts

Updated

10 years ago
Assignee: ducarroz → nobody
QA Contact: esther → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 8

5 years ago
(In reply to John Coonrod from comment #0)
> 1) The Compose screen has a file/print function, but no "print" button,
> which is
> confusing.

That's Bug 318955.

> 2) When you print a composed message before sending it, it does not print
> any of
> the header lines, which is annoying.

Indeed.

I'll merge this bug into bug 297702 which has more information, and starts out a bit better (one issue per bug, STR etc.). Keeping two bugs (one for mailnews core, one for TB) will just make it more difficult to address this.
No longer blocks: 297702
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297702

Updated

5 years ago
See Also: → bug 239215
You need to log in before you can comment on or make changes to this bug.