Closed Bug 1581096 Opened Last month Closed Last month

Search panel engine icon is not aligned with the magnifying glass and clock icons

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: itiel_yn8, Assigned: harry)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot

This is a regression from bug 1561894.
See attached.

Blocks: megabar
Flags: needinfo?(htwyford)
Iteration: --- → 71.2 - Sept 16 - 29
Points: --- → 1
Flags: needinfo?(htwyford)
Priority: -- → P2
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d552aa97a41
Align search panel engine icon with clock icons. r=dao
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Is this worth uplifting to 70? Please file the request if so.

Flags: needinfo?(htwyford)

Comment on attachment 9092846 [details]
Bug 1581096 - Align search panel engine icon with clock icons. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: UI misalignment in the standalone search bar.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Enter a search query in the standalone search bar. Then enter it again, so that it's in recent history. Observe if the history clock icon is aligned with the search engine logo at the top of the panel.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small CSS-only change in the standalone search bar.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9092846 - Flags: approval-mozilla-beta?
Flags: qe-verify+

I have reproduced this bug with Nightly 71.0a1 (2019-09-10) on windows 10, 64 bit!

The fix is now verified on Latest Nightly 71.0a1 (2019-09-23)

Build ID : 20190923215658
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

QA Whiteboard: [bugday-20190925]
QA Whiteboard: [bugday-20190925] → [bugday-20190925], [qa-triaged]

(In reply to Md. Majedul islam from comment #6)

The fix is now verified on Latest Nightly 71.0a1 (2019-09-23)

Thank you for testing! I can also confirm the fix with Nightly 71.0a1 (2019-09-23) on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13.

Comment on attachment 9092846 [details]
Bug 1581096 - Align search panel engine icon with clock icons. r?dao

Fix for new regression, verified in Nightly, let's take this for beta 10.

Attachment #9092846 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is verified fixed with Fx 70.0b10 (treeherder build provided in the comment above) on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.