Closed Bug 1581426 Opened 1 year ago Closed 11 months ago

Firefox Lockwise in Protection Report claims newly created Sync account connects with 1 other device, but should be 0

Categories

(Firefox :: Protections UI, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: aryx, Assigned: ewright)

References

Details

(Whiteboard: [protection-report])

Attachments

(1 file)

Firefox 71.0a1 from today and 70.0b6 on Windows 8.1

Firefox Lockwise in Protection Report claims newly created Sync account connects with 1 other device, but should be 0.

Steps to reproduce:

  1. Click on the avatar icon in the toolbar.
  2. Choose option to sign in with Firefox account.
  3. Enter an email address which doesn't have a Firefox account yet (or delete it before at https://accounts.firefox.com - at your own risk).
  4. Enter password and ago.
  5. Pull email.
  6. Verify the account with the link from the email.
  7. Open about:protections
  8. Scroll to the bottom.

Actual result:
Page claims there is 1 other device connected - that should not be possible because it's a new account.

Whiteboard: [protection-report][skyline]
Priority: -- → P1

Johann can you help find an owner for this one?

Flags: needinfo?(jhofmann)

Erica, did you want to take this?

Flags: needinfo?(jhofmann) → needinfo?(ewright)

Yes, this is going to be fixed for 71, but I'm waiting on a string change first. The number is not actually incorrect, just the way in which it is worded. Betsy is aware and working on it.
This doesn't actually block skyline, we should perhaps remove that from the whiteboard

Flags: needinfo?(ewright)
Whiteboard: [protection-report][skyline] → [protection-report]

71 is ending today. Depending on the string change we can probably still ask to get this in if we're quick now. Betsy, Erica, has there been any progress on this? :)

Thanks!

Flags: needinfo?(ewright)
Flags: needinfo?(bmikel)
Flags: needinfo?(ewright)
Duplicate of this bug: 1594329

Erica and I spoke about this. Here are the string changes. A decision was made to remove Sync from the string because it adds a layer of confusion about what you're syncing to. Have cleared this with UX content team as we are removing the feature name from the string. We are OK with that because we feel this wording is actually more clear.

Thanks Erica for talking this out with me!

[ 0 ] Connected to 0 devices Turn on Sync…
[ 1 ] Connected to 1 device Manage devices…
[ 2 ] Connected to 2 devices Manage devices…

Note that we are also adding the ellipses to all cases.

Flags: needinfo?(bmikel)
Assignee: nobody → ewright
Status: NEW → ASSIGNED
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e61b2935e9d5
Update Lockwise connected devices string. r=fluent-reviewers,nhnt11,flod
Flags: needinfo?(ewright)
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/320e0eac589d
Update Lockwise connected devices string. r=fluent-reviewers,nhnt11,flod
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Keywords: regression
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.