Closed Bug 1581757 Opened 5 months ago Closed 5 months ago

Support slicing the scene into an arbitrary number of picture cache slices

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: gw, Assigned: gw)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → gwatson

Previously, the setup_picture_caching function was hard coded
to support only a very specific shape of display list. With this
change, flags are added to PrimitiveCluster that can specify
if a picture cache slice should be created before / after this
cluster when picture caching is set up.

The usage of these flags in this patch matches the old behaviour,
so should not have any functional effect.

However, in future we will make use of this functionality to
create picture slices for a number of different use cases, such as:

  • Creating cache tiles for the UI.
  • Slicing the scene where there are video elements, in order to
    allow these to be composited directly by the OS. This may also
    apply to WebGL and/or canvas elements.
  • Slicing the scene when there is a very large fixed position
    background image or other element, to avoid invalidating the
    entire tile cache each frame.
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/08f2148de713
Support slicing the scene into an arbitrary number of picture cache slices r=nical

The android HW tests look like genuine new PASS results.

The OSX ones are a bit trickier to know - since it looks like there are some intermittents on some of those tests at the moment.

I'll do some investigation locally and try to re-land this tomorrow.

Flags: needinfo?(gwatson)

Rebased the patch, and filed https://bugzilla.mozilla.org/show_bug.cgi?id=1583091 to track the mac + scrollbar issue, which was previously only intermittent https://bugzilla.mozilla.org/show_bug.cgi?id=1581878.

I'll do one more try run on all platforms before pushing this.

Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2c9dbf826fe
Support slicing the scene into an arbitrary number of picture cache slices r=nical,kvark
Duplicate of this bug: 1584105
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc39374e708f
Support slicing the scene into an arbitrary number of picture cache slices r=nical,kvark
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Regressions: 1513520
You need to log in before you can comment on or make changes to this bug.