Closed Bug 1581969 Opened 4 months ago Closed 4 months ago

Don’t suggest Sync during Sync registration

Categories

(Firefox :: Messaging System, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: rfeeley, Assigned: MattN)

References

Details

Attachments

(2 files)

Attached image choose-what-to-sync.png

STEPS TO REPRODUCE

  1. In a fresh profile, register for Sync and save the password

EXPECTED RESULTS

  • I choose what to sync and complete registration

ACTUAL RESULTS

  • While choosing what to sync, the CFR suggests I turn on Sync.

I guess we can exclude this origin from the trigger I added in bug 1570372.

Blocks: 1570372
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED

The user may be in the process of setting up Sync so prompting to setup login Sync from a CFR would be untimely.

Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/5d60ea8fbdc6
Don’t activate the newSavedLogin trigger on accounts.firefox.com. r=jaws

Note, OK for beta uplift if it lands and sticks on m-c.

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

I have attempted to reproduce this issue in Nightly v71.0a1 from 2019-09-19, but it does not appear to reproduce with the basic steps from the description. There should be some way to know how to trigger that door hanger, specifically.
Matt, can you help? Do you know how to reproduce the issue, before attempting to verify it?

Flags: needinfo?(MattN+bmo)

Untested steps:

  1. In a new profile chose to sign in to sync
  1. Submit a username and password that will allow the password saved doorhanger to appear
  1. Choose to save the login for accounts.firefox.com

Expected result:
No CFR

Actual result:
CFR: "Recommendation" icon appears in the address bar. If you click on it, it would suggest Sync.

I suggested a new profile since the CFR only appears 3 times ever. Also, I think it only appears once per day or something.

Flags: needinfo?(MattN+bmo)

I managed to reproduce on Nightly v71.0a1 from 2019-09-16 and I have verified the fix on Nightly v71.0a1 from 2019-09-27 and Beta v70.0b9.
Verified on Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.