Closed Bug 1582117 Opened 1 year ago Closed 7 months ago

test_prompt_http.html|test_prompt_async.html Fission failure: mCrossOrigin/Ci.nsIAuthInformation.CROSS_ORIGIN_SUB_RESOURCE isn't true

Categories

(Core :: Networking: HTTP, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla78
Fission Milestone M4.1
Tracking Status
firefox78 --- fixed

People

(Reporter: enndeakin, Assigned: CuveeHsu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

User Story

The following tests should be enabled in this bug:
* toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html
* toolkit/components/passwordmgr/test/mochitest/test_prompt_async.html

Attachments

(1 file)

It fails within the test_schemeUpgrade subtest as the dialog does not appear.

I traced this as far as nsHttpChannelAuthProvider::PromptForIdentity not showing the dialog.

Priority: -- → P2
Fission Milestone: --- → ?

(In reply to Neil Deakin from comment #0)

I traced this as far as nsHttpChannelAuthProvider::PromptForIdentity not showing the dialog.

Should I move this bug to Necko or is that work already being tracked and can be marked as a dependency?

Flags: needinfo?(enndeakin)

I haven't triaged any of the remaining disabled password manager tests enough to know for sure what the cause of them is. I haven't filed any other bugs.

Flags: needinfo?(enndeakin)
Fission Milestone: ? → M4.1

FAIL Checking expected message - got "http://example.com is requesting your username and password. The site says: “schemeDowngrade”", expected "http://example.com is requesting your username and password. WARNING: Your password will not be sent to the website you are currently visiting!"

FAIL Checking expected message - got "https://example.org is requesting your username and password. The site says: “schemeUpgradeDedupe”", expected "https://example.org is requesting your username and password. WARNING: Your password will not be sent to the website you are currently visiting!"

This is a bug in Necko: https://searchfox.org/mozilla-central/rev/62a130ba0ac80f75175e4b65536290b52391f116/netwerk/protocol/http/nsHttpChannelAuthProvider.cpp#933-948,1181-1182 needs to properly compare the top level URI with the auth channel URI in a Fission-compatible way.

The prompt code then uses this flag at https://searchfox.org/mozilla-central/rev/62a130ba0ac80f75175e4b65536290b52391f116/toolkit/components/prompts/src/Prompter.jsm#324-325,353-357

Component: Password Manager → Networking: HTTP
Priority: P2 → --
Product: Toolkit → Core
Summary: test_prompt_http.html fails with fission enabled → test_prompt_http.html fails with fission enabled: Ci.nsIAuthInformation.CROSS_ORIGIN_SUB_RESOURCE not true in Fission
Blocks: 1582116

Once bug 1582116 lands, toolkit/components/passwordmgr/test/mochitest/test_prompt_async.html will also be fixed by this bug and should be enabled here.

User Story: (updated)
Summary: test_prompt_http.html fails with fission enabled: Ci.nsIAuthInformation.CROSS_ORIGIN_SUB_RESOURCE not true in Fission → test_prompt_http.html|test_prompt_async.html Fission failure: mCrossOrigin/Ci.nsIAuthInformation.CROSS_ORIGIN_SUB_RESOURCE isn't true

Junior, could you take a look at this?

Flags: needinfo?(juhsu)

In test_prompt_http.html,
The loadinfo from document channel child wrongly shows its a TYPE_DOCUMENT instead of TYPE_SUBDOCUMENT, which fails this check

Turning off document channel works well even if it's fission enabled. (i.e., document channel + fission would fail)
P1 since it looks bad that we could have wrong ExternalContentPolicyType.

Matt, is it a known issue?

Flags: needinfo?(juhsu) → needinfo?(matt.woodrow)
Priority: -- → P1

Junior, thanks for looking at this test. I'm tentatively assigning this bug to you until we determine whether it's a Necko bug or DocumentChannel bug.

Assignee: nobody → juhsu

Is this the same issue as bug 1594529?

Flags: needinfo?(matt.woodrow)

Yes, I believe it's the same issue. WIP patches fix test_prompt_http.html but leads crash in test_prompt_async.html
Thanks, Matt.

Depends on: 1594529

align priority with bug 1594529

Priority: P1 → P2

I don't see crashes in (test_prompt_async.html) when I also use the dependent patch: https://bugzilla.mozilla.org/show_bug.cgi?id=1583254 (https://phabricator.services.mozilla.com/D56220) do you have a try stack trace of that or platform details?

Flags: needinfo?(juhsu)

Ah I see the crash:

 3:37.65 GECKO(21767) [Child 22157, Main Thread] WARNING: This content process hasn't received the permissions for http://mochi.test:8888 yet: file /home/jonathan/projects/mozilla-unified/extensions/permissions/nsPermissionManager.cpp, line 3158
 3:37.65 GECKO(21767) Assertion failure: PermissionAvailable(prin, aType), at /home/jonathan/projects/mozilla-unified/extensions/permissions/nsPermissionManager.cpp:2284
[21738, Main Thread] WARNING: 'result.isErr()', file /home/jonathan/projects/mozilla-unified/startupcache/StartupCache.cpp, line 167
[21738, Main Thread] WARNING: 'result.isErr()', file /home/jonathan/projects/mozilla-unified/startupcache/StartupCache.cpp, line 167
[21738, Main Thread] WARNING: 'result.isErr()', file /home/jonathan/projects/mozilla-unified/startupcache/StartupCache.cpp, line 167
 3:38.71 GECKO(21767) #01: nsPermissionManager::CommonTestPermissionInternal(nsIPrincipal*, nsIURI*, mozilla::OriginAttributes const*, int, nsTSubstring<char> const&, unsigned int*, bool, bool) (/home/jonathan/projects/mozilla-unified/extensions/permissions/nsPermissionManager.cpp:2284)
Flags: needinfo?(juhsu)

Yes exactly the same.

Whiteboard: [necko-triaged]

Local test is passed. Let's see if treeherder happy

Pushed by juhsu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/764bc18cb7c4
enable fission with content policy fixed, r=mattwoodrow
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.