Closed Bug 1582743 Opened 1 year ago Closed 1 year ago

Update dav1d from upstream to commit c0865f3

Categories

(Core :: Audio/Video: Playback, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: achronop, Assigned: achronop)

References

Details

Attachments

(1 file)

Pick commits:

c0865f3 x86: add 32-bit support to SSSE3 deblock lpf
1e4e6c7 x86: add deblocking loopfilters SSSE3 asm (64-bit)
556890b AVX2 for chroma 4:2:0 film grain reconstruction
6d36322 Remove luma width check in fguv_32x32xn
99307bf Y grain AVX2 implementations
04ca711 Add film grain checkasm tests
b9d4630 Split out film grain block functions into a DSPContext
79c4aa9 obu: fix deriving render_width and render_height from reference frames
acad1a9 Silence some clang-cl warnings
69dae68 x86: Fix buffer overead in mc put
c0865f3 x86: add 32-bit support to SSSE3 deblock lpf
1e4e6c7 x86: add deblocking loopfilters SSSE3 asm (64-bit)
556890b AVX2 for chroma 4:2:0 film grain reconstruction
6d36322 Remove luma width check in fguv_32x32xn
99307bf Y grain AVX2 implementations
04ca711 Add film grain checkasm tests
b9d4630 Split out film grain block functions into a DSPContext
79c4aa9 obu: fix deriving render_width and render_height from reference frames
acad1a9 Silence some clang-cl warnings
69dae68 x86: Fix buffer overead in mc put
69dae68 x86: Fix buffer overead in mc put
a9315f5 x86: Increase precision of the final inverse ADST transform stages
e2702ea arm64: itx: Do the final calculation of adst4/adst8/adst16 in 32 bit to avoid too narrow clipping
c0e1988 Prefer __builtin_unreachable() over __assume() on clang-cl
666c71a Fix clang-cl assertion warning
e65abad arm: Fix assembling with older binutils
863c373 TileContext: reorder scratch buffer to avoid conflicts
bfc9f72 CI: use "needs:" to break the static build, test stage dependency
91b0af2 Apply high-bitdepth adjustment of pixel index after delta calculation
1ffbeda Use linear interpolation for high bit-depth pixel values
c09f107 Fix bugs in film grain generation
cfd6fe6 arm: mc: Making code style consistent
f01bbbd arm: mc: Push fewer registers in w_mask
c3e5ad0 arm: mc: Remove an unused instruction in w_mask
37a03fc Check absolute tile positions in sb-to-tile_idx table generation
2c1467b Use 64-bit integers for warp_affine mvx/mvy calculations
eeca6f2 x86: Fix inverse ADST transform overflows
70b66ff Optimize coef ctx calculations
a62c445 Consolidate horizontal scan tables
6757cab Change scan tables from int16_t to uint16_t
6751c98 Utilize the constraints in assertions to improve code generation
3d94fb9 arm64: mc: NEON implementation of w_mask_444/422/420 function
1dc2dc7 arm64: mc: NEON implementation of blend, blend_h and blend_v function
d20d70e Prefer `do {} while (0);` over `while (0);`
0f4edbf Cosmetics: CDF tables
61dcd11 x86: Add an msac function for coefficient hi_tok decoding
e29fd5c Add msac optimizations
a819653 Remove unused CDF:s
dff0a08 dav1dplay: abort if no input filename is provided
3a77c57 meson: move dav1dplay to a new examples section
42ea146 decode_coefs reuse lossless variable
ad0c041 Unroll hi_token loop in decode_coeff
5a4ae34 Quick out if seg_id == 0 in get_prev_frame_segid
d8799d9 Avoid CDF overreads in gather_top_partition_prob()
fa32f2d Set thread names on MacOS
6c3e85d Set thread names on Windows 10
b0d0002 arm: mc: Speed up due to memory alignment in ldr/str instructions
2ef970a checkasm: Catch SIGBUS in addition to the other signals
9a9c0c7 Export frame ITU-T T.35 Metadata
857232e Improve wiener filter C implementation using loop interchange
5f63e53 (tag: 0.4.0) dav1d 0.4.0
afee1ac tools: player: Add missing string.h header
4806492 Set thread names on BSDs
a0eb045 vsx: Add cdef_filter
60869f8 vsx: Add shorter types and unpack helpers
d12418b vsx: Set the correct alignment constraints
d04eab1 Update NEWS for 0.4.0
55e1edc Change SDL include in dav1dplay
407c27d arm: mc: neon: Merge load and other related operations in blend/blend_h/blend_v functions
d4df861 arm: mc: neon: Reduce usage of general purpose registers in blend/blend_v functions
b704a99 arm: mc: neon: Use vld with ! post-increment instead of a register in blend/blend_h/blend_v function
5ab6d23 tools: add a simple player example

In OSX I am getting a green screen for 10-bit images. It reproduces on a local build. I am looking.

Windows and Linux (x86_64) are fine for both 8-bit and 10-bit.

The green screen in the 10-bit images is an existing error, unrelated to this import. It has been regressed by Bug 1561178 according to mozregression. I will go on with this import and create a new bug for the green screen on AV1 10-bit images.

Pushed by achronopoulos@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0d0409a0f33a
Update dav1d from upstream to commit c0865f3. r=TD-Linux
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.