Closed Bug 1582833 Opened 2 months ago Closed 2 months ago

Some keyboard shortcuts and scrolling don't work after closing "find in page"

Categories

(Core :: Find Backend, defect)

71 Branch
Desktop
Unspecified
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: agashlin, Assigned: enndeakin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

  1. Run Firefox on a fresh profile with argument "example.com"
  2. Ctrl-F to bring up the find bar
  3. enter something (123)
  4. hit Esc to close the bar
  5. hit F5 to refresh; this doesn't work

Nothing shows up in Browser Console. Tested on Windows 10.

I found this regression range:

Last good revision: 5b303cb0a0a39e2bd4a6fea53535fe8e1d829b97
First bad revision: e33c3e14ee40f88d1775952e309dc2a617eb97f7
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5b303cb0a0a39e2bd4a6fea53535fe8e1d829b97&tochange=e33c3e14ee40f88d1775952e309dc2a617eb97f7

[Tracking Requested - why for this release]: UX regression in 71

Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Version: unspecified → 71 Branch

Neil, your patch in bug 1553384 seems to have caused this UX regression, could uou have a look please? Thanks

Flags: needinfo?(enndeakin)
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Summary: Some keyboard shortcuts don't work after closing "find in page" → Some keyboard shortcuts and scrolling don't work after closing "find in page"
Duplicate of this bug: 1582932

What is the status of the patch? This is a very annoying regression.

Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f7df0fca8536
update findbar state correctly when findbar is closed to allow keyboard to work properly, r=mikedeboer
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Duplicate of this bug: 1585040
You need to log in before you can comment on or make changes to this bug.