Closed Bug 1553384 Opened 9 months ago Closed 5 months ago

Make 'Find in page' work in fission world

Categories

(Core :: Find Backend, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox71 --- fixed

People

(Reporter: hiro, Assigned: enndeakin)

References

(Depends on 1 open bug, Blocks 3 open bugs)

Details

Attachments

(11 files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

nsWebBrowserFind.cpp and nsTypeAheadFind.cpp enumerate nsDocShellTreeItems, we need to replace it with using BrowsingContext (bug 1467214). We also need to make 'scrolling to a given frame rect' in fission (bug 1553012). I am not sure whether there are more tasks needed for fission.

No longer blocks: fission

CCing Mike de Boer and Brad Werth since he had touched those code.

Type: enhancement → defect
Priority: -- → P2
Assignee: nobody → enndeakin
Fission Milestone: --- → M4

I moved the WebBrowserFind parts to bug 1570965.

Two things still to do here:

  1. Fix up the RDFHelperChild.jsm (used for resist fingerprinting) as is detects findbar open/close messages
  2. The changes from tabbrowser.js to handle uninitialized findbar -- need to investigate what if anything needs to be done here
Attachment #9084032 - Attachment description: Bug 1553384, add a search subframes flag to the finder to opt in or out of subframe searching, r?mikedeboer → Bug 1553384, add a search subframes flag to the finder to opt in or out of subframe searching, r=mikedeboer
Attachment #9084034 - Attachment description: Bug 1553384, when not searching subframes, used for out-of-process child frames, disable modal highlighting, r?mikedeboer → Bug 1553384, when not searching subframes, used for out-of-process subframes, disable modal highlighting, r=mikedeboer
Attachment #9084036 - Attachment description: Bug 1553384, disable the modal highlight color when fission is enabled, r?mikedeboer → Bug 1553384, disable the modal highlight color when fission is enabled, r=mikedeboer
Attachment #9084047 - Attachment description: Bug 1553384, update find extension api to support out-of-process iframes. r?mixedpuppy → Bug 1553384, update find extension api to support out-of-process iframes. r=mixedpuppy
Attachment #9084043 - Attachment description: Bug 1553384, update findbar actors to inherit from JSWindowActor so that type ahead find works in out of process iframes, r?mikedeboer → Bug 1553384, update findbar actors to inherit from JSWindowActor so that type ahead find works in out of process iframes, r=mikedeboer
Attachment #9084041 - Attachment description: Bug 1553384, find should iterate over each frame within a document in the parent process to allow out-of-process frames to be searched through, r?mikedeboer → Bug 1553384, find should iterate over each frame within a document in the parent process to allow out-of-process frames to be searched through, r=mikedeboer
Attachment #9084050 - Attachment description: Bug 1553384, remove old find/findAgain methods in typeaheadfind in favour of a single find method, r?mikedeboer → Bug 1553384, remove old find/findAgain methods in typeaheadfind in favour of a single find method, r=mikedeboer
Attachment #9092509 - Attachment description: Bug 1553384, update letterboxing to be fission compatible now that findbar isn't using the message manager. Add a findbar open/close test for letterboxing, r=tjr → Bug 1553384, update letterboxing to be fission compatible now that findbar isn't using the message manager. Add a findbar open/close test for letterboxing, r=tjr,mconley
Blocks: 1581516
Blocks: 1581518

I landed this with an additional fix which I think will fix an intermittent orange I found at the last minute.

Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28490e71adab
add a separate method to typeahead find that allows searching only within a single frame. A mode argument is used instead of separate find/findAgain methods that can be used with different values on each child frame in sequence to... r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/2e7108b6bfc2
add a search subframes flag to the finder to opt in or out of subframe searching, r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/771094a651ca
when not searching subframes, used for out-of-process subframes, disable modal highlighting, r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/76e59e4beb07
disable the modal highlight color when fission is enabled, r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/2c1d142dbc8a
when subframe iteration is not used, don't navigate up to the top window in the find highligher. However, as fission doesn't handle getting frame coordinates yet, allow some callers to get the top window anyway if available so that... r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/ea3cbf08fa69
find should iterate over each frame within a document in the parent process to allow out-of-process frames to be searched through, r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/46f35eae82f6
update findbar actors to inherit from JSWindowActor so that type ahead find works in out of process iframes, r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/3977d67dc67a
update find extension api to support out-of-process iframes. r=mixedpuppy
https://hg.mozilla.org/integration/autoland/rev/21aa59810375
remove old find/findAgain methods in typeaheadfind in favour of a single find method, r=mikedeboer
https://hg.mozilla.org/integration/autoland/rev/656e05faba49
update letterboxing to be fission compatible now that findbar isn't using the message manager. Add a findbar open/close test for letterboxing, r=mconley
https://hg.mozilla.org/integration/autoland/rev/e33c3e14ee40
fix intermittent orange caused by fission changes, by waiting for page and findbar to be ready
Regressions: 1582833
Regressions: 1582932
Regressions: 1589519
Regressions: 1602033
Regressions: 1603020
Regressions: 1606406
Regressions: 1606392
Regressions: 1613097
You need to log in before you can comment on or make changes to this bug.