Closed Bug 1583055 Opened 9 months ago Closed 8 months ago

Today Pane: Messed up and scrambled content dislpay, it shows events in the far past without their headers, or disappears completely

Categories

(Calendar :: Calendar Views, defect)

Lightning 68
x86_64
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1560547

People

(Reporter: roland_schweiger, Unassigned)

References

Details

(Keywords: calendar-integration)

Attachments

(6 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Steps to reproduce:

Updated from Thunderbird 60.9 to 68.1.0
Lightning 68.1.0
ProviderForGoogleCalendar 68.0
gContactSync 3.1.7
ProviderForExchangeActiveSync 1.5
TBSync 2.4

English(Australian) dictionary 2.2.1webext
German Dictionary 2.0.6.1webext
Language Pack Deutsch (German) DE 68.0build 20190909201201

Using 2 Google accounts for calendar - task - and contact sync

PROBLEM

Calendar synchronisation and calendar view seem to work ok.

BUT the SIDE-BAR on the right-hand side of Thunderbird (in German called "Tagesplan") does NOT work properly.

It randomly shows up after opening Thunderbird, and it randomly disappears after opening Thunderbird.
It also displays garbage e.g. dates way long in the past.

What i did notice:

The calendar side-bar seems to work ok ONLY IF A CALENDER TAB IS ALWAYS OPENED.

So if a tab showing the Lightning calender is open all the time then Thunderbird will properly display the side-bar (or daily agenda or what it is called in english) - the little pane on the right hand side that can e.g. show 5 days ahead.

Please address this issue because it is very very confusing at first glance.

Actual results:

When Thunderbird is in a state where NO CALENDAR TAB IS OPENED but the calendar side-bar on the right-hand-side should be displayed, it will not display properly.
The side-bar (daily agenda) will either disappear, or re-appear with wrong dates way long in the past, actual garbage content.

It seems that the side-bar will only display correctly IF a calendar TAB is always open.

Expected results:

The side-bar should have displayed correctly todays (and a few days in future) appointments or tasks.

Unfortunately the calendar side-bar also behaves randomly faulty, EFEN IF A CALENDAR TAB IS OPEN all the time. Just noticed this by several times closing and re-opening Thunderbird. So even when a calendar tab stays open at the top toolbar of Thunderbird, the calendar side-bar on the right hand side only works sporadically, rendering it unusable and unreliable for the moment.

Component: Untriaged → Calendar Views
OS: Unspecified → Windows 10
Product: Thunderbird → Calendar
Hardware: Unspecified → x86_64
Version: 68 → Lightning 7.0

There is a known sporadic problem (Bug 1560547) with Lightning 68. As a workaround try to restart Thunderbird. Sometimes it works afterwards. Does the problem shown in Bug 1560547 matches your description of "behaves randomly faulty"?
If the today pane shows old events try clicking the circle shaped button to set it to today. Maybe it was manually set to a specific day before?

Flags: needinfo?(roland_schweiger)
Summary: Calendar side-bar only works properly IF a calender-tab is open, else it displays nonsense or disappears → Today Pane: Calendar side-bar only works properly IF a calender-tab is open, else it displays nonsense or disappears

No the described issue does not (or at least not fully) match the description in Bug 1560547.
Sometimes when opening Thunderbird, the side-bar (today pane) does not show at all, although it is marked to show in the view menu.
Sometimes it will show correctly, then sometimes it will show, it will show the today date but instead display old events.
When this happens, clicking the circle-symbol (or the back / forward buttons of the today pane) will not do anything, the pane seems to be copmpletely frozen.

Flags: needinfo?(roland_schweiger)
Attached image todaypane_wrong.jpg

This screenshot shows a typical symptom right after opening Thunderbird.
The today-pane (side-bar) shows today's date, but the events underneeth are totally random:
The 1st one "Neujahrstag" (= Ney years day) dates to January 1st 2018.
The second one "Kühl-Kombi ElektraBregenz" dates to May 5th 2013!
The third one is a birth date and refers to november 11th 2018
and so on.
Klicking the circle or back/forward buttons in the pane, has no effect at all.

Attached image TodayPane_correct.jpg

This screenshot is the example of a CORRECT view of my today-pane.
Compare it to the image in my other attatchment "todaypane_wrong";
here the coming-up appointments are properly shown.
I had closed/opened tha calendar tab, closed-opened Thunderbird.
Next time when re-opening thunderbird, the "wrong" today-pane will show again, or the pane disappears completely.
BTW i have NO vicus-scanner scanning my profile folders so we can exclude a problem arising from there.

Attached image Lightning_Ver68_0.jpg

Just uninstalled and re-installed Lightning. Although i use Thunderbird 68.1.1, when re-installing Lightning by searching in the add-ons, it offers me Lightning Version 68.0 Is this correct? Quite confusing because i thought that starting from Thunderbird 68.x Lightning should have exactly the same build version numbers?
Anyhow the problem persists. The "today pane" only works sporadically and unreliable.

Attached image TB_ver_68_1_1.jpg

als you see, using Thunderbird 68.1.1 - and after un- / re-installing Lightning, Lightning does revert to Version 68.0

You can force Thunderbird to use the built-in Lightning version following steps from https://support.mozilla.org/en-US/kb/calendar-updates-issues-thunderbird#w_when-i-use-my-user-profile-from-a-previous-thunderbird-version-with-a-newer-version-of-thunderbird-lightning-is-not-updated

  1. Remove Lightning Extension in the Add-ons Manager and restart Thunderbird twice
  2. Open Options > Advanced > Config Editor...
  3. Search for preference extensions.installedDistroAddon.{e2fda1a4-762b-4020-b5ad-a41df1933103}
  4. Right click and Reset the preference
  5. Restart Thunderbird

Just did that, and after resetting freference.extensions.installedDistroAddon.{e2fda1a4-762b-4020-b5ad-a41df1933103} and finally restarting Thunderbird, it did automatically re-install Lightning 68.1.1 corrspoinding it to thunderbird 68.1.1
My calendars (from google accounts that were added in the add-on ProviderForGoogleCalendar) all re-appear.

The problem with the today-pane unfortunately persists.

Duplicate of bug 1560547?

though i cannot fully reliably judge, this is most-likely NOT a duplicate of Bug 1560547
The today-pane behaves randomly when set to show in the View-menu. Sometimes after opening TB it will come up, sometimes it will show the correct agenda of today and the upcoming days, then on next time startup of TB, it will show events way in the past, without its headers.
So there are similarities to the described bug 1560547 but they are not the same.
i will include a screenshot of the error console.

this appears in the error-console right after obenin TB and right after TB shows a totally messed-up today-pane, with events way in the past, and missing headers of those events.

Summary: Today Pane: Calendar side-bar only works properly IF a calender-tab is open, else it displays nonsense or disappears → Today Pane: Messed up dislpay, it shows events in the far past without their headers, or disappears completely
Attached image scrambled today-pane

I can confirm this issue. But it also happens when Calendar is opened.
Thunderbird 68.1.1 (32-bit), Lightning 68.1.1, Windows 10 (1903)

Summary: Today Pane: Messed up dislpay, it shows events in the far past without their headers, or disappears completely → Today Pane: Messed up and scrambled content dislpay, it shows events in the far past without their headers, or disappears completely

I've recently seen this using Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.1.1 on Ubuntu 18.04 LTS.

It is intermittent, the item showing in the Today pane is Independence Day, and a restart of Thunderbird fixes the problem for me.

I was mistaken about being able to reproduce this on Linux.

The problem is with TB 68.1.1 and Provider for Google Calendar 68.0 on Windows 10

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 10 → All
Duplicate of this bug: 1586128

I have tried restarting Thunderbird and opening a calendar tab and nevertheless the Today Pane shows vastly outdated information and will not respond to clicking on other dates, clicking the "go to today" circle, or any other effort to get it to properly display calendar data. Thank you for working to address this as it makes using the calendar very frustrating.

UPDATE: I tried closing Thunderbird with the calendar tab displayed. When I restarted the calendar tab was no longer showing but the Today Panel was functioning correctly! I opened and then closed the calendar tab and it continued to display correctly. I dare not close Thunderbird but for the moment, it works. Still needs a fix, however, but I hope this additional information helps.. Thank you!

I recently fired up my Windows 10 laptop with Thunderbird 68.1.1, Lightning 68.1.1 and Provider for Google Calendar 68.0 installed.

Started Thunderbird and the Today pane was showing "Independence Day" of 2017. No other items from other subscribed Google calendars.

Unsubscribed from the US Holiday calendar, restarted and the holiday was gone but the Today pane was blank.

I noticed that my Linux Thunderbird 68.1.1 has Provider for Google Calendar version 68.1.0.

Tried checking for updates from within the Add-ons Manager in my TB on Windows and none were found.

I have the gdata-provider.en=US.xpi version 68.1.0 saved on my backup USB stick, so I plugged it into my Windows computer, used "Install from file" from within the Add-ons Manager, restarted and all is well now.

Roland, info, jrschacht2 are you all using Provider for Google Calendar version 68.0?

Phillip, How do they get version 68.1.0?

Never mind. I just found Version 68.1.1

Flags: needinfo?(jrschacht2)
Flags: needinfo?(info)

yes i am using ProviderForGoogleCalendar 68.0 and Thunderbird 68.1.1 and no newer version is offered.
currently i don't want to try out providerForGoogleCalendar 68.1.1 as it is the us version and it might mess up languages?
also i am not certain if providerForGoogleCalendar is the cause of the problem.

(In reply to Roland Schweiger from comment #19)

yes i am using ProviderForGoogleCalendar 68.0 and Thunderbird 68.1.1 and no newer version is offered.

That might be a bug.

currently i don't want to try out providerForGoogleCalendar 68.1.1 as it is the us version and it might mess up languages?

As far as I know there is only the en-US version of the gdata-provider extension.

also i am not certain if providerForGoogleCalendar is the cause of the problem.

I installed the 68.1.0 version I had and restarted Thunderbird multiple times without a problem.
Updated Windows 10 and restarted.
Started Thunderbird and could not reproduce the problem.
Installed the 68.1.1 version and restarted. Still working.
Quit and restarted several times without a problem.
So I'm pretty sure having an old version of the extension was the cause of the problem.

Maybe depends on bug 1560547 or a duplicate?

no it did NOT resolve the problem. Just installed ProviderForGoogleCalendar Version 68.1.1 from this link
https://archive.mozilla.org/pub/thunderbird/releases/68.1.1/en-US/
and now thunderbird and ProviderForGoogleCalendar are Version 68.1.1 and only difference is that the calendar provider now is in English.

However problem persists.
The today-pane behaves randomly and on my system exactly as before.
Sometimes after restart of TB the today-pane completely disappears, sometimes it shows very old holidays and refuses to accept clicks.
Sometimes it tends to stick to the calender-tab and will close, as soon as i close the calendar tab.

Whatever causes the problem (as stated, i am not sure if ProviderForGoogleCalendar really is the cause), it should be addressed because it makes the today-pane practically unusable.

(In reply to WaltS48 [:walts48] from comment #18)

I recently fired up my Windows 10 laptop with Thunderbird 68.1.1, Lightning 68.1.1 and Provider for Google Calendar 68.0 installed.

Started Thunderbird and the Today pane was showing "Independence Day" of 2017. No other items from other subscribed Google calendars.

Unsubscribed from the US Holiday calendar, restarted and the holiday was gone but the Today pane was blank.

I noticed that my Linux Thunderbird 68.1.1 has Provider for Google Calendar version 68.1.0.

Tried checking for updates from within the Add-ons Manager in my TB on Windows and none were found.

I have the gdata-provider.en=US.xpi version 68.1.0 saved on my backup USB stick, so I plugged it into my Windows computer, used "Install from file" from within the Add-ons Manager, restarted and all is well now.

Roland, info, jrschacht2 are you all using Provider for Google Calendar version 68.0?

Phillip, How do they get version 68.1.0?

Never mind. I just found Version 68.1.1

I am using TBird and Lightning 68.1.1 and PGC 68.0 which when I tried updating said there were no further updates. I see now your link for PGC 68.1.1; however, after I opened the calendar, then the Today Pane, since that point it has been working properly even with the calendar tab closed. So I dare not fool with it further! I have not restarted TB, however, and if the Today Pane is no longer working when I do, that's the next step I'll take. Thanks very much to all for troubleshooting this irritating problem!

Flags: needinfo?(jrschacht2)

GDATA Provider = ProviderForGoogleCalendar ??

This is slightly confusing to me. As mentioned, i did download ProviderForGoogleCalendar 68.1.1 and unfortunately it did not change the problem.

What is confusing: when trying to read the FAQ (of ProviderForGoogleCalendar), it redirects to a GitHub site.
And on that GitHub site, the plugin seems to have changed name.
It is now called GDATA Provider?
But the Thunderbird add-on manager still calls it ProviderForGoogleCalendar.

Can someone please explain?

I do not have installed ProviderForGoogleCalendar, but nevertheless the problem exists. So I disbelieve that there is any relation.

Th issue on my computer is exactly as described in comment 21.

Flags: needinfo?(info)

(In reply to info from comment #24)

I do not have installed ProviderForGoogleCalendar, but nevertheless the problem exists. So I disbelieve that there is any relation.

The issue on my computer is exactly as described in comment 21.

so it is safe to agree that ProviderForGoogleCalendar is NOT the cause of the issue.

As sated above this is most likely the same problem as in Bug 1560547. Just wait until Lightning 68.1.2 is released that contains the possible fix / workaround from Bug 1560547.

Thanks for the feedback Roland, info and jrschacht2.

I'm mystified as to why disabling the network calendar and restarting Thunderbird solved it for me in Thunderbird on Windows 10.
Noticing that the extension was 68.0. I thought that might be the reason.
I haven't been able to reproduce the problem after installing the gdata-provider.xpi version 68.1.1 extension.

Windows 10 64bit
Thunderbird win32 version 68.1.0
installed Provider for Google Calendar 68.0

Calendar tab closed - Opened Today Pane - empty and date selector > no effect.
Opened Calendar, calendar both local and gmail ok but Today Pane non functional - same as before.

Exit Thunderbird with Today Pane open.
Restart and Today Pane flashes and closes.
Needs double click to open, but still void of info.

Restarted with 'Provider for Google Calendar' disabled and all ok.

Then enabled 'Provider for Google Calendar' and restarted to fully enable - still ok
Any subsequent restarting Thunderbird and Today Pane flashes and closes - up the creek as before and double clicks required to open an empty Today Pane.
So disable addon again.

Next day:
In Addons - enabled 'Provider for Google Calendar'
About > Thunderbird > select to update to 68.1.1
update installs
Then restart to enable the addon and complete update.

Today Pane seems ok. It shows correct content, date functional .

Exit and restart Thunderbird.
Today Pane flashes and disappears.
Double click to select and it is void and useless again.

So it looks like I'll have to put up with non functioning Today Pane until Lightning 68.1.2 is up and running.

I have a simple Thunderbird 68.1.1 with built in Lightning. It also has the corruption or missing "Today Pane". I have done everything listed, it doesn't work.

On another bug report someone reported that they could get the "Today Pane" to return (It will eventually disappear again).

I am repeating it here so that others can get the "Today Pane" back. It works at least on Windows 10.

You have Thunderbird up and it has either a corrupted or missing "Today Pane".

  1. Bring up a "Write" email window.
  2. Close the main Thunderbird window. (The "Write" window will still be open)
  3. While the "Write" window is still up, reopen the Thunderbird.
  4. Close the "Write" email window.

The "Today Pane" should return, but eventually it will go away again, and you have to repeat the process.

Confirm: molto.libri comment 30.
Opening Write and leave window open, exit main and reopen does force Today Pane to now contain all correct info and functionality as a short term temp fix.

Error console emptied.
Exit Thunderbird and all windows fully closed. Restart.
Contents of error console below just in case it is of any use.

statusPrivacy is null gdata-event-dialog.js:40
<anonymous> chrome://gdata-provider/content/gdata-event-dialog.js:40
loadScript resource:///modules/Overlays.jsm:561
load resource:///modules/Overlays.jsm:226
load resource:///modules/Overlays.jsm:48
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:242
forEach self-hosted:266
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:236
AsyncFunctionNext self-hosted:839
fetchOverlay resource:///modules/Overlays.jsm:512
load resource:///modules/Overlays.jsm:101
load resource:///modules/Overlays.jsm:48
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:242
forEach self-hosted:266
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:236
InterpretGeneratorResume self-hosted:1284
AsyncFunctionNext self-hosted:839
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use _paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "setDocumentTitle", "www.thunderbird.net/Thunderbird — Release Notes (68.1.1) — Mozilla" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:3
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use _paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "setTrackerUrl", "//thunderbird.innocraft.cloud/piwik.php" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:4
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use _paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "setSiteId", "1" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:5
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use _paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "setCookieDomain", "*.thunderbird.net" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:6
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use _paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "setDownloadClasses", "download-link" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:7
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use _paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "trackPageView" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:8
_paq.push() was used but Piwik tracker was not initialized before the piwik.js file was loaded. Make sure to configure the tracker via _paq.push before loading piwik.js. Alternatively, you can create a tracker via Piwik.addTracker() manually and then use paq.push but it may not fully work as tracker methods may not be executed in the correct order.
Array [ "enableLinkTracking" ]
piwik.js:169:376
push https://www.thunderbird.net/media/js/piwik.js:169
<anonymous> https://www.thunderbird.net/media/js/matomo.js:9
RangeError: date value is not finite in DateTimeFormat.format() minimonth.xml:727:70
TypeError: aPeriod.start is undefined agenda-listbox.js:286:29
setOccurrence chrome://calendar/content/agenda-listbox.js:286
addItemBefore chrome://calendar/content/agenda-listbox-utils.js:309
addItem chrome://calendar/content/agenda-listbox-utils.js:359
onGetResult chrome://calendar/content/agenda-listbox-utils.js:648
onGetResult jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:528
queueItems jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:777
getItems
jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:962
getItems jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:691
postPone resource://calendar/modules/calUtils.jsm:241
getItems jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:690
funcName resource://calendar/calendar-js/calCachedCalendar.js:973
getItems jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:397
execute chrome://calendar/content/agenda-listbox-utils.js:698
refreshCalendarQuery chrome://calendar/content/agenda-listbox-utils.js:707
onLoad chrome://calendar/content/agenda-listbox-utils.js:910
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:44
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad resource://calendar/calendar-js/calCachedCalendar.js:75
execResponseFunc resource://calendar/calendar-js/calCachedCalendar.js:322
forEach self-hosted:266
emptyQueue resource://calendar/calendar-js/calCachedCalendar.js:327
onResult resource://calendar/calendar-js/calCachedCalendar.js:357
replayChangesOn jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}.xpi!/components/calGoogleCalendar.js:795
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 286}]'[JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 286}]' when calling method: [calIOperationListener::onGetResult] 3 calCompositeCalendar.js:528
Assert failed: [Exception... "[JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 286}]'[JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 286}]' when calling method: [calIOperationListener::onGetResult]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D.xpi!/components/calCompositeCalendar.js :: onGetResult :: line 528" data: yes]
calUtils.jsm:139
TypeError: rangeStart is null calRecurrenceInfo.js:426:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 426}]'[JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 426}]' when calling method: [calIRecurrenceInfo::getOccurrences] calStorageCalendar.js:797
Assert failed: [Exception... "[JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 426}]'[JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 426}]' when calling method: [calIRecurrenceInfo::getOccurrences]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D.xpi!/components/calStorageCalendar.js :: handleResultItem :: line 797" data: yes]
calUtils.jsm:139
ASSERT resource://calendar/modules/calUtils.jsm:139
getItems jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:400
execute chrome://calendar/content/agenda-listbox-utils.js:698
refreshCalendarQuery chrome://calendar/content/agenda-listbox-utils.js:707
onLoad chrome://calendar/content/agenda-listbox-utils.js:910
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:44
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad resource://calendar/calendar-js/calCachedCalendar.js:75
execResponseFunc resource://calendar/calendar-js/calCachedCalendar.js:322
forEach self-hosted:266
emptyQueue resource://calendar/calendar-js/calCachedCalendar.js:327
onResult resource://calendar/calendar-js/calCachedCalendar.js:357
replayChangesOn jar:file:///C:/Users/Anje/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}.xpi!/components/calGoogleCalendar.js:795

(In reply to molto.libri from comment #30)

I have a simple Thunderbird 68.1.1 with built in Lightning. It also has the corruption or missing "Today Pane". I have done everything listed, it doesn't work.

On another bug report someone reported that they could get the "Today Pane" to return (It will eventually disappear again).

I am repeating it here so that others can get the "Today Pane" back. It works at least on Windows 10.

You have Thunderbird up and it has either a corrupted or missing "Today Pane".

  1. Bring up a "Write" email window.
  2. Close the main Thunderbird window. (The "Write" window will still be open)
  3. While the "Write" window is still up, reopen the Thunderbird.
  4. Close the "Write" email window.

The "Today Pane" should return, but eventually it will go away again, and you have to repeat the process.

I can't reproduce this using Thunderbird 68.1.1, Lightning 68.1.1 and Provider For Google Calendar 68.1.1.

It seems that the issue was fixed in Thunderbird 68.1.2 and Lightning 68.1.2. The Today Pane is no longer scrambled on my computer.

same here. Thunderbird 68.1.2 and Lightning 68.1.2 no longer show the problem. The today-pane appears to work fine for now, and i re-started Thunderbird several times.
There is a little problem with language implementation: Lightning is in German, so e.g. when right-pressing in the calendar view, it will offer me "Neuer Nermin" (new appointment) but when inside an appointment, it will offer me "reminder" instead of "Erinnerung" so some bits of Lightning remain in English, when in the German version.
But most important : the problem with the today-pane seems to be fixed, in my described setup.
Many thanks.

Confirm - Thunderbird 68.1.2 and Lightning 68.1.2 no longer show the problem.

It appears this is fixed by 1560547 and a duplicate..

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1560547
You need to log in before you can comment on or make changes to this bug.