Closed Bug 1560547 Opened 6 months ago Closed 2 months ago

Today Pane: No events shown in today pane and missing section headers (today, tomorrow, upcoming x days)

Categories

(Calendar :: Calendar Views, defect)

Lightning 68
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image today_pane.png

Thunderbird 69.0a1 (20190621081202) with Lightning 7.1 on Windows 10

Created a fresh profile and noticed that the today pane is missing its section headers like Today, Tomorrow, Upcomging x Days. New created events do not show up in the today pane.

Error Console shows the following error without stack:

RangeError: date value is not finite in DateTimeFormat.format() minimonth.xml:722:70

Duplicate of this bug: 1561452

Changing version to Lightning 7.0 according to duplicate bug report.

Version: Lightning 7.1 → Lightning 7.0
Duplicate of this bug: 1560283

Last unresolved bug blocking meta bug 1556222.

Any idea?

Flags: needinfo?(geoff)

We still don't know what causes this or how to reproduce it. It's been quite a while since I last saw it though, so maybe it's gone away?

Flags: needinfo?(geoff)

No, it hasn't gone away, it's still present in TB68b5. I do see it with both, Windows and Linux. It's not exactly reproducible though.

So far I haven't seen the problem with TB69b1.

I've managed to get this to fail again and cough up a stack. With line numbers corrected:

I'm still confused though. There's an infinite value coming from somewhere. It surely has to be either cal.dtz.now() in onLoad, aNewDate.clone() in setDay, or cal.dtz.dateTimeToJsDate(this.start) in setDay.

Duplicate of this bug: 1579665

I'm using TB 68.0 and I'm seeing this regularly. When a meeting notice opens, that can sometimes cause the Today Pane to populate, other times, it will populate when TB starts up. From the behavior, it acts like an uninitialized variable is being used in the code somewhere, but that is just a wild guess on my part. Another guess is that the uninitialized variable may not be a date value, but is related to something else.

I'm also seeing things like on Start TB used to download from all three of my email servers at the same time. I was seeing some messages duplicated multiple times; while other messages had no sender, a date like 12:59 1969, and nothing in the body of header areas when I clicked on the messages. I would sometimes find garbled HTML from an unrelated email appended to the end of a good email from someone else. This was intermittent, but not infrequent. I turned off the download on startup function and set all three of the account configurations to download at relatively prime intervals (so they wouldn't download at the same time). This seems to have helped.

Removing the MSF files and letting TB rebuild didn't resolve the issue of corrupted emails which I can see exist, but can't read. The existing corrupted emails couldn't be recovered, and some proved very hard to delete.

I'm also seeing that plugins that were working just find are now reported as not compatible. I've not found a work around for this yet. Many of these plugins were real time savers (Xpunge) or otherwise relied on for daily use.

Lastly, TB 68.0 doesn't seem very stable and certainly isn't very fast in its execution. The latest version seems to take far longer to do simple things like move emails to new folders, or even to start up. I don't know if any of these issues are directly related to the subject of this ticket, but since they all occurred around the same time, I would assume they might be.

Please contact me if I can be of any help in debugging this issue.

(In reply to wilson from comment #10)
Hi, this bug report handles only the sporadic Today Pane issue in Lightning extension. If you see other issues with Thunderbird 68 please report them as separate bug reports (one issue per report) to make Thunderbird developers aware of them.

I understand the bug report is specific to the Today Pane; however, based on the notes, it is stated that no one has an idea of what is causing this bug. I included the larger context information in the hope that it might spark an idea. If the information is not helpful, please feel free to ignore it.

Currently TB 68.0 is not stable and really isn't very useful due to the issues listed here. I look forward to future improvements as I would hate to have to abandon such a necessary and successful product.

Duplicate of this bug: 1580823

I've updated to Thunderbird 68.0.1 and the issue is still present.

You mean 68.1.0. This bug hasn't been fixed, so the issue is likely still present.

I found disabling Lightning, then re-enabling it and restarting Thunderbird brought it back, but it is a chore every time to do that. Any Easier workarounds?

(In reply to Gary C Curtin from comment #16)

I found disabling Lightning, then re-enabling it and restarting Thunderbird brought it back, but it is a chore every time to do that. Any Easier workarounds?

Doing away with the 2 separate sets of code will make sure there are no longer syncing issues. Then, it will be a matter of maintaining the code itself, instead of managing matchups of 2 different products. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1493008

(In reply to Worcester12345 from comment #17)

Doing away with the 2 separate sets of code will make sure there are no longer syncing issues. Then, it will be a matter of maintaining the code itself, instead of managing matchups of 2 different products. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1493008

My question was for an easier workaround than taking a minute to disable - restart - enable - restart. Seems what you are proposing is neither a workaround, nor easy.

It is the fix which will avoid needing a workaround, or the disable - restart - enable - restart process you used.

(In reply to Worcester12345 from comment #19)

It is the fix which will avoid needing a workaround, or the disable - restart - enable - restart process you used.

All well and good, but not an answer to my question. Better you give a recipe for chicken soup.

I asked for any easier workaround than what I described. Easier, as defined by the Oxford English dictionary means not difficult. I have no programming knowledge, so to attempt what you are suggesting is going to be almost impossible for me, and even if it is possible, it will take months for me to first learn, and then if possible, re-write the code used in Thunderbird. That is certainly not easier.

I don't know if this is the same issue, but I have a similar thing going on.

When I open Thunderbird, sometimes the Today Pane closes itself on its own (it doesn't retain its "open" status). When I try to reopen it, the Today Pane button is first unresponsive, and then if I click it again, I get a calendar that's missing the events from my main calendar (my primary Google Calendar). What's odd is that my automatic "Birthdays" calendar and my manual entry "Annual" Google calendar did show up in the Today Pane. It's just missing the information from the main calendar.

I don't have to disable/enable Lightning or reinstall it to fix it. If I close and reopen Thunderbird once to a few times, the issue sometimes fixes itself.

(In reply to R. Hansen from comment #21)

I don't know if this is the same issue, but I have a similar thing going on.

Using Thunderbird 68.1.0 and whatever the latest version of lightning is. I did a manual update of add-ons. Windows 10 1903 if that matters.

Same here both with 68.0 and 68.1. Restarting sometimes solves it, and it seems to work most of the time if (on Linux) I do
export LANG=C
before starting thunderbird.
So it really seems locale / timezone related?

It is my habit to defragment my hard drive and shut down my system every evening. When I boot up and start TB the next morning, the Today Pane populates as expected. If I exit ThunderBird and restart, the Today Pane does not display normally. I hope this may help in debugging.

Duplicate of this bug: 1583060
Summary: No events shown in today pane and missing section headers → Today Pane: No events shown in today pane and missing section headers (today, tomorrow, upcoming x days)

Okay, I'm totally fed up with this bug still existing. The only plausible explanation that I can think of is that the call to aNewDate.clone() in TodayPane.setDay some how misfires and returns a Date object with a value at or near 8.64×10¹⁵, which is the upper bound of a valid date. But that would produce other visual errors which I have not seen.

With this patch I propose to log the thrown exception and carry on as if it hadn't happened. It's better than what we have at the moment.

(Note: on ESR the string "today-minimonth" needs to be "today-Minimonth".)

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9095064 - Flags: review?(paul)
Attachment #9095064 - Flags: approval-calendar-esr?(paul)
Attachment #9095064 - Flags: approval-calendar-beta?(paul)
Attachment #9095064 - Flags: review?(paul)
Attachment #9095064 - Flags: review+
Attachment #9095064 - Flags: approval-calendar-esr?(paul)
Attachment #9095064 - Flags: approval-calendar-esr+
Attachment #9095064 - Flags: approval-calendar-beta?(paul)
Attachment #9095064 - Flags: approval-calendar-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9c450141450d
Catch exception in Today Pane start-up. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Jorg K,
Does "Target Milestone: --- → 71" mean the fix will be part of a Thunderbird/Lightning version 71.x update? I am using Thunderbird/Lightning 68.1.1 and am experiencing this issue.

We'll backport it to TB 68.2. Watch this space.

You the man! Thank you.

TB 70 beta 3:
https://hg.mozilla.org/releases/comm-beta/rev/65017536f6e191483ee64ff70416244a733aa2f9

Bill, don't worry, the uplift for TB 68.2 will come. We're doing a beta before that. One word of caution: Since the issue isn't 100% understood, there is a chance that the fix isn't going to be as effective as you'd wish :/

Target Milestone: 71 → 70

TB 68.1.2 or TB 68.2 / Cal 7.0:
https://hg.mozilla.org/releases/comm-esr68/rev/473844ac508f35cee4f3b2c457dfc9bf7fc4cf6c

Bill, would you be interested in a TB 68.1.2 pre-release for testing?

Target Milestone: 70 → 7.0

It is kind of you to offer (and thanks for all you do to keep TB working). I won't be able to try it until tomorrow, though. If that works with your timeline, just let me know how to get it. Thanks!

Bill, what's your platform, Windows? 32 or 64 bit? - I mean for the binary, not the OS. Mac? Linux?

Of course (doh, from me). Linux 64-bit (openSUSE Tumbleweed and Leap 15.1).

(In reply to Jorg K (GMT+2) from comment #32)

TB 68.1.2 or TB 68.2 / Cal 7.0:
https://hg.mozilla.org/releases/comm-esr68/rev/473844ac508f35cee4f3b2c457dfc9bf7fc4cf6c

I get the following error with 68.1.2 (Build ID 20190929203249) during call to document.getElementById("today-minimonth"):

TypeError: document.getElementById(...) is null today-pane.js:126:20
updateDisplay chrome://calendar/content/today-pane.js:126
onModeModified chrome://calendar/content/today-pane.js:458
ltnOnLoad chrome://lightning/content/messenger-overlay-sidebar.js:406
AsyncFunctionNext self-hosted:839

According to Comment 26 we need a different patch for ESR branch with today-Minimonth instead of today-minimonth.

Flags: needinfo?(jorgk)

That's what I did:
https://hg.mozilla.org/releases/comm-esr68/rev/473844ac508f35cee4f3b2c457dfc9bf7fc4cf6c#l1.12

-      document.getElementById("today-Minimonth").value = cal.dtz.dateTimeToJsDate(this.start);
+      try {
+        // The minimonth code sometimes throws an exception as a result of this call. Bug 1560547.
+        // As there's no known plausible explanation, just catch the exception and carry on.
+        document.getElementById("today-Minimonth").value = cal.dtz.dateTimeToJsDate(this.start);
+      } catch (ex) {
+        Cu.reportError(ex);

but the patches in bug 1568723 and bug 1569513 were wrong :-(

Flags: needinfo?(jorgk)

Sorry, I only remembered reading about this therefore I posted it here. Is there a code search for comm-esr68 available, similar to https://searchfox.org/comm-central/source/?

Bill, as you can see, we need to fix some more stuff. On Linux we provide a tar.bz2 - Would you know how to run TB from that?

Stefan, not so far, but there are bugs to add it to DXR (or maybe not) and Searchfox (bug 1577406).

Maybe unrelated... but I'm finding this triggered with the CardBook extension.

If I disable CardBook and restart, all is normal.
If I re-enable CardBook and restart, Today Pane Event display is broken.

(In reply to shop.now from comment #41)

Maybe unrelated... but I'm finding this triggered with the CardBook extension.

I have this problem but I don't have the CardBook extension installed.

This seems to be a start-up issue. When starting Thunderbird, the calendar seems to have a delay before it starts. I often will see the Calendar tab come up delayed, and the Today Pane flash up and close. When Cardbook is enabled, I think that this increases the delay error/effect. An optional method of getting the Today Pane to show properly is to 1) Start Thunderbird, 2) Hit "Write" to start composing an email, 3) Close the main Thunderbird window, 4) Open Thunderbird. (I'm using Windows 10 64-bit with 64-bit Thunderbird.) When Thunderbird/Lightning are already in memory, opening the main window works. When Thunderbird is starting, it may or may not fail, and fails more with CardBook installed.

This seems to be a start-up issue. When starting Thunderbird, the calendar seems to have a delay before it starts.

Perhaps this is then affected by the number of extensions, and in which order they load?

(In reply to shop.now from comment #44)

Perhaps this is then affected by the number of extensions, and in which order they load?

It also appears when there are no extensions besides Lightning.

Hey guys, in a few hours I'll provide a preview version of TB 68.1.2 and then you can all try whether the issue is fixed.

(In reply to Jorg K (GMT+2) from comment #39)

Bill, as you can see, we need to fix some more stuff. On Linux we provide a tar.bz2 - Would you know how to run TB from that?

If it helps you, I should be able to handle a tar.bz2 file. I'd remove the existing TB rpm beforehand. Looks like quite a bit of testing has already occurred. Good luck!

A few things I can add. I only have two extensions in TB: Lightning and ImportExportTools NG (which I really no longer need). I also have the network calendar, USHolidays, provided by https://www.thunderbird.net/media/caldata/USHolidays.ics. Toggling the "Offline Support" setting of its properties definitely affects what is displayed on the Today Pane. For instance, I just enabled it, which caused the Today Pane to display properly (which is the first time this setting change caused this for me). The pane continued to display properly after I disabled it, but after shutting down and starting TB, the pane no longer displayed properly and it shows one event: from USHolidays, Easter Sunday (which will be in April, 2020). I believe this issue has been reported in another bug report. Disabling "Offline Support" causes Easter Sunday to disappear, but the pane still displays nothing.

Also, when the pane misbehaves, the "One Day Backward/Forward" buttons at the top of the pane do nothing other than change highlighting on a mouse event on them.

Starting TB 68.1.2 pre-release the first time it comes up ok. Restarting TB it comes up without the today pane being visible.
I do not see the 'RangeError: date value is not finite' in the error console anymore, but instead there is this error now:

TypeError: document.getElementById(...).isVisible is not a function today-pane.js:82:67
Not sure if this is the same problem though, or something unrelated.

TypeError: document.getElementById(...).isVisible is not a function today-pane.js:82:67

I saw that, too.

After a few stops and restarts of TB, the Today Pane has come up properly for me on each start. I am not an expert of any sort on the error console, having just discovered it in TB, but I do not see the errors reported by Christian and Jorg. I am using the 68.1.2 (64-bit) Linux package referenced above.

(In reply to Jorg K (GMT+2) from comment #51)

TypeError: document.getElementById(...).isVisible is not a function today-pane.js:82:67

I saw that, too.

That'll be fallout from backporting bug 1568723. I'll go there and post a fix.

With the pre-release of TB 68.1.2 and Cardbook installed, I get a 3-4 second delay between the time Thunderbird appears to the point where I see the Calendar tab. The Today Pane disappears as it did previously. There is one major difference--with the previous version, when I manually showed the Today Pane after a failure, it would NOT show me the "Today", "Tomorrow", and "Upcoming" labels, and it would show me incorrect events (from the past). With the pre-release version, when I manually show the Today Pane, it shows everything correctly.

Again, if I keep a composition window open, close the main window, and then open the main window again, it immediate shows properly.

Imported xpi... 2 errors (81 warnings not copied)

https://i.imgur.com/tj0jxvX.png

See comment #53 for the .isVisible. That will get fixed.

Still a lot of "fixes" for something that was "fixed" a week ago. Would integrating the calendar into Thunderbird make any of this easier? You'd think having it all integrated would smooth out some issues. Thanks for you hard work.

Worcester12345 I'm sick of you asking this. It's not helping. Please stop.

Maybe related to recent xpi (or not)... When I close Tbird with Today Pane open, and then reopen Tbird, the Today Pane momentarily flashes and then disappears.

Then clicking on the Today Pane (botton taskbar) twice is necessary to redisplay it.

This suggests to me that the Today Pane was active (but unseen) prior to the first click (which then "hid" it), and the second click made it appear.

Windows 10 64bit
Thunderbird win32 version 68.1.0
Provider for google calendar 68.0
Calendar tab closed.
Opened Today Pane - empty and date selector > no effect.
Exit Thunderbird with today Pane open.
Restart and Today Pane flashes and closes.
Need to reselect to open, but still void of info.

Info below captured via Error Console which was emptied prior to restarting Thunderbird.
statusPrivacy is null gdata-event-dialog.js:40
<anonymous> chrome://gdata-provider/content/gdata-event-dialog.js:40
loadScript resource:///modules/Overlays.jsm:485
load resource:///modules/Overlays.jsm:203
load resource:///modules/Overlays.jsm:40
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:185
forEach self-hosted:266
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:181
AsyncFunctionNext self-hosted:839
fetchOverlay resource:///modules/Overlays.jsm:447
load resource:///modules/Overlays.jsm:93
load resource:///modules/Overlays.jsm:40
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:185
forEach self-hosted:266
registerNonBootstrapped chrome://messenger/content/parent/ext-legacy.js:181
InterpretGeneratorResume self-hosted:1284
AsyncFunctionNext self-hosted:839
RangeError: date value is not finite in DateTimeFormat.format() minimonth.xml:727:70
TypeError: aPeriod.start is undefined agenda-listbox.js:261:35
setOccurrence chrome://calendar/content/agenda-listbox.js:261
addItemBefore chrome://calendar/content/agenda-listbox-utils.js:302
addItem chrome://calendar/content/agenda-listbox-utils.js:352
onGetResult chrome://calendar/content/agenda-listbox-utils.js:639
onGetResult jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:526
queueItems jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:757
getItems_ jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:938
getItems jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:668
postPone resource://calendar/modules/calUtils.jsm:249
getItems jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calStorageCalendar.js:667
funcName resource://calendar/calendar-js/calCachedCalendar.js:869
getItems jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:393
execute chrome://calendar/content/agenda-listbox-utils.js:689
refreshCalendarQuery chrome://calendar/content/agenda-listbox-utils.js:698
onLoad chrome://calendar/content/agenda-listbox-utils.js:904
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:44
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad resource://calendar/calendar-js/calCachedCalendar.js:78
execResponseFunc resource://calendar/calendar-js/calCachedCalendar.js:307
forEach self-hosted:266
emptyQueue resource://calendar/calendar-js/calCachedCalendar.js:312
onResult resource://calendar/calendar-js/calCachedCalendar.js:336
replayChangesOn jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}.xpi!/components/calGoogleCalendar.js:795
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 261}]'[JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 261}]' when calling method: [calIOperationListener::onGetResult] 3 calCompositeCalendar.js:526
Assert failed: [Exception... "[JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 261}]'[JavaScript Error: "aPeriod.start is undefined" {file: "chrome://calendar/content/agenda-listbox.js" line: 261}]' when calling method: [calIOperationListener::onGetResult]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D.xpi!/components/calCompositeCalendar.js :: onGetResult :: line 526" data: yes]
calUtils.jsm:147
TypeError: rangeStart is null calRecurrenceInfo.js:429:27
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 429}]'[JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 429}]' when calling method: [calIRecurrenceInfo::getOccurrences] calStorageCalendar.js:773
Assert failed: [Exception... "[JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 429}]'[JavaScript Error: "rangeStart is null" {file: "resource://calendar/calendar-js/calRecurrenceInfo.js" line: 429}]' when calling method: [calIRecurrenceInfo::getOccurrences]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D.xpi!/components/calStorageCalendar.js :: handleResultItem :: line 773" data: yes]
calUtils.jsm:147
ASSERT resource://calendar/modules/calUtils.jsm:147
getItems jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:399
execute chrome://calendar/content/agenda-listbox-utils.js:689
refreshCalendarQuery chrome://calendar/content/agenda-listbox-utils.js:698
onLoad chrome://calendar/content/agenda-listbox-utils.js:904
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad jar:file:///C:/Users/xxx/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi!/components/calCompositeCalendar.js:44
notify resource://calendar/modules/utils/calDataUtils.jsm:40
notify resource://calendar/modules/utils/calDataUtils.jsm:68
onLoad resource://calendar/calendar-js/calCachedCalendar.js:78
execResponseFunc resource://calendar/calendar-js/calCachedCalendar.js:307
forEach self-hosted:266
emptyQueue resource://calendar/calendar-js/calCachedCalendar.js:312
onResult resource://calendar/calendar-js/calCachedCalendar.js:336
replayChangesOn jar:file:///C:/Users/XXX/AppData/Roaming/Thunderbird/Profiles/yba3h802.default/extensions/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}.xpi!/components/calGoogleCalendar.js:795

I then disabled addon 'Provider for Google Calendar' and Today Pane is fully operational.
Now the Error console is full of a load of error relating to 'Piwik tracker' - so I presume due to disabled addon.

Further to comments above.
Restarted with 'Provider for Google Calendar' disabled and all ok.

Then enabled 'Provider for Google Calendar' and restarted to fully enable - still ok
Any subsequent restarting Thunderbird and Today Pane flashes and closes - up the creek as before and double clicks required to open an empty Today Pane.

Duplicate of this bug: 1583055

Thunderbird 68.1.2 packages hit both the openSUSE Tumbleweed and Leap 15.1 Mozilla repositories, and the Today Pane issue is fixed in both. Thank you, Geoff and Jorg (and others, I am sure) for your work on this.

I'm still encountering the exact same issues after updating to TB 68.1.2 (Lightning 68.1.2) on Windows 10 v.1903 build 18362.356. It is not fixed for Windows 10 :-(

TRUE. The problem appears not to be completely fixed in thunderbird 68.1.2
Using Windows7 64bit, Thunderbird and Lightning 68.1.2, ProviderForGoogleCalendar
The today-pane seems to work fine at first glance.

BUT a number of glitches unfortunately still appear in everyday use.
As many users, my PC usually runs several hours a day, then i put it in sleep mode and wake it up later, then put it so sleep mode again etc. etc. Usually Thunderbird stays open all the time.

Problem 1:
When the PC sleeps and is woken up AFTER 00:00 so when it is woken up on the next day, then the today-pane will NOT automatically move to the next day. This can become an issue and work should be done on this, at least allowing the user to set this behaviour.

Problem 2:
Future-day-appointments (e.g. for the next 7 days) will disappear completely, IF the today-pane is set to a past date, i.e. if the today-pane is set to yesterday instead of today.

So this does relate to Problem 1: if the PC wakes up after midnight, then all future appointments will disappear and no longer show in the today-pane. Clicking the today-circle will bring them back.

Thus the today-pane is unfortunately still unreliable and we rely more on having to use the calendar tab.

Please consider work on this.

please consider re-opening the bug report as, at least, not totally fixed.

I'm also encountering the exact same issue still using 68.1.2 on Linux. However, it seems to work reliably now when using "export LANG=C" before starting Thunderbird to force not loading my German localization.

I also see the issues described by Roland Schweiger, but these were already there for me since many releases, so I would guess this is a different (but still annoying) problem.

(In reply to Roland Schweiger from comment #67)

please consider re-opening the bug report as, at least, not totally fixed.

Please file a new bug, as these are different issues from the original.

Having now the same issue starting with 68.1.2 (after updating to ubuntu 19.10 from 19.04).

Maybe some hint: also the naming of the folders are wrong. I'm using Hungarian localization, and until now, inbox folder was called "Bejövő üzenetek", Sent "Elküldött üzenetek", etc., so everything in Hungarian. Now they are also in English.

(In reply to Jorg K (GMT+2) from comment #71)

(The folder name issue is fixed in TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/)

Not in my case:

https://www.dropbox.com/s/zyma5qf8r6sc7f4/Screenshot_20191102_102956.png?dl=0

kosal@kosal-pc:~$ apt-cache madison thunderbird
thunderbird | 1:68.1.2+build1-0ubuntu1 | http://hu.archive.ubuntu.com/ubuntu eoan/main amd64 Packages

Strange thing is to the today pane panel, when I disable lightning, restart thunderbird, enable, restart, then it works - until next start of thunderbird.

(Folder name issue should be fixed in 68.2.1, not 68.1.2. But this bug is about Lightning, right?)

(In reply to Jorg K (GMT+2) from comment #73)

(Folder name issue should be fixed in 68.2.1, not 68.1.2. But this bug is about Lightning, right?)

Yes, sorry - similar version numbers.

If the bug is in Lightning, I don't know, matter of fact is thunderbird and lightning don't work well together.

You need to log in before you can comment on or make changes to this bug.