Closed Bug 1583090 Opened 2 years ago Closed 1 year ago

distorted image (scaled version of part of image) when large image is partially visible when going back to page (restoring from bfcache)

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1580922
Tracking Status
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: dbaron, Unassigned)

References

(Regression, )

Details

(Keywords: regression, Whiteboard: [sci-exclude])

Attachments

(2 files)

Attached file about:support

This bugs happens for me with WebRender enabled, but if I force-disable WebRender the bug goes away.

Steps to reproduce:

  1. load https://www.nhc.noaa.gov/
  2. scroll down so the main map image is mostly offscreen (i.e., just the bottom hundred pixels or so is visible)
  3. click a link to one of the text statements (e.g., "Public Advisory #4", "Forecast Discussion #4", etc.)
  4. press the keyboard shortcut for back (e.g., Alt + <- on Linux)
  5. scroll up

Actual results:
after 4: distorted version of map image visible (part of the image is scaled up vertically)
after 5: distortion changes (still same underlying scaling, but different amounts)

Expected results: no distortion/scaling

I think if I look closely there's also some distortion visible during smooth scroll in some cases (maybe involving switching windows) even before the "go to a different page" step.

The result of mozregression gives this regression range, implicating bug 1568227.

Flags: needinfo?(jmuizelaar)
Attached image screenshot
OS: Linux → All
Priority: -- → P2
Hardware: x86_64 → All

This is likely a dup of 1580922

Flags: needinfo?(jmuizelaar)
See Also: → 1580922
Whiteboard: [sci-exclude]

David can you confirm this is now fixed in nightly? (bug 1580922 was resolved last week)

Flags: needinfo?(dbaron)

Yes, this looks fixed.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(dbaron)
Resolution: --- → DUPLICATE
Duplicate of bug: 1580922
You need to log in before you can comment on or make changes to this bug.