Closed Bug 1583565 Opened 2 years ago Closed 2 years ago

Crash in [@ java.lang.NullPointerException: at org.mozilla.gecko.media.GeckoHlsPlayer.getVideoInfo(GeckoHlsPlayer.java)]

Categories

(Core :: Audio/Video: Playback, defect, P2)

68 Branch
Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox-esr68 73+ fixed
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- fixed

People

(Reporter: marcia, Assigned: jhlin)

References

(Regression)

Details

(Keywords: crash, regression, regressionwindow-wanted)

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug is for crash report bp-1f49cad4-9275-4238-8f0b-eeac60190924.

Seen while looking at beta specific crashes - not a new regression but goes back to at least 68.0. Many mentions of crashing while browsing the reddit mobile site: https://mzl.la/2mulNoj.

here are some URLs:

Various flavors of Pixel running API 29 are in the mix. Perhaps we could try to reproduce this crash?

Java stack trace:

java.lang.NullPointerException
	at org.mozilla.gecko.media.GeckoHlsPlayer.getVideoInfo(GeckoHlsPlayer.java:717)
	at org.mozilla.gecko.media.GeckoHLSDemuxerWrapper.getVideoInfo(GeckoHLSDemuxerWrapper.java:104)
Flags: needinfo?(sorina.florean)
Component: Audio/Video → General
Product: Firefox for Android → GeckoView
Version: Trunk → 68 Branch

Please move back to Fennec if GeckoView is not the proper product/component for this bug.

There are some crashes in Focus, but the lion's share of crashes are Fennec. The Focus crashes are happening on Google Pixel devices as well.

Hello, I tried to reproduce this crash using the information from comment 0 but I wasn't able.

Devices used

  • Samsung Galaxy S8 (Android 9);
  • Google Pixel 2 (Android 9).

Build:

  • Firefox 68.1.1 - playstore.

If there is any information on this crash or additional help about this ticket, please let me know and I will help, thanks.

Flags: needinfo?(sorina.florean)

Just from looking at mercurial logs I think this bug 1552145 is a highly likely candidate for causing these problems.

This crash signature really spiked with the release of Fennec ESR 68.1 (September 3), but started ramping up in July 9 (either with the release of Fennec ESR 68.0 or the 68.1b beta builds in the Fennec Nightly and Beta channels).

Component: General → Audio/Video: Playback
Product: GeckoView → Core
Regressed by: 1552145

[Tracking Requested - why for this release]: fennec crash regression

John, how familiar are you with the HLS player code ?

Flags: needinfo?(jolin)
QA Whiteboard: [qa-regression-triage]

Nils, this is still pretty high volume. Is there anybody with cycles to look into it?

Flags: needinfo?(drno)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)

Nils, this is still pretty high volume. Is there anybody with cycles to look into it?

I'll check it.

Flags: needinfo?(jolin)
Flags: needinfo?(drno)
Assignee: nobody → jolin

The priority flag is not set for this bug.
:drno, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(drno)

Is this still something you might investigate? It's still high volume for Fennec and present in lower volume in Focus as well.

Flags: needinfo?(jolin)

(In reply to Liz Henry (:lizzard) from comment #11)

Is this still something you might investigate? It's still high volume for Fennec and present in lower volume in Focus as well.

Sorry for not updating the status for so long. Although unable to reproduce it locally, I did some code study and thought the symptom could be mitigated. I'll try to land the patch after completing bug 1592140.

Flags: needinfo?(jolin)
Flags: needinfo?(drno)
Priority: -- → P2
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/82fd8c769ea9
check if Java wrapper is still valid when updating media info. r=jya
Attachment #9115544 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

Please nominate this for ESR68 approval when you get a chance. It grafts cleanly as-landed.

Flags: needinfo?(jolin)

Comment on attachment 9115545 [details]
Bug 1583565 - check if Java wrapper is still valid when updating media info. r?jya

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This patch fixes crashes that were reported thousands of times.
  • User impact if declined: Occasional crashes when playing HLS contents.
  • Fix Landed on Version: 73
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It is just a minor change that checks for null pointers.
  • String or UUID changes made by this patch:
Flags: needinfo?(jolin)
Attachment #9115545 - Flags: approval-mozilla-esr68?

Comment on attachment 9115545 [details]
Bug 1583565 - check if Java wrapper is still valid when updating media info. r?jya

Fixes a frequent Fennec crash. Approved for 68.5b2.

Attachment #9115545 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+

Hi, i tried to reproduce the crash with Google Pixel 3a XL(Android 10) -api level 29 on an aarch64 build for version 68.3.0, but i was not able to reproduce it with the provided info from description and neither with info from comment 4. I also do not reproduce the crash on 68.5b2 on the same device on an aarch64.

We will wait a few days until marking as verified to see whether after someone reproduces it.

Yeah, I think we can just keep an eye on crash-stats for a bit to verify that the crash is gone.

You need to log in before you can comment on or make changes to this bug.