Closed Bug 1583616 Opened 5 months ago Closed 5 months ago

Suggestion for https://www.1001tracklists.com incorrectly prompts to search instead of visit

Categories

(Firefox :: Address Bar, defect, P1)

68 Branch
defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: yoasif, Assigned: mak)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Navigate to https://www.1001tracklists.com once, to establish autocomplete
  2. Type "1001" into the bar.

What happens:

Firefox autocompletes my entry to 1001tracklists.com/ but shows that it will search with my search engine for "1001" if I press enter.

Expected result:

Firefox will "visit" 1001tracklists.com/ instead of searching.

Reported on reddit:

https://www.reddit.com/r/firefox/comments/d8qp0q/why_is_autocomplete_behaving_unreliably_here/

9:23.63 INFO: No more inbound revisions, bisection finished.
9:23.63 INFO: Last good revision: 99a6defccec0caa61a65fddb3b9ea4b416133662
9:23.63 INFO: First bad revision: 3779a2682cc744ca22372a94ea3befe0fccf7029
9:23.63 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=99a6defccec0caa61a65fddb3b9ea4b416133662&tochange=3779a2682cc744ca22372a94ea3befe0fccf7029

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1537640

Marco, can you look into this regression caused by your patch in bug 1537640? Thanks!

Flags: needinfo?(mak77)
Summary: Autocomplete for https://www.1001tracklists.com incorrectly prompts to search instead of visit → Suggestion for https://www.1001tracklists.com incorrectly prompts to search instead of visit
Attached image c0WJJuI.png

Yes, I'll have a look at this.

Assignee: nobody → mak77
Status: NEW → ASSIGNED
Iteration: --- → 71.2 - Sept 16 - 29
Points: --- → 3
Flags: needinfo?(mak77)
Keywords: regression
Priority: -- → P1

The tokenizer currently thinks large numbers are "broken" IPs, thus it says they
can't be an origin. Unfortunately we use that same code path to identify possible
origin prefixes, and origins can start with a number. Thus we end up searching
rather than autofilling the origin.

For now fix the heuristic for IPs, in the future we may evaluate splitting these
code paths.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/2e7ce1c4f3f0
Some numbers are searched and not autofilled. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Unless you feel strongly about getting this into 70 release, I'd like to let this ride the trains with 71.

You need to log in before you can comment on or make changes to this bug.