Closed Bug 1583665 Opened 2 months ago Closed Last month

Cannot install addon when running Firefox in a full screen window

Categories

(Toolkit :: Add-ons Manager, defect, P5)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: Agi, Assigned: pbz)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

  • Maximize Firefox on MacOS (clicking on the green expand icon in the top left corner of the window)
  • Navigate to a.m.o
  • Try to install any addon

Expected:

  • Install door hanger appears

Actual:

  • Nothing happens (looks really broken to me)

In the console there's this:

Add-on installation is not allowed while in or before entering fullscreen mode.

which makes me think Firefox thinks it's running a website in fullscreen mode? but that's not true (the window is in fullscreen, but not the content, I still see the chrome).

Regressed by: 1412561

Unable to reproduce, do you have any further details?

Flags: needinfo?(agi)
Priority: -- → P2
No longer regressed by: 1412561

I can reproduce this. When I navigate to https://eviltrap.site/trap/fullscreen-addon/ and enter fullscreen via F11 shortcut I can't install addons (same console message). I suspect this is because the fullscreen check in AddonManager.jsm does not explicitly check for DOM fullscreen.
https://searchfox.org/mozilla-central/rev/23f836a71cfe961373c8bd0d0219ec60a64b3c8f/toolkit/mozapps/extensions/AddonManager.jsm#2303

The report here is on osx, not windows (I'm assuming you're windows due to F11). osx (at least) differentiates between content full screen (you don't see chrome/tabs/urlbar/etc) and chrome full screen (you have tabs/urlbar/etc). You cannot install addons in the former, you can install in the latter. This is by design and was implemented in bug 1412561. The fullscreen-addon page above enters content full screen mode.

If you cannot install in the latter, which is what I cannot reproduce (addons install for me just fine), then we need to understand why.

Thanks for looking at this Shane! I uploaded a video here: https://www.youtube.com/watch?v=Wf-htEZmI7Y

It's on the latest nightly as of today. I put Firefox in chrome full screen and try to click on "install" twice but nothing happens. I then put Firefox back into windowed mode an now installing works.

I'm on macOS mojave 10.14.6 if it helps.

Can you think of something more that can help you reproduce this bug?

Flags: needinfo?(agi)

Well, this is strange. I just tried this on latest release/beta/nightly and local build, I cannot reproduce on any of them.

Can you try this in a clean profile?

Flags: needinfo?(agi)

oh, I'm also on 10.14.6

I can't reproduce on a clean profile, so this is something specific to my profile. I wonder what that might be.

Flags: needinfo?(agi)

IDK, I don't see any prefs that seem to be involved but that would be my first guess.

IDK, I don't see any prefs that seem to be involved but that would be my first guess.

Leaving open to see if anything crops up to explain it, but otherwise doesn't seem to be a typical bug.

Type: defect → task
Priority: P2 → P5

I can reproduce this in my Nightly on OSX and I think we should track this as a regression.

The patch for bug 1412561 was only ment to block DOM fullscreen addon installations to prevent websites from abusing it.
I'll submit a patch to update the AddonManager code to check for DOM fullscreen only.

Assignee: nobody → pbz
Status: NEW → ASSIGNED

I'd really prefer understanding why a clean profile works fine before landing a patch. My year old default profile also does not have an issue with this.

Something seems to set the fullscreen attribute when the window is maximized. Not sure if that's intentional. I can't test this properly because I currently don't have access to a mac.
I'd like to land the patch soon, because the fullscreen issue also affects other platforms. If you want we can leave the bug open.

Clean profile is also affected, just tested this in a macOS vm on latest nightly.

Pushed by pzuhlcke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/96917f5eb072
Fixed AddonManager.jsm fullscreen check to only cancel installation for DOM fullscreen. r=johannh
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Hello,

Verified the fix using the latest Nightly (71.0a1/20191009213914) under MacOS Catalina 10.15.

After maximizing the browser (either by using the keyboard shortcut or by clicking the green expand icon), add-on installation is possible and carried out, confirming the fix.

Status: RESOLVED → VERIFIED

Is this something we should consider uplifting to ESR68?

Flags: needinfo?(pbz)

I wouldn't say it's critical. It would be low risk because the patch is very small.

Flags: needinfo?(pbz)

It doesn't seem terribly necessary, you can still install, just not in full screen.

Thanks for the insight.

You need to log in before you can comment on or make changes to this bug.