Closed Bug 1583860 Opened 2 months ago Closed 2 months ago

Intermittent js/src/jit-test/tests/bug1375074.js | ================== (code 66, args "--ion-eager --ion-check-range-analysis --ion-extra-checks --no-sse3") [1.2 s]

Categories

(Core :: JavaScript Engine, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: tcampbell)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: tcampbell [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=268363232&repo=try
Full log: https://queue.taskcluster.net/v1/task/Yf5_NmfLRV6111R2KzXssw/runs/0/artifacts/public/logs/live_backing.log


This is a tsan failure on try, but I believe the issue is related to Bug 1568245.

https://searchfox.org/mozilla-central/rev/45f30e1d19bde27bf07e47a0a5dd0962dd27ba18/js/src/jit/IonBuilder.cpp#1154

We should not be accessing JSScript::realm() directly from off-thread anymore. Can probably store the realm in the IonBuilder.

Assignee: nobody → tcampbell
Status: NEW → ASSIGNED
Priority: P5 → P1
Regressed by: 1568245

It is no longer safe to access JSScript::realm() off-thread. That is
okay because IonBuilder already has a CompileRealm for us to use.

Blocks: 1583816
Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c520d4083fa2
Don't access JSScript::realm() off-thread. r=jandem
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.