Closed Bug 1584336 Opened 4 months ago Closed 4 months ago

Inner width and alignment are off in the searchbar on Windows and Linux

Categories

(Firefox :: Search, defect, P2)

Desktop
Unspecified
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: harry, Assigned: harry)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1582396 +++

Bug 1582396 comment 9 includes screenshots of some unusual behaviour in the standalone search bar. The issues only exist on Linux and Windows and happen intermittently.

:harry, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(htwyford)
Flags: needinfo?(htwyford)
Regressed by: 1582396
Iteration: 71.2 - Sept 16 - 29 → 71.3 - Sept 30 - Oct 13
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f52bbe2a1903
Re-add the width attribute to the searchbar. r=dao
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9097390 [details]
Bug 1584336 - Re-add the width attribute to the searchbar. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: UI inconsistency in the searchbar
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See https://bugzilla.mozilla.org/show_bug.cgi?id=1582396#c11
  • List of other uplifts needed: Bug 1582396
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Minor CSS fixes
  • String changes made/needed:
Attachment #9097390 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Anca, does this fix the issue you noted in bug 1582396?

Flags: needinfo?(anca.soncutean)

Comment on attachment 9097390 [details]
Bug 1584336 - Re-add the width attribute to the searchbar. r?dao

Taking this for beta 12 along with the fix in bug 1582396; let's verify in beta.

Attachment #9097390 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Attached video screencast issue .mp4

I have no access to the provided beta treeherder build. Instead, note that, I've manage to still reproduce this issue with Nightly 71.0a1 (20191001213452) - treeherder build from comment 5 (see screencast) and with the latest official Nightly 71.0a1 build (20191003093956) on Ubuntu 18.04 x64.

Flags: needinfo?(anca.soncutean) → needinfo?(htwyford)

Anca, can you please clarify the STR here? Your STR in bug 1582396 comment 11 ends with the searchbar being dragged into the toolbar. Your video above has the searchbar in the overflow menu. I tried your bug 1582396 comment 11 STR and followed them up by dragging the search bar into the overflow menu once more, but still can't reproduce your video above.

Also I noted that on my Linux machine, the STR in bug 1582396 comment 11 originally led to the searchbar dropdown not being aligned with the searchbar itself (this has since been patched, in this bug). Has that issue been fixed?

Flags: needinfo?(htwyford) → needinfo?(anca.soncutean)

Sorry for creating a confusion here. The issue mentioned in comment 10, is reproducible inside the Overflow Menu (steps from https://bugzilla.mozilla.org/show_bug.cgi?id=1582396#c0), as well as in Toolbar ( if the Search Bar is directly drag inside the Toolbar, but only after the bug occurred inside the Overflow Menu). I will try to resume all the behaviors I've encountered so far (one of them I observed it intermittently today) - tested with Fx 70.0b12.

Search Bar in Overflow Menu:

  1. The Search bar dropdown doesn’t properly adjust its dimension when it is dragged inside the Overflow Menu
  • The width of the Search bar is now correctly adjusted inside the Overflow Menu (fixed in bug 1582396, no longer reproducible)
  1. [Intermittent] The content is not adjusting its size accordingly (see screenshot: https://drive.google.com/file/d/1hEKEKnDNz4wQ4f5HgkDHaE8T3eMqy79z/view?usp=sharing).
  • Still reproducible on my side, but I had to be very persistent to be able to triggered it, and as mentioned above, can be seen inside the Toolbar but only as a consequence of being triggered initial inside the Overflow Menu (and not at every attempt).

Search Bar in Toolbar:

  1. Inner width and alignment are off in the Search bar on Windows and Linux
  • The width of the Search bar is now correctly adjusted when it is dragged from the Overflow Menu to the Toolbar (fixed in bug 1584336, no longer reproducible)
  1. [Intermittent] The content is not adjusting its size accordingly, the “Change Search Settings” overlaps the one-click search engines icons (see screenshot: https://drive.google.com/file/d/1r0hbGjbtzp9rUu31l9hoVL9BuYZRaGNt/view?usp=sharing )

Should I considered both issues verified (1582396 and 1584336), since the targeted problem (dimension adjustment) was handled/verified? And the remaining intermittent problems will then be treated separately?

Flags: needinfo?(anca.soncutean) → needinfo?(htwyford)
Depends on: 1586861

Let's mark these bugs as verified. Both of the intermittent problems you describe have the same root cause. I've identified it in bug 1586861 and posted a fix.

Flags: needinfo?(htwyford)

This issue is no longer reproducible with Fx 71.0a1 (2019-10-07) and Fx 70.0b13 across platforms (Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64), the Search bar’s width/alignment is now correctly adjusted.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.