Closed Bug 1586861 Opened Last month Closed 29 days ago

SearchOneOffs.__rebuild is getting stale layout information

Categories

(Firefox :: Search, defect, P3)

defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.3 - Sept 30 - Oct 13
Tracking Status
firefox71 --- fixed

People

(Reporter: harry, Assigned: harry)

References

Details

Attachments

(1 file)

Currently, we use DOMUtils.getBoundsWithoutFlushing to determine if the width of the searchbar has changed and thus needs to be rebuilt. As outlined in bug 1584336 comment 12, there are two width-based layout bugs in the searchbar when it moves between the Overflow menu and the toolbar. They both have the same root cause, which is that DOMUtils.getBoundsWithoutFlushing is returning stale information and thus the searchbar popup uses old layout information.

I propose we use window.promiseDocumentFlushed to get the searchbar width instead.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/030df8fe65c7
Use promiseDocumentFlushed in SearchOneOffs.__rebuild. r=dao
Priority: -- → P3

Clearing ni since there’s a new revision on Phabricator for review.

Flags: needinfo?(htwyford)
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3297a09b231a
Use promiseDocumentFlushed in SearchOneOffs.__rebuild. r=dao
Status: ASSIGNED → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.