Closed Bug 1584487 Opened 5 months ago Closed 5 months ago

Themes do not work properly on Windows 7

Categories

(Thunderbird :: Theme, defect)

All
Windows 7
defect
Not set

Tracking

(thunderbird_esr6870+ fixed, thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: bsh, Assigned: Paenglab)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

After upgrading to 68.1, only the default theme works. The light or dark themes don't: there are no window borders, titlebars, minimize/maximize/close buttons, nothing, when opening messages or anything in a new window (I'm not using tabs).

Actual results:

No window borders visible, can't close windows. (If using the setting to open new windows for everything instead of using tabs.)

Expected results:

Windows should have their usual borders and stuff.

Those themes work. Please try with add-ons disabled, see Help menu.

(In reply to Jorg K (GMT+2) from comment #1)

Those themes work. Please try with add-ons disabled, see Help menu.

not for me... this is light theme, the only addon that works is disabled.
https://imgur.com/a/gQdYTaY

The Default, Light and Dark themes all work for me using Thunderbird 68.1.1 on both Windows and Linux. With and without "Show Title Bar" enabled in the Customize window. My preference is to show the title bar.

Could you try using safe mode? Use Help > Restart with Add-ons Disabled.

Flags: needinfo?(bsh)

Started my old PC with Win7 Aero...and yes, only on Aero the window has no window frame. restricting the rule to only the main window fixes it.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9096929 - Flags: review?(jorgk)
Attachment #9096929 - Flags: approval-comm-esr68?
Attachment #9096929 - Flags: approval-comm-beta?

No need to test. I found the issue.

Flags: needinfo?(bsh)

(In reply to Richard Marti (:Paenglab) from comment #5)

No need to test. I found the issue.

I couldn't have helped anyway, got so pissed I switched back to 60.9. this new version is just useless, soooo many bugs. :(

Comment on attachment 9096929 [details] [diff] [review]
1584487-main-window-transparency.patch

Sorry, I can't test this. My Win 7 box is 1800km away and hasn't been started in years. But I understand people hanging on to it since Win 10 made a bunch of hardware obsolete :-(
Attachment #9096929 - Flags: review?(jorgk)
Attachment #9096929 - Flags: review+
Attachment #9096929 - Flags: approval-comm-esr68?
Attachment #9096929 - Flags: approval-comm-esr68+
Attachment #9096929 - Flags: approval-comm-beta?
Attachment #9096929 - Flags: approval-comm-beta+
Keywords: checkin-needed
Component: Untriaged → Theme
OS: Unspecified → Windows 7
Hardware: Unspecified → All
Summary: Themes do not work properly → Themes do not work properly on Windows 7
Target Milestone: --- → Thunderbird 71.0

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8ce981f703f9
Apply Aero transparency rule only to the main window. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.