Closed Bug 1584697 Opened 5 months ago Closed 5 months ago

Accounts dialog visual glitches

Categories

(Thunderbird :: Account Manager, defect)

All
Windows
defect
Not set

Tracking

(thunderbird_esr6870+ fixed, thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 70+ fixed
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: teohad, Assigned: Paenglab)

Details

Attachments

(4 files, 1 obsolete file)

Attached image tb68_glitches.png (obsolete) —

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Clean new install of 68.1.0, also updated yesterday to 68.1.1. Windows Server 2016 or Win10. Old TBs don't suffer from the bugs here.
No add-ons (disabled Lightning), no custom themes, nothing.
Two aggravating and dangerous visual glitches in at least Accounts settings dialog.

Open the Accounts setup dialog window and select an account's Server settings page.

Actual results:

The Username field, while wide enough (visually), its content is cut off somewhere in the middle and the rest of the username is not visible and it can be misleading and wrongly identified as a wrong or incomplete username.
The same is true for the SMTP settings page where the informational fields are also "internally" cut off and longer contents are cut off somewhere in the middle of the field.

Some pages in the Accounts dialog cause horizontal scrollbar to appear while not really necessary as they reveal only empty space on the right.

Expected results:

The actual Username fields' contents should be visible as long as there is space in the field to its full width. The same for SMTP settings' server's info area.

Also pages like "Copies & Folders" should not have scrollbars.

Attachment #9097085 - Attachment is obsolete: true
Attached image tb68_glitches.png

Thanks for reporting. Yes, I can see the scrollbar in the "Copies & Folders", but I can't see a user name or SMTP details being cut off anywhere. Hold on, you mean the info1@test123test123.c where the "om" is missing, I got it. Can you please supply an additional screenshot for the cut off SMTP details.

Richard, can we please look into this.

Flags: needinfo?(richard.marti)

This is Windows only and has something to do with the .folderMenuItem (the menulists with the folder icons in them). I need to look why they use more space than we see. The same happens in filter create dialog when a folderMenuItem is visible. Then the scrollbar is shown.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows
Hardware: Unspecified → All
Attached image tb68_smtp.png

As seen in the screenshot for SMTP area, there is a "m" hidden from .com in the username.
Also, for Authentication Method it says: "Password, transmitted", where "insecurely is not visible - it can be seen if I click on the label/text itself and hit "End" button on the keyboard.

Thanks. Richard, more stuff to look at.

I've chosen folderMenus.css because wherever the icons are applied the dropmarker gets the image too (also when it doesn't show the image is reserves the space on the right which makes the usage of more space.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #9097111 - Flags: review?(jorgk)
Attachment #9097111 - Flags: approval-comm-esr68?
Attachment #9097111 - Flags: approval-comm-beta?

(In reply to Teodor from comment #4)

Created attachment 9097109 [details]
tb68_smtp.png

As seen in the screenshot for SMTP area, there is a "m" hidden from .com in the username.
Also, for Authentication Method it says: "Password, transmitted", where "insecurely is not visible - it can be seen if I click on the label/text itself and hit "End" button on the keyboard.

We do only one issue per bug. Please could you file a new bug for this issue?

Jorg K asked for this additional SMTP screenshot. Also I believe they are the same (or related) bug(s) - labels are cut off while there is plenty of space in the "parent" container.

We do only one issue per bug. Please could you file a new bug for this issue?

Let's do this here in a "part 2", OK? We're fixing visual issues in the AM, that's the bug ;-)

Okay, here is part 2 for the SMTP info field.

Attachment #9097135 - Flags: review?(jorgk)
Attachment #9097135 - Flags: approval-comm-esr68?
Attachment #9097135 - Flags: approval-comm-beta?

And comment #2, the missing "om"?

This would be part 3 ;-) , but I don't see this. Do you?

Not where I am right now using Android ;-) - try a long email address and switch panes. Hard to understand since there is enough space in the box.

Tried, don't see it.

Comment on attachment 9097111 [details] [diff] [review]
1584697-no-moz-image-region-dropmarker.patch

This miraculously gets rid of the horizontal scrollbar. The Swiss master at work :-)
Attachment #9097111 - Flags: review?(jorgk)
Attachment #9097111 - Flags: review+
Attachment #9097111 - Flags: approval-comm-esr68?
Attachment #9097111 - Flags: approval-comm-esr68+
Attachment #9097111 - Flags: approval-comm-beta?
Attachment #9097111 - Flags: approval-comm-beta+
Comment on attachment 9097135 [details] [diff] [review]
1584697-SMTP-field-width.patch

This works, too. I'll fix the typo in the commit message.
Attachment #9097135 - Flags: review?(jorgk)
Attachment #9097135 - Flags: review+
Attachment #9097135 - Flags: approval-comm-esr68?
Attachment #9097135 - Flags: approval-comm-esr68+
Attachment #9097135 - Flags: approval-comm-beta?
Attachment #9097135 - Flags: approval-comm-beta+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1c185647609b
Don't apply the -moz-image-region to the dropmarker to not virtually extent the menulist. r=jorgk
https://hg.mozilla.org/comm-central/rev/20f327d46fb9
Let the values in the serverInfoBox use the whole width. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.