Closed Bug 1584793 Opened 4 months ago Closed 4 months ago

Autocomplete richlistbox text invisible for in-content dark mode

Categories

(Firefox :: Preferences, defect, P1)

71 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: ke5trel, Assigned: ke5trel, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

STR:

  1. Enable dark mode.
  2. Go to about:preferences#home.
  3. Specify a Custom URL for the homepage and type the letter 'a'.

An autocomplete listing appears with white text on a white background.

Yeah, this is a pretty serious readability problem. Thanks for the patch Kestrel!

Priority: -- → P1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9450968c8fb
Add in-content colors to autocomplete richlistbox for dark mode r=dao
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

I did not manage to reproduce the issue following STR provided in the description on all OS platforms using Fx 71.0a1 (2019-09-27). If you can verify that the issue is fixed? http://archive.mozilla.org/pub/devedition/candidates/71.0b11-candidates/build1/

Flags: needinfo?(ke5trel)
You need to log in before you can comment on or make changes to this bug.