Closed Bug 1585096 Opened 1 year ago Closed 3 months ago

Clean up the code path separation caused by the devtools.responsive.browserUI.enabled pref

Categories

(DevTools :: Responsive Design Mode, task, P3)

task

Tracking

(firefox80 fixed)

RESOLVED FIXED
Firefox 80
Tracking Status
firefox80 --- fixed

People

(Reporter: gl, Assigned: mtigley)

References

(Blocks 2 open bugs)

Details

(Whiteboard: fission-rdm-reserve)

Attachments

(3 files)

No description provided.
Priority: P3 → P2
Whiteboard: fission-rdm-mvp
Priority: P2 → P3
Whiteboard: fission-rdm-mvp → fission-rdm-reserve
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Summary: Clean up the code path separation caused by the devtools.responsive.browserUI.enabled pref in ui.js → Clean up the code path separation caused by the devtools.responsive.browserUI.enabled pref
Depends on: 1648616
No longer depends on: 1648616
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f2a450ccf51
Cleanup code path separation caused by browserUI pref in index.js, manager.js, and ui.js r=gl
https://hg.mozilla.org/integration/autoland/rev/eaacbe5e997a
Cleanup code path separation in RDM's React components. r=gl
https://hg.mozilla.org/integration/autoland/rev/51c34a326c00
Cleanup code path separation in RDM's screenshot action. r=gl
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
You need to log in before you can comment on or make changes to this bug.