Closed Bug 1585320 Opened 11 months ago Closed 10 months ago

NetMonitor blocking - Row for Enable Request blocking / actions should be fixed and not scrollable

Categories

(DevTools :: Netmonitor, enhancement, P3)

71 Branch
enhancement

Tracking

(firefox70 unaffected, firefox71 verified)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: cfogel, Assigned: davidwalsh)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Affected versions

  • 71.0a1 (2019-09-29)

Affected platforms

  • all available;

Steps to reproduce
devtools.netmonitor.features.requestBlocking set on true

  1. Launch Firefox, access any webpage, open the DevTools inspector - Network tab;
  2. Block any request so that the Blocking UI is enabled;
  3. Add multiple filters in the Request Blocking section so that the scroll bar is enabled for them;
  4. Scroll inside the section;

Expected result / Enchancement suggestion

  • as per the actions section in the Search subSection, the row with Enable Request blocking could be fixed and not scrolled with the filters;
  • having multiple requests blocked would force the user to scroll back up if a check for all toggled(on/off) would be intended;

Actual result

  • the row is scrollable;

Regression range

  • not a regression, only visible after implementation of bug 1580728;

Additional notes

  • attached screenshot with the issue;

Thanks for the report!
Honza

Has STR: --- → yes
Priority: -- → P3

Thank you for the report Cristian! There is no screenshot in this bug and on my Mac I don't see scrolling. Is this a Windows issue? Any more information would be super helpful!

Flags: needinfo?(cristian.fogel)

Didn't double check after posting, see the attached gif.

Yes, this can be noticed on macOS as well.
To notice this behavior you need to block requests until the section becomes scrollable or adjust the height of the tool.

Flags: needinfo?(cristian.fogel)
Assignee: nobody → dwalsh
Status: NEW → ASSIGNED
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d55564fd2d44
Always show request blocking top bar r=Honza
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Marking as verified with the curent nighlty build 72.0a1 (2019-10-22).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.