Closed Bug 1585531 Opened 5 months ago Closed 5 months ago

Perma Tier 2 fission toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | TypeError: doc is null - Should not throw any errors

Categories

(Toolkit :: Password Manager, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: annyG)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=269365274&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/TtVC6Av0QPSPmmXGNexchw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-10-02T04:53:22.072Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking for echoed password
[task 2019-10-02T04:53:22.072Z] 04:53:22 INFO - add_task | Leaving test test_iframe
[task 2019-10-02T04:53:22.072Z] 04:53:22 INFO - add_task | Entering test test_schemeUpgrade
[task 2019-10-02T04:53:22.073Z] 04:53:22 INFO - checkPromptState: Expected: https://example.com is requesting your username and password. WARNING: Your password will not be sent to the website you are currently visiting!
[task 2019-10-02T04:53:22.073Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking expected message
[task 2019-10-02T04:53:22.073Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking title visibility
[task 2019-10-02T04:53:22.073Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking textbox visibility
[task 2019-10-02T04:53:22.073Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking passbox visibility
[task 2019-10-02T04:53:22.074Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking checkbox visibility
[task 2019-10-02T04:53:22.074Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking checkbox label
[task 2019-10-02T04:53:22.074Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking checkbox checked
[task 2019-10-02T04:53:22.074Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking expected icon CSS class
[task 2019-10-02T04:53:22.074Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking textbox value
[task 2019-10-02T04:53:22.074Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking passbox value
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | checking button0 default
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | checking button1 default
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | checking button2 default
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | Checking focused element
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - Buffered messages finished
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | TypeError: doc is null - Should not throw any errors
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - checkEchoedAuthInfo@http://mochi.test:8888/tests/toolkit/components/prompts/test/prompt_common.js:192:18
[task 2019-10-02T04:53:22.075Z] 04:53:22 INFO - test_schemeUpgrade@http://mochi.test:8888/tests/toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html:284:22
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - asyncnextTick/<@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:1795:34
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - async
nextTick@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:1811:11
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - setTimeout handler*SimpleTest_setTimeoutShim@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - add_task@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:1755:17
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - @http://mochi.test:8888/tests/toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html:74:9
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - GECKO(8756) | MEMORY STAT | vsize 2103772MB | vsizeMaxContiguous 76281582MB | residentFast 94MB | heapAllocated 17MB
[task 2019-10-02T04:53:22.076Z] 04:53:22 INFO - TEST-OK | toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | took 1274ms

Flags: needinfo?(kmaglione+bmo)
Regressed by: 1582531
Summary: Perma fission toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | TypeError: doc is null - Should not throw any errors → Perma Tier 2 fission toolkit/components/passwordmgr/test/mochitest/test_prompt_http.html | TypeError: doc is null - Should not throw any errors

This was re-skipped in bug 1582531 and no new failures since Oct 4.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → FIXED
Assignee: nobody → agakhokidze
Target Milestone: --- → mozilla71

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.