Closed Bug 1585539 Opened 3 years ago Closed 3 years ago

Deprecate GenericCountView-based datasets

Categories

(Data Platform and Tools Graveyard :: Datasets: Client Count, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: akomar, Assigned: akomar)

References

Details

Attachments

(3 files)

We'll deprecate the following datasets:

  • client_count
  • client_count_daily
  • core_client_count

They have good GCP-native replacements and use HLL implementation incompatible with BigQuery.

Replacements are:

Duplicate of this bug: 1571794
Duplicate of this bug: 1571806

desktop_dau depends on client_count_daily.
It seems to be undocumented and redundant after we got exact MAU tables.

We have just one scheduled query that uses desktop_dau.
Peter - you're the owner of this query, can you migrate it to use one of exact MAU tables or unschedule if you no longer need it?

Daniel - I'm going to submit a PR that decommissions both these datasets. Let me know if there might be any use cases I missed.

there's also desktop_active_dau which depends on clients_daily_v6 and should be decomissioned.

See Also: → 1581996
Duplicate of this bug: 1543518
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Product: Data Platform and Tools → Data Platform and Tools Graveyard
You need to log in before you can comment on or make changes to this bug.